How to change temp sensor reporting interval

Hello

I need for my automation much more frequent temp sensor readings.
I have Zigbee sonoff device but when Im trying to change that in config Ive got below error

Any idea how this can be changed ?

Battery powered devices will only wake up and send the change when it happens. There is no point in them sending the same data over and over again. If it is 21 degrees for 2 hours it’s 21 degrees. There is no need to send it until it changes.

I my project I need to examine temp every 5 mins, even small changes. Currently Ive got update ~30 mins
Also how do I know if sensor is working at all?
If I understood you correctly if temp will not change it might not be sending update eg week

I know, from experience, that my Aqara sensors only report in on a change - this allows the batteries to last for years. I’m not sure what you would gain going to every 5 minutes if there is no change.

To check if a sensor is working simply warm it up with your hand (if possible) or introduce a heat source/cold air.

Z2M will show you when it last communicated :

Looking at yours you don’t have last seen and availability enabled like mine :

Enable last seen in Settings/Advanced in Z2M :

image

And availability check - either use advanced or simple. I use simple :slight_smile:

image

4 Likes

Thanks a lot for this tip - I didnt know about this option
Changed as advised - and looks better now!