How to connect? Web interface, SSH and Samba not working!

I reseted my router, and my Xiomi lights. After doing this and restarting home assistant the web interface just will not come up.
Also I can not connect via SSH, I get

ssh: connect to host hassio.local port 22: Connection refused

In addition this, even the Samba does not work… I have no way to connect to the Hass.io!? Any help?

I have a huntch that that the problem might be in the configuration.yaml file regarding the light settings I have set to the Milight. But how am I supposed to fix this, when I can’t even connect to the damn thing.

try the IP address instead of the bonjour name

I tried, still can’t connect

ssh [email protected]

Do you have a fixed IP assigned to your HA server? If not it may have changed with the router reset. Check your router for the current IP.

If you think a part of your config if preventing startup add a # before the relevant lines. This will cause HA to ignore them and hopefully start. Then you can troubleshoot a narrow band of code.

The ip is correct. I just get ssh connection refused…
Yes, I would do that, if I could get to the config… Is there any way to edit the config file by connecting the SD to computer?

UPDATE / SOLUTION: I used ExtFS soft on my mac to access the config files in the SD card. Then I used Etcher to do a fresh install of Hass.io and copied my configuration files there.

So yeahh… All in all, I got it working but my faith in the stability of Hass.io and homeassistant in general has been shaken. Reconfiguring everything is a pain.

2 Likes

So it happened again… No way to connect to Hassio. The things I did before this happened:

  1. Edit the configuration.yaml (Added a MQTT switch)
  2. Validate that the config file was indeed right
  3. In the settings; restart homeassistant
  4. This seemed like nothing was happenning so I login via SSH and did a host restart

After this, the Hassio refuses to connect at all.
Tried even plugin in a HDMI, but I guess it is not even supported.

There is definetely something wrong but I’ve got no idea what…

1 Like

If you are running this on a Pi, make sure your power supply is up to the job.

I have a 2 amp one, should be enough.

I just did a complete wipe of my old 0.35 and got 0.60 in with hass.io today, and I just encountered the same issue as you.

Does anyone have any idea how to connect and fix a problem if configuration.yaml is invalid (even though validating it through Settings worked)?

I’ll probably go back to the latest AIO version again if this happens again to at least have an OS in the background, even though hass.io seems very nice to work with otherwise.

1 Like

SSH into it. You turned on the samba add-on right?

In a way it’s comforting to know that I am not the only one with this problem.
I’ve posted a solution up there. You can edit the configuration.yaml file by pluggin the sd card into your computer. The file path is: resin-data/resin.data/homeassistant

2 Likes

Ah cheers! I actually missed that. I just wiped it and started over, but I won’t be doing that every time so it’s good to know that it’s actually possible to get to the files. Oh well, gotta have something to do when you’re off work for a whole week! :wink:

+1

I was on .59, when I tried to upgrade it to .60 i returned me an error few times so I tried to restart it, after restarting I can ping it:
#[2018-01-02 10:38:54 CST][Slaw@~]$ ping hassio.local PING hassio.local (192.168.2.100): 56 data bytes 64 bytes from 192.168.2.100: icmp_seq=0 ttl=64 time=4.957 ms 64 bytes from 192.168.2.100: icmp_seq=1 ttl=64 time=4.901 ms 64 bytes from 192.168.2.100: icmp_seq=2 ttl=64 time=6.257 ms ^C --- hassio.local ping statistics --- 3 packets transmitted, 3 packets received, 0.0% packet loss round-trip min/avg/max/stddev = 4.901/5.372/6.257/0.626 ms

I can’t ssh:
`#[2018-01-02 10:39:01 CST][Slaw@~]$ ssh hassio.local
ssh: connect to host hassio.local port 22: Connection refused

#[2018-01-02 10:39:11 CST][Slaw@~]$ ssh 192.168.2.100
ssh: connect to host 192.168.2.100 port 22: Connection refused`

There’s nothing
`#[2018-01-02 10:39:04 CST][Slaw@~]$ nmap hassio.local

Starting Nmap 7.60 ( https://nmap.org ) at 2018-01-02 10:39 CST
Nmap scan report for hassio.local (192.168.2.100)
Host is up (0.0075s latency).
Other addresses for hassio.local (not scanned): 192.168.2.21
rDNS record for 192.168.2.100: Raspberry
Not shown: 995 closed ports
PORT STATE SERVICE
80/tcp open http
110/tcp open pop3
143/tcp open imap
993/tcp open imaps
995/tcp open pop3s`

Looks like I’ll need to reinstall it :confused:

Cheers,
Slaw

Oh happy days… It happened again. 3:rd reinstall of homeassistant in a month.

Do you guys have the homebridge addon installed? I am wondering if it could it be behind all this? I didn’t have this bug before I installed homebridge.

EDIT: 01.02.2018 And again :slight_smile: So the homebridge addon wasn’t the issue. Now trying a different power supply and after that I am migrating to the all-in-on installer if it would be more stable.

1 Like

And again. :slight_smile: This time I was able to connect via ssh and samba, but homeassistant logs told that I have some Json corruption problems in main.py. I am starting to feel that the problem could be the sd card, so I changed that and now I am installing hassbian. Eliminating possible causes.

Also the possibilities to do any troubleshooting in Hassio seem quite limited. It’s not even possible to do a downgrade or reinstall of homeassistant is it?

EDIT: And again and again. Happened on Hassbian also, so I assume the problem is ether the sd card, power supply or the pi itself.

I just experienced something like this. I was on the latest version a few days ago when it suddenly stopped working. No web, ssh, or anything else.
I’m using a good power supply with a SD card.
Next up will try with a USB stick instead of the SD card.
Did anyone else solve their problem?

I’m just now having the same issue.

I’m able to SSH to root on port 22222 but connection refused on 22…
Been at this since yesterday and unable to figure it out…

This is happening consistently with me as well. A reboot caused it last time a month ago or so, this time it was a power outage, the power eventually came on, but no Hassio. It wasn’t the network as I changed those settings to wifi just in case to no avail.

It is going to be a real pita if I have to juggle two sd cards for reinstalls when it decides to lose its ability to ssh or samba on random reboots. It’s floating on the network according to my LAN, but not allowing entry; there must be some fix to this by plugging in the SD card into the computer and adjusting a file… I wish I knew which one?

I enabled my Mac to mount the file system, and I created snapshots with the Hassio web interface when it was working, but I don’t know how to restore like that or where to find the snapshots if you can’t get the thing booted in the first place. Help would be welcome.

Same issue here…

I’m having this issue as well. no web/ssh/samba, but HA was working (scripts and automation were turning on and off). Suddenly the web UI started working again but I still can’t ssh or samba. I’ll try to update via the web interface to 0.65 and see if it starts working again.

edit : Oh well, it partially worked. Updating it restored my samba access, or it was a reboot of the samba module, I did both back to back. Still no ssh yet