How to disable auto update HA on Hassbian start?

Hello

how to disable auto update on HA start?

Jul 29 18:46:32 rasp-camera hass[419]: 2018-07-29 18:46:32 INFO (MainThread) [homeassistant.setup] Setting up logger
Jul 29 18:46:44 rasp-camera hassbian-config[495]: You are using pip version 10.0.1, however version 18.0 is available.
Jul 29 18:46:44 rasp-camera hassbian-config[495]: You should consider upgrading via the 'pip install --upgrade pip' command.
Jul 29 18:46:46 rasp-camera hassbian-config[495]: Changing to the homeassistant user
Jul 29 18:46:46 rasp-camera hassbian-config[495]: Changing to Home Assistant venv
Jul 29 18:46:46 rasp-camera hassbian-config[495]: Upgrading Home Assistant
Jul 29 18:47:06 rasp-camera hassbian-config[495]: Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Jul 29 18:47:38 rasp-camera hassbian-config[495]: Requirement already up-to-date: setuptools in /srv/homeassistant/lib/python3.5/site-packages (40.0.0)
Jul 29 18:47:42 rasp-camera hassbian-config[495]: Requirement already up-to-date: wheel in /srv/homeassistant/lib/python3.5/site-packages (0.31.1)
Jul 29 18:47:59 rasp-camera hassbian-config[495]: You are using pip version 10.0.1, however version 18.0 is available.
Jul 29 18:47:59 rasp-camera hassbian-config[495]: You should consider upgrading via the 'pip install --upgrade pip' command.
Jul 29 18:48:20 rasp-camera hassbian-config[495]: Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Jul 29 18:48:20 rasp-camera hassbian-config[495]: Collecting homeassistant==0.74.2

i want use HA 0.72.1 because i want that DHT sensor work…
On every restart, i lost that version

What command are you using to to start HA? Or is this just when you install it?

sudo systemctl restart [email protected]
sudo systemctl start [email protected]

Strange, my version does not do that. Can you do

cat /etc/systemd/system/[email protected]

this installation use Hass.io for RPi, instead for the installation that i installed HA manually, i do not have any problem.

configuration.yaml does not have update command enabled, i don’t understand

#
# Service file for systems with systemd to run Home Assistant as the homeassistant user.
#

[Unit]
Description=Home Assistant for %i
After=network.target

[Service]
Type=simple
User=%i
ExecStart=/srv/homeassistant/bin/hass
SendSIGKILL=no

[Install]
WantedBy=multi-user.target

This is certainly not hassio, it is hassbian see

I seem to remember that someone saying that hassbian updated itself on first run, but the systemd script shouldn’t do this from then on. Are you sure this happens again after you have downgraded HA and restarted?

hassbian right

ok the problem in on RPi boot, not at HA start.

I’m sorry

1 Like

Where i can fins the command that make auto update ha on system startup?

It’s not hiding in /etc/crontab ?
using @reboot

i cant find here

SHELL=/bin/sh
PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin

# m h dom mon dow user  command
17 *    * * *   root    cd / && run-parts --report /etc/cron.hourly
25 6    * * *   root    test -x /usr/sbin/anacron || ( cd / && run-parts --report /etc/cron.daily )
47 6    * * 7   root    test -x /usr/sbin/anacron || ( cd / && run-parts --report /etc/cron.weekly )
52 6    1 * *   root    test -x /usr/sbin/anacron || ( cd / && run-parts --report /etc/cron.monthly )

It looks, from the first trace, like that the script being run is the one in /opt/hassbian/suites/homeassistant.sh. Not sure what causes that to be run on first boot though.

Edit:

Got it, its a systemd service at /etc/systemd/system/install_homeassistant.service

Yes!

it was easy … hahah
thank you!
i disable this service

thank you man

1 Like

It is interesting, because it looks like it will upgrade my system when I reboot, and I have never noticed that - but I guess I don’t reboot very often

pi@hassbian:/etc/systemd/system 
$ uptime
 17:21:17 up 115 days, 23:31,  1 user,  load average: 0.84, 0.53, 0.47

I had the update service disabled yet when I rebooted my Pi it did an update. This broke a few things so I don’t want to auto update. I ended up taking a more blunt approach by:

 chmod -x /usr/local/bin/hassbian-config

So far so good. I have no idea how it upgraded in the first place but hopefully this will solve things for the time being. When I’m ready to upgrade I just do:

$ sudo -u homeassistant -H -s
$ source /srv/homeassistant/bin/activate
$ pip3 install --upgrade homeassistant