How to force the renaming of a device in Z2M?

I had a Zigbee switch enrolled in Zigbee2MQTT, with the friendly name my_switch. This name was pushed to HA and used in automations.

Then one day the switch stopped working. It still had a good battery but Z2M saw it as unavailable.

I then tried to remove it from Z2M, but this failed. I went for the nuclear strike and forced the removal. The device was gone.

A few days later I tried to re-enroll the drive and, behold, it immediately got registered. I then wanted to change its friendly name to my_switch with the push to HA (to restore the previous functionality out of the box). This failed because the name is known (in Z2M I presume). I also tried without pushing to HA (same thing - thus my assumption that it is somewhere in Z2M)

my_switch is not shown anywhere on the Z2M interface (because the device with this name was force-deleted) so it must be a leftover somewhere.

My question: what can I do to definitely get rid of the previous name so that I can register a device and use that friendly name again?

Right after typing my question I realized that the name may be in configuration.yaml (which is also updated by the frontend).

This was the case. So I

  • stopped Z2M
  • removed the entry from configuration.yaml
  • restarted Z2M
  • changed the friendly name back to my_switch (with the option to push to HA)

and all functionality was restored (HA reacts to the button again though the automation)

1 Like