How to Program a Remote ZWave Controller to Turn On A Light?

I’ve paired a Go Control WA00Z-1 two-button controller to HA, but I cannot figure out how to program the buttons to turn on and off a light (or open and close a blind). VeraPlus, for all it’s limitations, could do this easily. But… I know the fault lies with me; I just don’t understand it. Any pointers are appreciated.

You need to listen for the “zwave_js_value_notification” events for the different button presses in the dev tools->events tab.

then use the data there in your automations.

here is one I use for the exact switch you are using to control a lamp bulb:

  - alias: LC MBR Lamp Toggle with Scene Switch
    trigger:
      - platform: event
        event_type: zwave_js_value_notification
        event_data:
          node_id: 35
          label: Scene 001
          value: KeyHeldDown
    action:
      - service: script.turn_on
        data:
          entity_id: >
            {% if is_state('light.mbr_lamp', 'on') %}
              script.lc_mbr_lamp_control_off
            {% else %}
              script.lc_mbr_lamp_control_on
            {% endif %}

Thanks for the tip…I’m working my way through it. I’ll report back.

The automation test works, but pressing the remote button does nothing. Not sure how to troubleshoot it.
alias: Remote Close Blind 1
description: ‘Button 1 Held Down Closes Blind 1’
trigger:

  • platform: event
    event_type: zwave_js_value_notification
    event_data:
    node_id: 12
    label: scene 001
    value: KeyHeldDown
    condition: []
    action:
  • device_id: a733282bf9240a73eecaf587d039d4d9
    domain: cover
    entity_id: cover.blinds_1
    type: set_position
    position: 100
    mode: single

Do you see the events in the events tab when you press and hold the button? (short press and long press are two different events)

Also please get used to properly formatting your code blocks. put three back ticks (```) on the line before and after the code block.

1 Like

Yes, while listening to the event, I see the info from the device appear. That’s where I get the scene, label and value.

alias: Remote Open Blind 1
description: ''
trigger:
  - platform: event
    event_type: zwave_js_value_notification
    event_data:
      node_id: 12
      label: scene 001
      value: KeyPressed
condition: []
action:
  - device_id: a733282bf9240a73eecaf587d039d4d9
    domain: cover
    entity_id: cover.blinds_1
    type: set_position
    position: 70
mode: single```

Hmmm…then I guess I’m not sure what could be going wrong. :thinking:

It is a fairly simple automation and you said you already tested the action so that should be correct. And you are seeing the events in HA so that should be good as well.

I guess I would recommend adding an “id:” to the automation so you can see the automation trace to see if there is something it will point you to why it’s failing.

Should be label: Scene 001. It is case sensitive.

I’ve tried it now on two different remote brands. I can see the events in HA. The actions work in the automation test, but they’re just not working together.
How/where do I add an “id”?

Finally success. I tried rebuilding the automation from scratch and discovered new trigger options that were not present before. Suddenly, it all works. Thanks for the tip about event listening. That helped me identify the corresponding button scenes.

1 Like

What were those?

If you create an automation with the UI it gets added automatically.

I didn’t see the id in the code you posted so I assume you created it manually.

if so then you just add “id:” and then a unique identifier. it can be anything. I usually use the entity id of the automation without the domain:

alias: Remote Open Blind 1
description: ''
id: lkgjhlk_bnlklkjnl  #<-- here
trigger:
  - platform: event
    event_type: zwave_js_value_notification
    event_data:
      node_id: 12
      label: scene 001
      value: KeyPressed
condition: []
action:
  - device_id: a733282bf9240a73eecaf587d039d4d9
    domain: cover
    entity_id: cover.blinds_1
    type: set_position
    position: 70
mode: single

good catch. missed that.