How to properly setup configuration.yaml for ios devices

The documentation is pretty confusing as to what is needed. Is setting up device_tracker enough?

  - platform: icloud
    username: !secret icloud_username
    account_name: !secret icloud_username
    password: !secret icloud_password

What about the following? No matter what I do, notify does not appear in the developer services.


ios: is still needed as is notify:

@robbiet480 told me if you have no notify in services something is seriously wrong. I used a scorched earth purge of ios in my files to fix this last time.

Basically removing all iOS entities from entity registry (GUI under configuration)
removing the ios integration
removing ios: from config yaml
resetting the data in the ios app and then deleting the app
STOPPING home assistant via ssh and then editing the core files in .storage to get rid of ANY ios device. deleting ios devices from known_devices.yaml, deleting ios.conf
RESTARTING home assistant from ssh
verifying that there is NOTHING related to iOS in entity registry, no integration and no ios devices in .storage files
Then add back the ios app and login which will create everything again. Edit ios: back into config yaml and restart. This should also add back the integration (if so, you should restart after the first time you see the integration added).
Then check if you have a notify.notify in the services in dev-tools.

The above never fails for me. SOme people say it didn’t work for them but TBH I suspect they skipped a few steps/step and didn’t take the time to make sure it was really gone before readding etc.

Can you share with me your configuration.yaml settings for anything and everything ios related?

For ios, device_tracker, notify, discovery and anything else?

It would be greatly appreciated.

I also noticed that I have no ios.conf file. Were should that be located?

my ios looks like this: I have no idea if this is correct or not. It’s old.

  discovery: true
  username: !secret icloud_username
  password: !secret icloud_password

I only have this:


So where do you put in your icloud info? Is that for device_tracker only?

I don’t use icloud anywhere in Home Assistant

And your devices show up on the map?

What about the platform?

Yes they show on the map.
I DON’T use icloud platform at all…

If you aren’t using the platform, how do your devices appear? From the HA ios app itself?

Yes… the app sends locations to home assistant

can someone tell me how to change the update rate?
I believe that this is account_fetch_interval: 0.25.
that should definitely have to be changed in the configuration.yaml, right?
However, I don’t know how to do this?