How to properly turn add mac suffix to true and OTA updates?

Hello,
I triyed to turn “add mac suffix” to “true” but I don’t understand how to make OTA available with this setting on.

As I turn this to true I can’t see the device online in esphome (while it is connected as integration and is working properly).

Am I missing something?

I also tryied to rename the device adding the mac address in “devicename”, with no success and renaming the yaml file with the same devicename.

thanks

Nobody using this new feature yet?

People are, but probably not together with the dashboard, as they target different usecases.

The problem you have is that the dashboard doesn’t support name_add_mac_suffix, so it tries to connect to the device name without the MAC suffix, which of course doesn’t work. You can either OTA from the command line using the --device option, or try to set the use_address option under wifi to the devicename with the suffix (but that requires you to modify the YAML file for each device, so it kind of defeats the point of name_add_mac_suffix).

Oh thank you for clarifing it. Unfortunately the documentation was not so detailed and I was trying every possible combination :slightly_smiling_face:

So unless this feature will be implemented into the dashboard it will be pointless at least for my noobs needs :slightly_smiling_face:

Thank you for answer!

Do you think that this issue was resolved with today esphome release?

1.20