How to remove the warning info showing up when to call hass?

There are three python versions in my os.

debian@debian:~$ python --version
Python 2.7.16
debian@debian:~$ python3 --version
Python 3.7.3
debian@debian:~$ python3.9 --version
Python 3.9.6

I install homeassistant this way:

python3.9 -m pip install homeassistant

And set environment variable for hass.

 hass
2021-07-14 09:26:57 WARNING (MainThread) [homeassistant.bootstrap] Support for the running Python version 3.7.3 is deprecated and will be removed in the first release after December 7, 2020. Please upgrade Python to 3.8.0 or higher.

How to ban this warning info output by hass?

have you made an alias for python3 that is still pointing to python 3.7 ? You just need the python3 alias to point to python 3.9.6… it’s a simple command from memory - google should be able to help…

I can’t change hass action!

vim  .bashrc
alias python3="/usr/local/bin/python3.9"

source .bashrc

Now check :