Https grafana panel does not show up

Still struggling to get a grafana panel in my dashboard.
In my browser the url displays the correct panel, but in a iframe it does not.

  - title: energie
    panel: true
    cards:
      -  type: iframe
         url: https://10.0.0.31:3050/d/t5FdhVIWk/enrgie-per-uur?orgId=1&from=1562504387479&to=1562525987479&panelId=2&fullscreen
         aspect_ratio: 75%

The message in the dashboard says 10.0.0.xx refuses to connect
An in developers tool of google chrome it says : Refused to display ‘https://10.0.0.XX:XXXX/login’ in a frame because it set ‘X-Frame-Options’ to ‘deny’.

Just ran into this problem. With the newer versions of Grafana they have disallowed embedded graphs in frames by default. To allow you have to add allow_embedding = true in the Grafana configuration.

Here are a few links:
GitHub Issue
Grafana Upgrading doc
Grafana Configuration doc

1 Like

Hello, I have problem with adding grafana to iframe. I already changed allow_embedding to true but when I try to hit grafana in HA then I got “…in a frame because it set ‘X-Frame-Options’ to ‘deny’.”
I ran HA and grafana in docker.

What should be done unordered to use grafana from outside and inside home network from homeassistant as panel_iframe?
Thanks

With docker-compose, in my yaml file for my grafana service I used this to get the iframe working:

    environment:
      GF_SECURITY_ALLOW_EMBEDDING: 'true'