Hue bridge discovered but not registering

My hue IP changed and I needed to remove the old IP and add the new one in. So, I removed the phue.conf and updated the IP in my configuration.yaml

HA shows it as discovered, but when I click to configure it, and press the button on my hue bridge, it does nothing. When I click ‘submit’ it fails.

Things I’ve tried:
Remove all traces of hue from HA config code and start over with hue
Replace only bridge IP in configuration.yaml
Reboot HA
Reboot hue bridge
Verify hue IP

Setup:
RPi3 with Hassbian running 0.72.0

Logs:
Log Details (WARNING)
Wed Jun 27 2018 22:00:47 GMT-0400 (Eastern Daylight Time)
Connected to Hue at 192.168.1.4 but not registered.

Update:

I finally got it to work, but the only way of doing it was to enable discovery. It still lists two hue bridges in my configuration > integrations

I had to completely remove/comment out my configurations I had for these and use the discovery entirely.

I don’t want to break what is working currently, but if I remove discovery and add the hue component manually in configuration.yaml, will it continue working?

it should. Also, you should make your internal IP static for your hue bridge so you don’t run into this again. Google search dhcp reservation for your router and use it to lock the IP of the hue bridge. I also recommend doing this for just about every device you have connected to your network.