Hue Groups gone after update

Hi,

Hue grouped lights are not vissible anymore in my homeasssistant. I have found this Enable grouped light if enabled in previous version of Hue integration by marcelveldt · Pull Request #61582 · home-assistant/core · GitHub but for me this is not solving it (i’m on 2021.12.3). I came from 2021.11.5 I also know I have to look under integrations → hue → entities now and enable grouped lights specifically. But my groups are not there. I have also made sure to show all entities in the list that are not enabled.

Rooms made in the hue app do appear. (which are also groups if I’m not mistaken, as is_hue_group=true) . But my old groups (made like >3 years ago) are gone after the update. Completely. Can[t find logging cant find nothing. They are still there in the bridge

I also read somewhere adding a new group should at least make the new group visible (tested with iconnecthue), but this doesn’t work in my situation either. They are simply not there.

Anybody any ideas?

2 Likes

I noticed the same things. My rooms were there but my manual groups were not. I used iconnecthue to make zones and that worked although they were created in a deactivated position (which is expected behavior). However, after activating them, I had to restart home assistant for them to become available. Simply reloading the hue integration did not work.

1 Like

Same for me.

I had to remove and reinstall the integration.

Now it’s become very unreliable. I need to reload it several times a day. Lights are not updating their status.

Have you updated? This is supposed to be fixed in 2021.12.3

My lights are updating just fine, but the manual groups are still gone, even after an reinstall of the integration

Edit: Fixed it. You have to go into the Integrations → Hue → Entities and click on the groups and click on ‘activate entity’ and restart HA

I’m having the same problem. As a test, I created (through manual API calls to the bridge) a new group and a new zone, and the new zone appeared in Home Assistant (in a disabled state), but the group never did. It seems like the new 2021.12.x doesn’t support groups anymore for legacy users. It’s going to take many hours to recreate them all as zones :frowning:

I use hue light groups to create groups that don’t appear in the Hue app. I don’t use HA light groups as they control each light independently in (seemingly) random series, which can look suboptimal when turning on groups of track lights. Is there really no future support for Light groups?

Still no response or solution to this? Same issue

Same issue here…

I found the problem.
The groups get disabled.
You have to enable it in the UI.

Activate the “Enable entity” switch.

It’s documented.

1 Like

Hi guys,

I am new to home assistant and migrating from another home automation software. The Philips Hue integration is the last thing I have to do to complete the migration. So far so good.

I started with Philips Hue 7 years ago and all lights and switches are Philips Hue since nearly 5 years. It simply works since that time. I have a HueBridge.

Some years ago I created some hue light groups with iconnecthue. I don’t mean room or zone groups, I mean light groups. For example I have 2 gu10 spots in my living room. Instead of switching them one by one, I can use the group to switch them both together.

  • group name: living room spots
  • device names: living room spot left | living room spot right

These groups aren’t recognized by home assistant. I already tried to restart home assistant, but they don’t appear.

So I removed the respective light group “living room spots” and recreated it. After a home assistant restart they still don’t appear.

So I removed the respective light group “living room spots” angain, but now I created a new zone in iconnecthue with the same name. After restarting home assistant the zone gets created automatically and I can control the zone “living room spots” from home assistant. It works this way.

The issue I have with is, that a simple light group of some spots for example now is a zone in the Hue app. Not a major issue, but also not very nice. :wink:

Is this the way to go nowadays?

Thanks and regards Hoppel

Ok, iConnectHue also recommends to not use these light groups anymore, as they are an outdated concept.

So I deleted all my groups and created zones instead. It works fine for me. They are recognized by Home Assistant, when you do a developer tools restart.

I also use them with the HomeKit integration.

Thanks and regards Hoppel