Humidifier service, entity, unique ID setting

Hello, everyone,
I tried to integrate “Humidifier services” into HA via YAML editing:

generic_hygrostat:
  - name: Hygrostat předsíň
    humidifier: switch.odvlhcovac_zasuvka_1
    target_sensor: sensor.senzor_teploty_a_vlhkosti_vlhkost_vzduchu
    min_humidity: 30
    max_humidity: 70
    target_humidity: 50
    dry_tolerance: 3
    wet_tolerance: 0
    device_class: "humidifier"
    min_cycle_duration:
      seconds: 5
    keep_alive:
      minutes: 3
    initial_state: true
    away_humidity: 35
    away_fixed: True
    sensor_stale_duration: 00:15:00

After restart HA, I can see the ID of this entity in the Settings/entity menu (name is “humidifier.hygrostat_predsin”), the entity is obviously working (values from the sensor are displayed), but it cannot be edited via the UI because it does not have a unique ID. How can I get this unique ID, how can I assign it to this entity? Is there any easier way to integrate the “Humidfier” service than by editing configuration.yaml?
Thanks in advance to all responders.

generally adding unique_id: should work

generic_hygrostat:
  - name: Hygrostat předsíň
    unique_id: h1
    humidifier: switch.odvlhcovac_zasuvka_1

Didn’t test it though.

so yes, add unique_id yourself.

Wonderful! I kept adding “entity_id= prst.xyz”, and getting back “Invalid config for 'generic_hygrostat, entity_id is an invalid option…”. Great advice, thank you very much!