iCloud Device Tracking

Hey.

I’ve added two accounts to device tracking such as this:

> #device_tracker:
>   - platform: icloud
>     username: email
>     password: pass
>     account_name: name
>   - platform: icloud
>     username: email
>     password: name
>     account_name: name

Now, it adds the first device without problems into known_devices.yaml, but not the second? What am I doing wrong? There are no errors in the event logs.

thanks

Anyone help? Still struggling.

I don’t think that it is supposed to support 2 icloud accounts

I think it uses the family locator service on the iphone so anyone in your “family” would be tracked.

I have two entries in mine and it works fine. Both phones are tracked.

please post your config so dquancey can look at it, it might help.

Yeah could you post your config please?

I’ve tried but not able to see where I’m gonig wrong.

Mine is the same as yours, except I am not using the account name option. Is there anything in your error log related to iCloud? Are you sure you have the passwords correct?

I’m guessing you don’t really have device_tracker: commented out. Right?

Yeah, sorry I added that in manually when copying the code into here.

The accounts/passwords are correct and no errors in the logs. I’m a little confused.

have you done tried
hass --script check_config
to see what it comes back with?

I’ll give that a go shortly.

If I just have 1 icloud account in, it pulls that through, tried both accounts singularly to see if they had a problem, but both worked on their own.

known_devices.yaml looks like this (nothing redacted)

iphone:
hide_if_away: false
mac:
name: iPhone
picture:
track: true
vendor:

hass --script check_config

comes back with no errors.

You are taking away all the easy answers.

I’m guessing email/password and name are different between the two phones?

Wait, I thought I fixed it, I hadn’t…

please clarify.
did you think you had fixed something before my email or did you think my suggestion had fixed it and it didn’t? LOL

Before.

I added each account on their own, then changed the name in known_devices.yaml, added 2nd account, which added a 2nd device into known_devices.yaml, but this just rendered the 1st account useless.

Hurting my brain.

Right.

NOW I’ve fixed it. Feeling a little stupid doing so.

Both iPhones were NAMED iPhone…

Changed name and both phones now reporting.

Thanks for the suggestion above, you fixed it for me.

Glad I could help

1 Like