iCloud3 v2.4 - An advanced device tracker custom component that is integrated with the iOS App location monitor

@gcobb321 - sadly, I am having the same, or at least a very similar issue, as @spry-salt. I have 3 iPhones all tied to family sharing and findmy. All three have the app loaded. All three are accessible in icloud3. ONE of those phone is continually being “paused” due to a fantastic number of errors labeled “(OldLoc Poor GPS)”. Eventually IC3 posts an entry about “Tracking Paused - Excessive Errors Encountered” with a count of old locations and location errors, generally in the thousands. I can see from the logs that IC3 is constantly bombarding the iCloud family sharing until it finally gives up and pauses. At that point even zone entry/exits seems to stop from the phone app.

The problem is I have no idea where to tackle this. I recognize that IC3 is looking to iCloud to resolve the location of the phone but I am not finding anything obviously different between this phone and the other two on the same account.

Any hints? Anything from a log that might provide some insight that I should look at?

ANY pointers would be much appreciated.


I’ve read through the documentation and I’m unclear what I need to do to prevent the 2FA pop up. How do I enable family sharing or find my mode to prevent that? I have no ability to turn off 2FA.

Apple requires 2fa. You can not turn it off.

Does this mean every device I’m tracking will get the popup every time I restart HA? Do I just hit “okay” and move on (meaning I don’t need to enter the 6 digit code anywhere)?

I thought there was a workaround to this…am I mistaken? Any way to avoid the popups?

@El_Duderino Apple is verifying the device your HA is running on as a valid device. Once the account is authenticated/verified by entering the 6-digit code, you will not receive the popup messages for the next 3 or 4-months (determined by Apple). The verification tokens and cookies that authenticate your HA device, you will be good.

See the iCloud3 docs here. Apple is verifying the device your HA is running on as a valid device.) for more information about what isgoing on and how to enter the code –

I just installed iCloud3 v2.4. Even though the documentation is not exactly the same situation with this latest HA version, and my iPhone SE 2020, I think it works. At least I can see the states “home” :slight_smile:

My question, when I restart HA, my iPhone gets notification and there is Apple ID verification with 6 digits number. What do I need to do with those numbers?

Do I need to enter it somewhere? I read the documentation “Authenticating Your iCloud Account”, but I still don’t understand. Right now, I click OK (kind of, can’t remember). And that’s it.

Can you please explain to me in more details?

NOTE: Actually this is the iPhone for my daughter, so I am setting it up to integrate with HA. And I am Android user, so I know iOS in general, please be easy on me lol. Thank you :slight_smile:

Typically, you’d see a badge next to Notifications in the side bar. Clicking on Notifications will take you to the Notifications View where a configuration message is waiting. Clicking on Configure calls up the dialog where you enter the 2FA code. To practice this, reset the iCloud interface from the Icloud3 Event Log Actions menu.

If you aren’t receiving a badge next to Notifications, this happens from time to time at an unforeseen interval, just ignore the 2FA code and move on. Easy enough?

I think I found it by going to developers tools, States. There I saw an entry something like Apple ID verification. I clicked that, in the Info tab, enter the code. Wait a few seconds, then it’s gone.

I think that’s it, and I don’t see any other notifications on HA. Thanks for your feedback.

I tried to add the Event Log card, but I cannot make it work.

Here is the location of the .js file:


I added to the Dashboard resources as JavaScript module:


And here is the error when creating card:

How to correct this?

Possibly you are using the www/community directory for storing custom cards. In that case add following line to config_ic3.yaml:
event_log_card_directory: www/community

Apparently, this is how to fix it. Simply remove the indentation.
Probably the documentation needs to be updated.

I’ve attempted to install this component. I appreciate the time and effort you’ve taken to create it but quite frankly, your instructions to install and setup are not very good.
It’s very difficult to follow them and they do not flow very well with all the notes interwoven within the instructions. I would strongly recommend you structure them so they are easy to follow in a step-by-step method.
I consider myself to be very computer literate and have never had any problems with any other aspects of HA. I sincerely do not mean this to be disrespectful only constructive.


@rob0225 Yes, those instructions are out of date and there have been many changes to HA since they were written. iCloud3 v3 beta was released 3 weeks ago. It is a complete and is a true HA integration with many new features. It’s looking pretty good and hope to expand the people that are trying it in a few weeks.

iCloud3 documentation is here if you want to take a look at it.

1 Like

By any chance, is there anything in iCloud3 that defines “iphone_stationary”? For unknown reason my Android phone was tracked as “iphone_stationary”, while my iPhone was “Stationary”. This happened several times, which I can’t think what could cause it.

I posted a thread here. Please if you might know something.

@HA_n00b The iCloud3 custom_component creates a Stationary zone when the device has been in the same location without moving for a period of time. The ios app picks up it’s location and also puts it in the zone. The purpose is to save battery life by requesting the devices location fewer times. Expecially when close to home.

It appears the Android app also gets the Stationary and puts those devices in it too. You can disable the iCloud3 stationary zone by adding the stationary_still_time: 99999 parameter to the configuration.

Thanks, I will try that. I’m just wondering why the Android tracker uses “iphone_stationary”, that’s weird isn’t it. I won’t get confused if it uses “android_stationary”. Probably copy-paste error :grinning_face_with_smiling_eyes:

Note: impatiently iCloud3 v3. 0 :relaxed:

Isn’t it because the iPhone created a zone “iphone_stationary” (and shows it as “stationary”) and the androids use that zone (that already has been created by the iPhone) and show it with the complete name “iphone_stationary”?

1 Like

After some digging, you are correct. The “iphone_stationary” zone was created by iPhone or iCloud3, I don’t know. I searched in the /config folder and found this reference:


In the icloud3-event-log.txt, I found this:

-- sys event -- 6:50:25p - - - - - Configuring Device > XXXXX (iphone), • Initialize Tracking Fields, • Initialize Zones, • Initialize Stationary Zone > iphone_stationary, • Update HA Device Entities, • Sensor entity prefix > sensor.iphone, • Initialize Sensor Fields

And I can see it in the Map view:


But, I cannot delete/edit it:


I cannot find it in the configuration.yaml.

So, how do I delete this? @gcobb321

You can’t. iCloud3 will always create it. You can set the still time so it never gets used and set it’s base location to somewhere you will never be (equator, in the ocean, North Pole) but it will always be created if you are using iCloud3


I disable the iCloud3 stationary now as you suggested previously. I guess iCloud3 would stop creating that iphone_stationary zone.

But, I still won’t be able to delete that existing one? Because, if I go to that location again, that zone will be assigned to all my phones.