IFTTT ETIMEDOUT errors in HA configuration

Hello,
I’m having difficulties with my ifttt/webhook api HA configuration. I created a test applet with a simple a webhook trigger and webhook action.
The webhook action is:
URL: ht t ps://blah.blah.com:8123/api/webhook/“integration ifttt api”
method: post
type: json
body: { “action”: “call_service”, “service”: “switch.turn_off”, “entity_id”: “switch.audioswitch” }.
I triggered the service in HA with { “event” : “testaudioswitch” } and the applet gets an ETIMEDOUT. After I checked all my configurations several times I decided to run a tcpdump and I found the IFTTT (amazon aws) server sent/retransmitted 4 packets to hassbian on dest port 8123 and with no reply. Netstat -ltn shows hassbian listening tcp4/port 8123. So, i created the following bash script on another external server:
/usr/bin/curl -v -X POST -H “Content-Type: application/json” -d ‘{ “action”: “call_service”, “service”: “switch.turn_on”, “entity_id”: “switch.audioswitch” }’ ht tp s:// blah.blah.com:8123/api/webhook/“integration ifttt api”
The curl is successful. So i ran a tcpdump again while i ran the curl and the packet trace was very similar if not identical to the call from ifttt, the only difference being hassbian responds and the conversation is complete.
I’ve done this configuration on 2 other servers and its pretty cookie cutter. But, Im missing something (probably something really dumb) and I’m stumped. Any guidance or direction would be greatly appreciated.
Thanks in advance,
Eric

Below is some relevant configuration.

Hassbian 0.85.0/ RPI3

configuration.yaml:
http:
base_url: blah.blah.com:8123
ssl_certificate: /etc/letsencrypt/live/blah.blah.com/fullchain.pem
ssl_key: /etc/letsencrypt/live/blah.blah.com/privkey.pem
api_password: 1234
trusted_networks:
- 192.168.1.0/24
- 192.168.100.0/24
ifttt:
key: 12345678…

automation:

  • id: trigger webhook
    trigger:
    platform: event
    event_type: ifttt_webhook_received
    event_data:
    action: call_service
    action:
    service_template: ‘{{ trigger.event.data.service }}’
    data_template:
    entity_id: ‘{{ trigger.event.data.entity_id }}’

Well shoot, I apologize to any and all that may have given this post any thought…
It was a routing issue :frowning: (rookie mistake :().
Thanks again,
E

Can you expand on what you mean by routing issue? I am a medium user and have been using Hass.io for a few years-ish now. I am stumped by this IFTTT Webhook that seems like it should be a simple setup.

Hello, I don’t recall the specifics but I’m running Hassbian and I was using multiple ethernet interfaces. I finally ran a packet trace and found I had a routing issue between the 2 interfaces IE: sending the request out on one interface and never receiving the ACK.
The configuration is really straight forward, all I can offer is to keep searching the threads and post your configuration.
Thanks,Eric