IFTTT . No module named 'aiodiscover', error when upgrading

[22:54:08] ERROR: The configuration check did not pass!
[22:54:08] ERROR: See the output below for more details.
Testing configuration at /tmp/config
Failed config
  General Errors: 
    - Component error: ifttt - No module named 'aiodiscover'

Successful config (partial)
[22:54:08] INFO: The full output has been written to /share/check_config.txt

I have this in configuration.yaml:

ifttt:
  key: abcd

And then I have the integration IFTTT webhook.

Not sure I understand what this error is. Or is there any other places IFTTT could be?

Tried to look for breaking changes in the release 2021.12.1 but could not find something specific to aiodiscover and could not yet identify something similar (maybe I did not search enough)

The same issue for twillo.

Failed config
General Errors:
- Component error: twilio - No module named ‘aiodiscover’
- Component error: ifttt - No module named ‘aiodiscover’

1 Like

I’m having the same.
I’ve opened an issue.

1 Like

I am having the same issue with rpi power supply checker. I deleted the integration and I also get this error when trying to add it back. Config flow could not be loaded

Running Core in a venv.
Just upgraded to 2021.12.2
python 3.9.6

Im seeing the same issue for Twilio. Has anyone tried to upgrade regardless to see if its a false positive?

1 Like

I have the same with the Sonos integration. First got an import error after the upgrade to 12.0. Then I removed the component and tried to reinstall I get config flow could not be loaded and in the log I then see this:

Logger: homeassistant.config_entries
Source: config_entries.py:720
First occurred: 9:58:25 AM (4 occurrences)
Last logged: 9:58:25 AM
 
Error occurred loading configuration flow for integration sonos: No module named 'aiodiscover'

Issue remains in 2021.12.3… I might try to manually install the modules and see what happens.

After installing aiodiscover it is now saying No module named 'scapy'
After installing scapy I get… Error occurred loading configuration flow for integration rpi_power: cannot import name 'DeviceOrServiceType' from 'async_upnp_client.const' (/srv/homeassistant/lib/python3.9/site-packages/async_upnp_client/const.py)

It seems that manually installing the modules aiodiscover and scapy solved the issue here. After installing both and restarting Home Assistant the Sonos integration found devices and asked to setup the integration.

1 Like

So how do you do that?

1 Like

Yes, please share how you do that.

I am using a virtualenv in a jail on a TrueNAS installation. For me the commands to install are:

service homeassistant install aiodiscover
service homeassistant install scapy

But I think this might be different depending on how and where you have installed homeassistant.

Yes, i’m using Home Assistant OS. I guess it seems this is something the dev’s need to do?
Just a shame no one has picked up the issue yet.

You can always roll back to the last working version untill this is fixed (2021.11.5 in your case). Be aware that this is a free open source project so you cannot have expectations regarding within what time things get fixed. This issue doesn’t seem to be affecting a lot of people so that also doesn’t speed up the fix time.

Yeah I know, I completely understand - just wish I knew more so I could contribute.

Anyway - I think I may have found a way to do it using the terminal in Visual Studio Code. Will try it when I get home.

I am looking in github for more related issues. Maybe you can change the issue to DHCP instead of twillio. As that seems to be the underlying issue not the twillio component itself.

Also the twilio component doesn’t seem to have code owners assigned in github and therefore the issue isn’t assigned to anyone.

I can’t change the issue label unfortunately, but I see you tagged bdraco in the issue so we shall see what that comes up with. Thanks for your help :slightly_smiling_face:

rpi_power_status still broken in 2021.12.4

Still not able to add Power supply checker in 2021.12.5.

I’m having exactly the same issue with the Twillio integration, the issue on Github has been closed unfortunately

1 Like