IKEA Tradfri Bulb Switches On in Wrong Color and Brightness

Hello!

I have faced a very weird problem which I could not figure out.
If I activate a scene with specific color and then switch off the IKEA Tradfri Bulb with automation and then switch it on back again, it would ignore color and brightness settings, but rather swtich on with the same settings when it was switched off.
For example.

  1. Set color RED
  2. Switch off
  3. Call Service Light On and set Temperature to 370 and brightness 100%
  4. Result: Only switches on, without defined color and brightness settings applied.
    I do have 2 Hue bulbs in the same room, they work perfectly.

Any ideas?

2 Likes

I started having this issue with our Kitchen Cabinet lights and now another bulb as well.

What’s weird is that on Home Assistant, it says that the bulb is at 85% brightness (as it should be) but the bulb looks like it’s lit to 1% brightness instead. Manually moving the percentage up or down a value immediately resolves the issue, but as you can imagine, it isn’t ideal to have to whip out your phone to fix this issue when the lights are meant to come on automatically or with a push of a button…

For a little more info:

The Kitchen Cabinet Lights get turned on and off with a dimmer button. The brightness is set to it’s previous state, but it does not behave this way if the lights get turned off and on. It worked perfectly fine in the past, but suddenly without any updates to HA, I’ve had issues.

The other bulb comes on via PIR sensor. I use Adaptive Lighting to determine the brightness of this bulb when it turns on. As with the Kitchen Cabinet lights, it worked perfectly fine prior to 2 days ago. I have made no changes to HA.

Anyone else having similar issues or have any potential fixes?

I haven’t had a moment to start deep diving and troubleshooting nor have I made any changes since my last response here, but all of my bulbs are now affected including the 2 wifi bulbs so I’m now certain that this isn’t a Zigbee2mqtt or Tradfri issue. Is anyone else experiencing the same?

Hello jtihonov, I know it has been a year, but have you been able to fix this? I have the exact same problem with my tradfri GU10 color led. When I change the light while its on, everything works. But when an automation turns on the light, all settings are ignored and it turns on in the previous state.

Yes I am. But I only started using this light yesterday so it has never worked for me. FYI in my case it’s a zigbee light without remote. I control it via zigbee stick through zha.