Ilumin (Inovelli) LZW42 RGB Bulb

Does anyone happen to have a configuration xml for the Ilumin LZW42 RGB Bulb by Inovelli or perhaps a generic profile for an RGB bulb?

I went through the process of copying the config files for their LZW31 dimmer switch which worked great but it seems that they have completely moved past creating config files for open z-wave 1.4…

I was considering creating my own based off their smartthings config file but the RGB bulbs are a little more complex than the dimmers and I don’t have the time to try and hamfist it as this is not an area I am super experienced with.

What are you hoping a config file will provide? Is there a problem with the bulbs? If you want to set configuration parameters, you can do that manually.

The bulb just shows as “Inovelli Unknown: type=0005, id=0001 (Node:5 Complete)” in HASS with no configuration parameters. It functions fine as a generic white dimmable bulb but there is no way for me to configure the RGB functions. I had the same issue with their switch until I did some config files editing to get it to work with HASS and the old open z-wave protocol.

How would I configure the bulb manually? Unlike their dimmer switches, there is no physical switch to access functions, nor does their instruction manual elaborate beyond anything other than the smartthings app.

Edit: I am seeing that I can send commands to the device “manually” I was conflating manually that with physically. This is all still very new to me so I am sorry for that. I see that they have a list of commands in the manual regarding that.

The name you can update in HA, in the Devices page.

For config parameters, you can find them in the manual or the same is listed here. For example, to adjust the color temperature to 6500k, you should be able to call the zwave.set_config_parameter service with data:

node_id: 5
parameter: 52
value: 6500
size: 2

As for the RGB functionality, I have never used any bulbs, but HA does have support for them without any special configuration (there are a few bulbs that have special handling). What is the value of the supported_features of the light entity? Also, maybe you could post a copy of the Node data in the zwcfg*.xml file.

1 Like

I completely forgot about sending the commands manually that way. I was confusing “manually” with “physically.”

The value of supported_features is 1.

Put the node data into a pastebin here.

This all might be a little bit out of my ability to invest time into it right now. I was hoping to be able to configure the bulb easily with parameters rather than manually doing everything, especially with the multitude of ways you can configure an RGB bulb. Just might have to use it as a regular dimmable white bulb and hope ozw 1.6 integration comes soon for home assistant.

The value 1 for supported_features means the light only supports dimming, that’s it. For color you would need to see at least 17. So that would explain why you aren’t presented any color functionality.

The XML file looks reasonable, it is showing that color support was detected. For some reason, HA is not picking this up, I can’t see why.

If you want to try one more thing before punting for now, you could try turning on debug logging and see if the problem is revealed. You can add the settings below to configuration.yaml then restart HA. It will produce a lot of debug logging related to zwave that you could post to pastebin.

logger:
 default: info
  logs:
    homeassistant.components.zwave: debug
    openzwave: debug
    libopenzwave: debug

Sounds good. I have to step away until tomorrow night and then I will have a go at it. Thanks a lot for your help so far!

I’m in the same situation here. Any help is appreciated.

I created the following in my open-zwave configs (configs/inovelli/lzw42.xml) for LZW42 (the RGBW bulb):

<?xml version="1.0" encoding="utf-8"?>
<Product xmlns="http://code.google.com/p/open-zwave/">

  <!-- Configuration Parameters -->
  <CommandClass id="112">
    <Value genre="config" instance="1" index="2" value="0" label="Memory Function" units="" size="1" min="0" max="1" type="byte">
      <Help>0 returns to last ON state, 1 = Returns to last state (ON or OFF)</Help>
    </Value>
    <Value genre="config" instance="1" index="81" value="2700" label="Warm White Adjustment" units="Kelvin" size="2" min="2700" max="4999" type="short">
      <Help>Adjusts the warm white color component 2700 = 2700 Kelvin, 4999 = 4999 Kelvin</Help>
    </Value>
    <Value genre="config" instance="1" index="82" value="6500" label="Cold White Adjustment" units="Kelvin" size="2" min="5000" max="6500" type="short">
      <Help>Adjusts the cold white color component. 5000 = 5000 Kelvin, 6500 = 6500 Kelvin</Help>
    </Value>
  </CommandClass>

  <!-- Association Groups -->
  <CommandClass id="133">
    <Associations num_groups="1">
      <Group index="1" label="Lifeline" max_associations="1" auto="true" />
    </Associations>
  </CommandClass>

</Product>

and then after I added the bulbs to Home Assistant, I went to Configuration --> Customizations, selected the Bulb, and set the supported_features bit flag to 145 based on the follow bit flag settings:

SUPPORT_BRIGHTNESS = 1
SUPPORT_COLOR_TEMP = 2
SUPPORT_EFFECT = 4
SUPPORT_FLASH = 8
SUPPORT_COLOR = 16
SUPPORT_TRANSITION = 32
SUPPORT_WHITE_VALUE = 128

This allows me to set the three config parameters in the zwave section, as well as control the RGBW from the UI.

I made a guide with links to all files for anyone who is interested

1 Like

I was just working on this when you posted it; thanks for saving me a ton of time!

I did have to add the “config_path” key to my zwave configuration (below) to get it to see the new configs, but that wasn’t a big deal to figure out compared to what I’d have had to do without your how-to!

zwave:
  usb_path: /dev/serial/by-id/usb-0658_0200-if00
  network_key: !secret zwave_key
  config_path: /config/ozwave/config

Shit, i forgot about that piece. I’ll add it to the guide. I totally meant to do that.

One suggestion, when downloading the config files the instructions should point to the HASS fork of the OZW repo, not OZW 1.4. The HASS fork has more device support.

Oh really, I’ll do that.

EDIT: That means I need to update my stuff

Also, HA is accepting PRs for config files, they get added to the next release usually. You could try submitting a PR. The only thing I’m not sure of is if they want to accept ones that haven’t been merged upstream yet. Looks like there is an upstream PR in progress.

Not sure they want my files. I cobbled them together by stripping all the ozwave 1.6 crap. They work, but they don’t add the correct supported features for some things.

FYI Inovelli themselves maintain a set of OpenZWave configs + manufacturer_specific entries for their devices. It includes a few additional products (maybe their switches?). Thank you for your guide, @petro, it helped me fill in some of the blanks

So I know this is an old post, but since I was running into the same problem, I also found an alternative method that works for me with a script, with or without using the Inovelli configs. I simply create a script that uses the service light.turn_on, and uses the following service data:

white_value: 255
brightness: 255
rgb_color:
  - 255
  - 255
  - 255

This activates the warm white setting.

1 Like