Image overlay in floorplan picture-elements card not loading

Hi everyone,

I just followed some youtube videos about setting up a 3D Floorplan with Sweethome3D. Right now I’m at the point where I need to setup the picture-elements card in lovelace.

It seems that I have a problem with adding the overlay image for the lights (state image). It just won’t load elements with type image (lamperker.png)? I have placed all images in the config/www/ folder. The ‘dark.png’ background image seems to load fine. Image sizes are all the same and I can see the image is available when I go to http://myIP:8123/local/lamperker.png

What am I doing wrong? It’s probably something small… help is much appreciated :slight_smile:

type: picture-elements
image: /local/dark.png
elements:
  - type: image
    entity: light.erker
    tap_action: none
    hold_action: none
    state-image:
      "on": /local/lamperker.png
      "off": /local/transparent.png
    style:
      top: 50%
      left: 50%
      width: 100%

image

Complete Dashboard lovelace code:

views:
  - title: Home
    panel: true
    cards:
      - type: picture-elements
        image: /local/dark.png
        elements:
          - type: image
            entity: light.erker
            tap_action: none
            hold_action: none
            state-image:
              "on": /local/lamperker.png
              "off": /local/transparent.png
            style:
              top: 50%
              left: 50%
              width: 100%

Just found my issue.

state-image should be state_image :man_facepalming: