!includes are not being included. Groups not working


I’ve been having some issues with !includes in my configuration.yaml. Basically, all of the information in my groups.yaml seems to not be having any effect on the UI at all.

I get no errors when checking the config via UI or via SSH. I have tried with other !includes like customize_glob but it doesn’t work with other files either.

Here is my configuration.yaml:

  # Name of the location where Home Assistant is running
  name: Home
  # Location required to calculate the time the sun rises and sets
  latitude: REDACTED
  longitude: REDACTED
  # Impacts weather/sunrise data (altitude above sea level in meters)
  elevation: 10
  # metric for Metric, imperial for Imperial
  unit_system: metric
  # Pick yours from here: http://en.wikipedia.org/wiki/List_of_tz_database_time_zones
  time_zone: Europe/Stockholm
  # Customization file
  customize: !include customize.yaml
  # Customization file for entities matching a pattern
  customize_glob: !include customize_glob.yaml

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml

And this is what I have on my groups.yaml:

  name: home
  view: true
  icon: mdi:home
    - group.living_room
    - group.dining_room
    - group.bedroom
    - group.kids_bedroom
    - group.hallway
    - group.bathroom
    - group.common_area
    - weather.smhi_home
    - sun.sun
    - sensor.yr_symbol
    - remote.harmony_hub
    - media_player.all_speakers
    - media_player.non_sonos_group
    - device_tracker.rash_s9
  name: living room
  icon: mdi:sofa
    - light.hue_color_lamp_1
    - light.hue_color_lamp_2
    - light.hue_color_lamp_3
    - media_player.living_room
    - media_player.living_room_speaker
    - media_player.sonos_direct
    - media_player.sonos_speaker
  name: dining room
  icon: mdi:silverware
    - light.hue_ambiance_light_1
  name: bedroom
  icon: mdi:hotel
    - light.hue_ambiance_light_2
    - media_player.master_bedroom_speaker
    - media_player.pargash_cc_bedroom
    - media_player.ue50es6305
  name: kids bedroom
  icon: mdi:baby-buggy
    - light.hue_color_table_2
  name: hallway
  icon: mdi:door
    - light.hue_color_table_1
  name: bathroom
  icon: mdi:toilet
    - media_player.bathroom_speaker
  name: common area
  icon: mdi:home-modern
    - light.hue_color_lamp_1
    - light.hue_color_lamp_2
    - light.hue_color_lamp_3
    - light.hue_ambiance_light_1
    - media_player.living_room
    - media_player.living_room_speaker
    - media_player.sonos_direct
    - media_player.sonos_speaker  

Any idea what I could be missing? Thanks for your help!

Lovelace doesn’t use groups to decide what to display. You either need to set these pages up in lovelace or revert to the ‘states’ ui.

Ok. Now I understand. So I have been reading documentation that is not relevant for the release I’m working with.

Is there any way to know what releases the documentation applies for and for which it doesn’t?

The states UI have been the default user interface for Home Assistant for a while, the problem with it was that there was this sort of mixing up configuration stuff with user interface stuff in a hackish way. So, they decided to separate the configuration from the UI by using this UI called Lovelace, which has its own documentation, right here: https://www.home-assistant.io/lovelace/

Lovelace was an optional UI for a while but in the last release (I believe) it was made the default UI. You find the option to switch back to the states UI under the information tab.


Just the link that I needed! I will give it a try and revert to states UI if needed.

Any opinions about that? Which one do you think is better? Or the one with the most pros?

Lovelace is now the default and may be the only option in the future.

There are tons of cards for it. Some are built in some are custom cards. Lovelace is more flexible than the standard ui and much more customizable.

If i were you i would make the switch.