InfluxDB 4.0.3 Flux queries not working

When trying to use Flux I get a Error flux not enabled: <nil> error.

The browser network console shows a 400 for http://homeassistant:8123/api/hassio_ingress/H-JBG7XXXXXXXXXX-XXXXXXXXXXXXXXXXXXXXioVx_8/chronograf/v1/sources/0/proxy/flux?path=%2Fapi%2Fv2%2Fquery%3Forganization%3Ddefaultorgname

Version info:

System Health

version core-2021.2.2
installation_type Home Assistant Supervised
dev false
hassio true
docker true
virtualenv false
python_version 3.8.7
os_name Linux
os_version 5.10.11-v7l+
arch armv7l
timezone America/Los_Angeles
Home Assistant Community Store
GitHub API ok
Github API Calls Remaining 4800
Installed Version 1.11.0
Stage running
Available Repositories 741
Installed Repositories 4
Home Assistant Cloud
logged_in true
subscription_expiration February 14, 2021, 4:00 PM
relayer_connected true
remote_enabled false
remote_connected false
alexa_enabled false
google_enabled true
can_reach_cert_server ok
can_reach_cloud_auth ok
can_reach_cloud ok
Hass.io
host_os Raspbian GNU/Linux 10 (buster)
update_channel stable
supervisor_version supervisor-2021.02.6
docker_version 20.10.3
disk_total 58.3 GB
disk_used 19.0 GB
healthy true
supported failed to load: Unsupported
supervisor_api ok
version_api ok
installed_addons Mosquitto broker (5.1), File editor (5.2.0), InfluxDB (4.0.3), Node-RED (8.1.1), Grafana (6.1.0)
Lovelace
dashboards 4
resources 0
views 6
mode storage

Same issue here:
When trying to use Flux I get a Error flux not enabled: <nil> error.

System info:

  • Home Assistant OS 5.12, running as VM in Proxmox on an Intel NUC (NUC7i7BNH) with 3GB RAM and 32GB disk space
  • Supervisor 2021.02.9
  • Core 2021.2.3
  • InfluxDB Add-on: version: 4.0.3

Configuration of InfluxDB add-on:

auth: true
reporting: true
ssl: true
certfile: fullchain.pem
keyfile: privkey.pem
envvars:
  - name: INFLUXDB_HTTP_FLUX_ENABLED
    value: 'true'

@frenck, as maintainer of the InfluxDB Home Assistant add-in, perhaps you can help shed a light on this issue?

Looking at the influxdb.conf in the add-on, it seems that Flux is enabled:


Thanks in advance.
Michaël

Update: there is already an issue logged on Github which seems related to the same problem, so I’ll follow-up there:

1 Like