Initial delay with zwave devices

I am still new to Home Assistant and Z-Wave so I am still learning. I am running Hass.io in Docker on a PC and I have the Aeotec Gen5 USB Z-Wave stick. I bought a Dome Z-Wave Siren (battery powered) that I wanted to beep when a door was opened or closed. It was working OK but the delay was making me crazy. It took about ~2 seconds to make the noise but sometimes it was fast (if I remember correctly it was fast after the first trigger). I want things to be responsive so that is one of the reasons I chose Home Assistant since everything is local.

I assumed there was a delay with the Dome Siren because it is battery powered (I suppose that in order to preserve batteries, it must be sleeping and then waking up to listen to commands) so I sent it back for a refund. I bought a Neo Coolcam Z-Wave Siren that can be powered using a USB charger. I paired it in secure mode in Home Assistant while being powered by USB (I don’t even have batteries anyway). It seems to be working fine BUT I still experience a delay. I moved it next to the Aeotec Stick (~40 cm distance) and when I switch it on the Home Assistant UI, it takes about ~1.5 seconds to make the sound. Then if I trigger it again it is very fast, there is no delay that I can experience. Since the device is powered, I would have expected not to have any delay at all time. Is it normal? I don’t have light switches yet but if there is a ~1.5 delay I will be very disappointed.

Also, the Coolcam siren reports 24% battery level even if there is no battery, could it be configured wrong? I added it as secure, should it be added as non-secure? I am running the lastest version of Hass.io.

Here is the log, my understanding that the command was sent from HA at 13:32:58.708 but the confirmation that the siren was triggered was received at 13:32:59.939

2020-01-25 13:32:58.708 Info, Node005, Value::Set - COMMAND_CLASS_SWITCH_BINARY - Switch - 0 - 1 - True
2020-01-25 13:32:58.708 Info, Node005, SwitchBinary::Set - Setting node 5 to On
2020-01-25 13:32:58.708 Detail, Node005, Queuing (Send) SwitchBinaryCmd_Set (Node=5): 0x01, 0x0a, 0x00, 0x13, 0x05, 0x03, 0x25, 0x01, 0xff, 0x25, 0x44, 0x5a
2020-01-25 13:32:58.708 Detail, Node005, Queuing (Send) SwitchBinaryCmd_Get (Node=5): 0x01, 0x09, 0x00, 0x13, 0x05, 0x02, 0x25, 0x02, 0x25, 0x45, 0xa5
2020-01-25 13:32:58.708 Detail,
2020-01-25 13:32:58.708 Info, Node005, Sending (Send) message (Callback ID=0x44, Expected Reply=0x13) - SwitchBinaryCmd_Set (Node=5): 0x01, 0x0a, 0x00, 0x13, 0x05, 0x03, 0x25, 0x01, 0xff, 0x25, 0x44, 0x5a
2020-01-25 13:32:58.718 Detail, Node005,   Received: 0x01, 0x04, 0x01, 0x13, 0x01, 0xe8
2020-01-25 13:32:58.718 Detail, Node005,   ZW_SEND_DATA delivered to Z-Wave stack
2020-01-25 13:32:59.939 Detail, Node005,   Received: 0x01, 0x07, 0x00, 0x13, 0x44, 0x00, 0x00, 0x7b, 0xd4
2020-01-25 13:32:59.939 Detail, Node005,   ZW_SEND_DATA Request with callback ID 0x44 received (expected 0x44)
2020-01-25 13:32:59.939 Info, Node005, Request RTT 1230 Average Request RTT 796
2020-01-25 13:32:59.939 Detail,   Expected callbackId was received
2020-01-25 13:32:59.939 Detail,   Expected reply was received
2020-01-25 13:32:59.939 Detail,   Message transaction complete

But if I send a second command quickly, the command is sent a 13:33:01.480 and the reply received at 13:33:01.510 (which makes sense because I can’t hear a delay of 30 ms)

2020-01-25 13:33:01.480 Info, Node005, Value::Set - COMMAND_CLASS_SWITCH_BINARY - Switch - 0 - 1 - True
2020-01-25 13:33:01.480 Info, Node005, SwitchBinary::Set - Setting node 5 to On
2020-01-25 13:33:01.480 Detail, Node005, Queuing (Send) SwitchBinaryCmd_Set (Node=5): 0x01, 0x0a, 0x00, 0x13, 0x05, 0x03, 0x25, 0x01, 0xff, 0x25, 0x46, 0x58
2020-01-25 13:33:01.480 Detail, Node005, Queuing (Send) SwitchBinaryCmd_Get (Node=5): 0x01, 0x09, 0x00, 0x13, 0x05, 0x02, 0x25, 0x02, 0x25, 0x47, 0xa7
2020-01-25 13:33:01.480 Detail,
2020-01-25 13:33:01.480 Info, Node005, Sending (Send) message (Callback ID=0x46, Expected Reply=0x13) - SwitchBinaryCmd_Set (Node=5): 0x01, 0x0a, 0x00, 0x13, 0x05, 0x03, 0x25, 0x01, 0xff, 0x25, 0x46, 0x58
2020-01-25 13:33:01.490 Detail, Node005,   Received: 0x01, 0x04, 0x01, 0x13, 0x01, 0xe8
2020-01-25 13:33:01.490 Detail, Node005,   ZW_SEND_DATA delivered to Z-Wave stack
2020-01-25 13:33:01.510 Detail, Node005,   Received: 0x01, 0x07, 0x00, 0x13, 0x46, 0x00, 0x00, 0x03, 0xae
2020-01-25 13:33:01.510 Detail, Node005,   ZW_SEND_DATA Request with callback ID 0x46 received (expected 0x46)
2020-01-25 13:33:01.510 Info, Node005, Request RTT 29 Average Request RTT 223
2020-01-25 13:33:01.510 Detail,   Expected callbackId was received
2020-01-25 13:33:01.510 Detail,   Expected reply was received
2020-01-25 13:33:01.510 Detail,   Message transaction complete

What state is your Z-Wave node in before you send the command? It should either be “Ready” or “Sleeping”. You can find this in the Z-Wave control panel, select your node, then click “Node Information”.

Most non-battery powered devices do not go into sleeping state, though it’s always good to double check. Especially since the performance is changing depending on how long it has been since it was last triggered, this is a good indication that it can go into sleeping.

1-2 seconds seems fairly normal for battery powered devices in a sleeping state. For example, I just triggered my front door lock and the RTT was 1448 (ms).

[Edit] Make sure you check that the voltage being sent to your device is strong enough. For the Neo Coolcam Siren, I found this tidbit:

Support two types of power supply- Battery power & USB charged ( 6V, 0.5A ) If the voltage is in 4.5-6V, it will report low power.

In which case, if it’s in low-power, it will likely sleep.

In node information, “is ready” and “is awake” are both true. I tried 2 different 5V power sources (USB charger and power bar with USB) with the same results. I do not see a low power info (I might not be checking at the right place, do you know where it would be listed?) but all USB sources I have are 5V. It does make a pretty loud sound when setting the volume to max so it doesn’t seem to be a low power problem however if it is, I will simply try to buy a 6V USB charger (they don’t seem easy to find).

In fact you might be right that the device is probably in low power mode (I don’t know where I can check this info however). As you said, in the manual it says 6V mini-USB (but it should say micro USB… so I am not sure I can fully trust that manual) but the Amazon description said 5V. It makes sense because it uses 2 x CR123A batteries, so 2x 3V = 6V.