Input slider automation, why doesn't this work?

I’m trying to set up an input_slider with shell command automation.
I had one set up already and copied it for the second one.

> input_slider:
>   brightness_slider:
>     name: Brightness
>     initial: 10
>     min: 5
>     max: 15
>     step: 1
>   led_slider:
>     name: Led
>     initial: 100
>     min: 30
>     max: 255
>     step: 5

> shell_command:
>   set_lamp_to_slider: 'pilight-send -p kaku_dimmer -u 0 -i 18961818 -d {{ states.input_slider.brightness_slider.state }}'
>   led_to_slider: 'ledchange br {{ states.input_slider.led_slider.state }}'

> automation 3:
> - alias: "Change Sofa lamp brightness"
>   hide_entity: True
>   trigger:
>     platform: state
>     entity_id: input_slider.brightness_slider
>   action:
>     service: shell_command.set_lamp_to_slider
>   condition:
>     condition: state
>     entity_id: switch.sofa_light
>     state: 'on'
> - alias: "Change LED strip brightness"
>   hide_entity: False
>   trigger:
>     platform: state
>     entity_id: input_slider.led_slider
>   action:
>     service: shell_command.led_to_slider
>   condition:
>     condition: state
>     entity_id: switch.ledstrip
>     state: 'on'

The first slider works the second LED slider does not.
The automation gets triggered correctly but it seems the shell_command does not get executed.
any ideas?

Thanks.

Before the above I think you need
automation 4:

Haha just noticed the date of the post, I guess you solved it by now :slight_smile:

I did, but thanks anyway :relaxed: