Home Assistant Community

Install Hass.io on a debian distribution already having samba share

#1

Hi amazing community.

I installed HA on my debian.
everything is fine, but I admit that the hass.io with it plugins may make some stuff easier.

I already tried to install it with the docker method, but came accross an issue => I never used docker. So i tried the samba add on to modify the files within docker from my laptop. But the issue is that I already have shared folder on the debian installation

I noticed that the docker system had another IP range than my nettwork. And I guess that it is doing some port mapping in order to reach it from the lan.
But the issue is that the host already has a samba share and I was not able to find out a way to access the samba of the docker directly from my network.

Is there a way to give the docker system a dedicated IN within my LAN ?
for information my lan is with 192.168.1.xx . That way I could enable all kind of services without being afraid that it does not work …

#2

So you couldn’t just install it from the documentation? Using the script? What do you need to know about docker first?

You don’t need the samba add-on, just add the path to your samba share.

Kind of.

You DO NOT need the samba docker. Get rid of it.

Ignore the subnet. It’s normal and works just fine, and there is no reason to try to break how Docker works, just because you don’t understand it.

#3

If first tried to install without hassio and this system is currently up and running fine.

I then tried with hassio, the two dockers where installed and i could access the HA webpage (of course if first turned off the HA installed on the computer to make sure that I’m on the one with docker.
And of course I had the hassio menu, so it was for sure the docker version :slight_smile:

well that was what I was thinking of, but files from the docker are located in a container, I was not aware that I can access it content from the host directly. Any idea where the path is under debian ?

#4

No they aren’t.

Here is the script. I suggest you read it.

DATA_SHARE=/usr/share/hassio

If you want to RETAIN data, you don’t leave it in a container. A docker container is ephemeral and disposable.

1 Like
#5

Thanks i’ll try this again :slight_smile:

just for understanding, why is there no way to have directly the hassio menu without a docker ? Is there a technical reason for this, or could it be possible to have this menu directly without docker on a debian system ?

#6

The hassio menu is part of the supervisor. You can’t get this if the supervisor (which manages the docker containers for home assistant and add-ons) can’t manage the docker instance.

No. The supervisor is centered around Docker. It requires Docker. Docker is actually a better (easier to manage) system than manually managing a python virtual environment

1 Like