Installing EVCC from github

Hi all, noob here.

I am trying to install EVCC (EV Charge Controller) to home assistant. Getting stuck on what is probably the easiest thing.
Installation notes say:


EVCC is provided as binary executable file and docker image. Download the file for your platform and then execute like this:

evcc -h


Download ‘the File for Your platform’ - What file ? My home assistant is running as Operating System (VM) on windows.

I tried to copy all the files by typing "git clone” to terminal.
It seemed to work, at least it showed it copied evcc. Then tried to type "evcc -h” as per instructions. Getting "command not found” in return…

I have managed to install go-e charger integration…

What am I doing wrong? Am I completely over my head?

Please be nice:)


Have you seen this: Integration in Home Assistant als Addon · Issue #235 · andig/evcc · GitHub

At the end of the long conversation I think there is a short how-to.

That’s what I’ve found after 2 mins of googling.
Don’t know if it works, that’s for you to find out :slight_smile:

Is it possible to read the passwords, tokens, etc. for the hassio addon (path config/evcc.yaml) from the Home Assistant configuration file secrets.yaml? At the moment it’s all in plain text…
Or is the evcc.yaml already encapsulated well enough?