Installing Home Assistant on a RPi 4b 8GB with SSD boot

Tags: #<Tag:0x00007f3273b44bd0> #<Tag:0x00007f3273b44860>

Thanks for the clarification, only inquiring because I just got my Pi 4 8Gb (ordered prior to reading your guide :frowning_face:), and preparing to start an all new install in an effort to upgrade my instance of Hassbian running on a Pi 3b+, and looking for the cleanest install option, utilizing minimum system resources to allow for optimum performance, and full control over the native OS

Following this guide you will - in a not so distant future - be able to do ALL updates (HA, OS and supervisor) through simple clicks in the HA frontend.

1 Like

Updating Raspberry Pi OS literally takes 1 min, once a month, or less often if you choose. Other than that, you do nothing to the OS and use and update HA, add-ons, Supervisor, as normal from the web interface.

@Coolie1101 running a Supervised install is very simple, however, you may find it easy to use the official HA OS image as is used in this guide.

After reading the 0.118.0 release notes and watching the release party stream yesterday it seems that 5.x of HA OS is getting very close to a stable release and native install on an 8gb Pi4 will be supported OOTB.

Are you saying following this guide is best, or HA OS on Raspberry Pi OS?

I don’t want to suggest not to follow someone else’s guide. The choice is up to you. Both options work and have advantages and disadvantages.

This is what I’m trying to figure out.

I did a test install on another Pi3b using your guide here but it shows unsuported installation.

image

Correct, Supervised on any other OS than Debian 10 is ‘officially’ unsupported. It still works without issue though (my own backup machine is a Pi4 4gb with a Supervised install).

Even Frenck runs an unsupported install from what I saw in the live stream yesterday, so it’s not a huge deal. All it means is that you will need to reply on the forums for support and can’t post issues to Github.

1 Like

@kanga_who are there any advantages in installing HA supervised on a separate OS?

Do you run both simultaneously?, how does that work?, I always assume I cannot have 2 instances communicating to the same devices or using the same addons simultaneously, i.e. zwave, nest, etc…

Definitely - you are able to leverage the underlying OS to install software that isn’t available through the HA platform. It’s also very easy to remove and re-download HA should you have the need, without needing to re-flash the SSD/SD.

I don’t have the Pi running any automations or doing any work, although the config between the 2 machines is 99% the same. I simply have things like automations commented out so they don’t run. If for some reason my production machine goes down, I can log into the Pi, change it’s IP, un-comment some yaml and reboot to have HA back up and running again within minutes.

It’s overkill, but I have the equipment laying about, so I use it.

1 Like

Good to know, never thought about duplicating configs the way do, that could have saved me alot in the past, do you use Z-Wave, if so, how would you handle the transition between hosts?

No I don’t, only Zigbee for non-essestial items like Temp and LUX sensors.

Probably getting a little off topic now though :wink:

Was just thinking the same, maybe if you have the time, you can share a dual setup for us noobs.

Cheers.

1 Like

Thanks for the detailed guide, helps alot.

Hello,

First of all thank you for this guide, i manage to achive the up and running system in 10 min with snapshot restored.
The only problem is my MHZ-19 CO2 sensor connected directly to the PI UART PINS (14 , 15) , this worked fine before with HASSIO 4.X and SD card. I added enable_uart=1 in the config.txt.
I can see /dev/ttyS0 under System–> Hardware, but HA dont receive any data from that sensor.

I followed this guide to setup the MHZ-19 sensor: https://home-assistant-china.github.io/components/sensor.mhz19/

Anyone have a method for getting it onto the SSD when SSD is connected to rPi and you cant connect it direct to a PC? I brought m.2 rpi case and didnt think of a usb adaptor to flash it on PC :frowning:

The HA image download page says:

  • Raspberry Pi 4 Model B (1 GB, 2 GB and 4 GB model) 32-bit (32-bit is required for GPIO support)
  • Raspberry Pi 4 Model B (1 GB, 2 GB, 4 GB and 8 GB model) 64-bit (64-bit is required for 8 GB model)

So it seems you have to use the 32-bit version to use GPIO. And it seems there is no way to use GPIO on an 8Gb model because it requires the 64-bit version.

I saw the info from HA image download page and made some research before using the 64 bit image.
It seems that info is outdated and I received some confirmation that GPIO should work also on v5.5 64 bit.
After my post i notice something, the sensor receive some data from time to time (not reliable) but this confirm that it should work.
image

And anyway, booting from SSD works only with 64-bit, so i had no choice.

@leo23 this is interesting news. Where did you find the info that GPIO is working with the 64 bit version? Couldn’t you use HA’s serial integration to directly test the GPIO communication? I guess you would have to temporarily disable the mhz19 sensor platform for that test.

Tried to install the new homeassistantOS with rpi4 / 2Gb but it did not work, have installed hassos 5.3.img/32-bit ,on a SANDisk ssd 120Gb, connected to DELTACO SATA connector, have followed exactly as stated in the description.
With the same DELTACO SATA connector and the same Rpi4/2Gb ,I got started new raspberry pi OS to boot from ssd CRUCIAL 120Gb and worked.
Could it be SanDisc SSD that is the problem?