Installing Home Assistant OS using Proxmox 7

If not available, you can install SSH with this.

apt install openssh-server openssh-client -y

Yeah, I went the route of firing up a Debian VM then installing on that. The bummer is I can’t pull the configs off the old VM since that was installed using the script from the Proxmox CLI.

/bin/ash: foo: not found is a common result when doing things on the underlying OS.

What are you trying to run that is giving you that?

I open a console to the HA VM then login to the underlying OS. Any command like apt, find, etc. gives me the not found response.

1 Like

@kanga_who I’m following the instructions to install on my NUC. I’ve made it to Section 2.2. When I type

apt-get install sudo

I get this:

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package sudo

Not sure what to do next…

Edited to add: I found the post above by @Hs82H and that worked. Could I suggest that you add that to the initial post? Thanks!

@Hs82H and @Anwen, This has been added, thank you.


Thank you very much for the detailed guide - I now have Home Assistant running on my 4th gen i5 NUC which has 8GB of memory and a 80GB mSata SSD drive. I gave the HA VM 4GB of memory, 2 cores and 32GB of disk space. It seems to be running at a little over 50% memory usage - I’m a bit surprised that it is using that much memory, as folks in this thread seemed to think 2GB was enough for HA.

HA VM stats

I have one question - I have the systemmonitor sensors set up from my previous Supervised install on Ubuntu. They are showing data, but are these giving me accurate information given that HA is running in a VM? They don’t correspond to what I see in Proxmox - they are showing about 4% CPU use and 22% memory use.

platform: systemmonitor
    - type: disk_use_percent
      arg: /
    - type: memory_use_percent
    - type: processor_use
    - type: last_boot

Memory use reported by Proxmox is the basic output of the “free” command. It includes kernel filesystem cache and buffers, both of which can be released very quickly at any time.

It’s not a good indication of process or even truly a Linux VM’s real RAM use. Even a VM with a tmpfs filesystem if you have a distro that uses that, will affect that number.

You’ll have to get into the VM and use the various switch options for “free” or tools like vmstat, top, htop, or others to get a real understanding of RAM use in any Linux.


I am having issues of the condition: time part of my automations not working. Trying to trouble shoot.

The host which runs Proxmox is on Europe/Berlin. The container running is in the correct timezone (Europe/Berlin). Same is the UI.

The VM (which runs the hassio container) which I set up the script mentioned in the initial post is still on UTC.

Host (localtime)
Container (localtime)

On VM:

$ timedatectl
                      Local time: Tue 2020-06-15 07:59:09 UTC
                  Universal time: Tue 2020-06-15 07:59:09 UTC
                        RTC time: Tue 2020-06-15 07:59:10
                       Time zone: Etc/UTC (UTC,  +0000)
       System clock synchronized: yes
                     NTP service: active
                 RTC in local TZ: no

I am trying to change that in the VM with

$ timedatectl set-timzone Europe/Berlin
Failed to set time zone: Failed to set time zone: Read-only file system

This changes the localtime until next reboot of the host or the VM. Not perfect.

How can I change the timezone of the VM inside Proxmox persisting a reboot?

I checked. Changing to localtime on the VM solved my initial problem of the time conditions not firing.

Best regards.

1 Like

Does anyone know how to set a static IP for the VM in the Proxmox GUI? (please no answers about static leases etc ect).

I can do it on the OS but I’m sure I should be able to do it at the VM level as you can with ESXi.

Apart from the above query, this guide is awesome. I had an old laptop, put some more memory in it and it is running Proxmox with a HomeAssistantOS install - just so easy. Old laptop = battery = UPS! Only drawing 14W so a definite alternative to a Pi.

Easily installed a Let’s Encrypt SSL cert so I don’t get the silly SSL warning.

Only additional thing I had to do was to stop the laptop suspending when I closed the lid - edit /etc/systemd/logind.confas root and…


restart the service or reboot your machine

systemctl restart systemd-logind.service

Job done. Thanks @kanga_who.

1 Like

I would set it up on your switch or router to the VM’s mac address.
I’ve been running my HA on Proxmox for the last 6 months or so and that it was I do with any VM/CT that i need to remain static. Then if you need to spin another copy you have the option of selecting Unique to create a new MAC (and subsequent new IP) or just reuse the original.

I use an internal FQDN so I can get LetsEncrypt certificates so a fixed IP is easier. You can set container IPs in Proxmox but I’ll need to do it on the VM via the command line.

just wondered if I’d missed something as you can set the VM IP in ESXi.

I did by opening the shell in the Proxmox node, and going to;

nano /etc/network/interfaces

and changing this info, then reboot.

auto vmbr0
iface vmbr0 inet static
        bridge-ports eno1
        bridge-stp off
        bridge-fd 0

Thank you for your guide.

unfortunately i have some problems with the new installation.

Currently running “HassOS” on ProxMox > Ubuntu > Docker > hassOS

i tried the installations script from Whiskerz007. Unfortunately Deconz does not work for me anymore, I cannot find any Zigbee device. The stick is connected and assigned to the VM and the old VM is shut down.

Someone maybe has similar problems?

I have a quick question.
I am thinking of going back to Proxmox, can two different VMs use the same USB device?

yes, but not at the same time. so no is the answer

Just to clarify, you are running (or trying to run) an Ubuntu VM, and have then installed HassOS in that VM? That’s unnecessary layers.

Run two VM’s - HassOS using the script as per this guide, then a separate Ubuntu VM for anything else like an MQTT server, Plex, etc. That’s how I have mine installed and HassOS sees USB devices without issue.

What’s the recommended best practice for hard drive setup under this install method?

I’m moving from a RPi 3B to an Optiplex 3020 with a 4th gen i5, 12 GB RAM, and a 500 GB HDD. I’m adding a 256 GB SSD. Planning on a similar setup to @kanga_who, Home Assistant with add-ons like I have now, plus eventually looking to add an NVR setup and maybe Plex in separate VM’s down the line. What is the best setup in terms of which drives should hold Proxmox itself, as well as my VM’s and data?

I have a 128gb SSD for Proxmox, and use that same drive for my 3 VM’s. I then have a 3TB WD Purple Drive to save all camera footage from Shinobi, and a 1TB SSD that holds my Plex media, but a HDD for Plex is also fine.

1 Like

yep i just want to run it with HassOS only, this is my old setup.

Unfortunately I have problems, Zigbee does not work although for example the firmware in deconz is recognized