Installing Home Assistant OS using Proxmox 7

I don’t only access Proxmox, so use Putty for all my SSH connections. Easier to have everything in one place.

Like @kanga_who I use terminal (I run MacOS) for all remote connections.

Worth remembering that putty/terminal is a remote connection and the Proxmox shell is a console connection as if you have plugged in a keyboard and monitor to the system - that is it works even without networking in the KVM/LXC.

This is depend on your need, in my case if I want a quick changes I will use Proxmox console which usually performing update etc. However some hard function which required copy paste then I will use the SSH terminal. I know that in most cases depend on your console setup you can also perform the same task on console. But anyway that is just me. Everyone will have their own preferences

@kanga_who thank you for your contribution! Moved from the raspberrypi install methods to new proxmox box!

The script installs Home Assisnatnt OS 8 RC version, followed instruction all went smooth, restored my old config fro HA untill I noticed random (under investigation) Home Assistant reboots. VM does not restart.

Then started from scratch deleted VM made manual install, Home Assisnatnt OS 7.6 same. Deleted VM again, manually istalled Home Assisnatnt OS 7.6 and new home assistant configuration from zero same results. Changed recorder to default (i was using mariadb in my Supervised raspberry install), same.

Nothing obvious in all the logs. Switched logger to info today.
Any clues where to look?

Worked like a charm. Very much appreciated.
Running it on Promox 7 now on a Intel J4215 plattform with 4 cores and 16GB RAM.

So, I’ve installed using this guide and don’t see the IP address coming up. It shows “Guest Agent not running”.
Just like Installing Home Assistant OS using Proxmox 7 - #180 by Judman13 this user experienced, the output I’ve got when running the update commands is:

# sudo apt update && sudo apt dist-upgrade -y && sudo apt install                                                                                                              qemu-guest-agent -y && sudo apt autoremove --purge -y
Hit:1 http://security.debian.org/debian-security bullseye-security InRelease
Hit:2 http://ftp.debian.org/debian bullseye InRelease
Hit:3 http://download.proxmox.com/debian/pve bullseye InRelease
Hit:4 http://ftp.debian.org/debian bullseye-updates InRelease
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
All packages are up to date.
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
qemu-guest-agent is already the newest version (1:5.2+dfsg-11+deb11u1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

What should I do to have this solved?

If you’ve used the script above in the past 24hrs, it is broken, it downloads the wrong image (haos_generic-aarch64-8.0.rc3.vmdk)

Yes, I’ve used it today. Any idea for a solution or workaround?

Use the Home Assistant OS VM from https://tteck.github.io/Proxmox/

2 Likes

Here’s my take on “is the way

Prior to Section 1, you will want to ensure UEFI Boot & Virtualisation is enabled and Secure Boot is disabled in the bios of your machine.

Section 1 - Use this guide
Section 2 - Use Proxmox VE 7 Post Install script*
Section 3 - Use Home Assistant OS VM script*
*Always remember to use due diligence when sourcing scripts and automation tasks from third-party sites.

Enjoy

1 Like

After many days of testing I realized that at random my addons were not loading at all, same with my system tab that has the logs and supervisor info etc, my network usage was decreasing, cpu and ram usage was increasing. That time I was having either a home assisntant restart or addons staying frozen with integrations working.

The problem seems to be the odd home assistant OS DNS behaviour described here and in many more post at github:

Solution here:

I am using Home Assistant OS on Proxmox with pfSense running on the same VE.
Hope that I have helped !

I have been banging my head against a wall for hours following the original guide with scripts multiple times and not getting anywhere. Glad I scrolled all the way down here. I have been trying to fix a "Guest Agent not running” issue but really the container never really started up to initiate the Guest Agent I suppose. Thanks.

1 Like

I’ve installed HAOS via the script ten times. I still cannot get past the Preparing Home Assist screen. I’ve scoured these forums, cutting and pasting from my error log. Nothing. Here’s where I think the problem is:

22-05-03 00:15:28 ERROR (MainThread) [supervisor.supervisor] Update of Supervisor failed: Can’t install ghcr.io/home-assistant/amd64-hassio-supervisor:2022.04.0: 500 Server Error for http+docker://localhost/v1.41/images/create?tag=2022.04.0&fromImage=ghcr.io%2Fhome-assistant%2Famd64-hassio-supervisor&platform=linux%2Famd64: Internal Server Error (“Get “https://ghcr.io/v2/”: net/http: request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers)”)
22-05-03 00:15:28 CRITICAL (MainThread) [supervisor.core] Can’t update Supervisor! This will break some Add-ons or affect future versions of Home Assistant!

Any suggestions as to where I’m going wrong with this install would be greatly appreciated. Thanks!

It seems it can’t connect to the outside network. Internet…

For those who couldn’t get it working like me, I followed the commands at: How to Install Home Assistant on Proxmox

And got it working. Hope this helps, I thort my old machine was the issue. Turns out it was fine.

I ran through the OP yesterday to test. Worked as it should.

1 Like

I went through 4ordy’s install processable above. Cannot get past the supervisor starting.

I think this has to do with my Netgear R6700v2 router Netgear GSS116E switch. Looking into that. I’ll update what I find. Just in case someone else is having this issue.

Failed for me at 3.1 but started step 3.2 up to the “click OK” and then selected >_Shell to open console as root. Then I followed the steps offered by mochman on Jun 9, 2021 here:

which kept me going at least through 3.8.

The script in 3.1 is working as intended. The script doesn’t use anything with file extension zip.

Gret Script and great Tutorial!
I followed every step and then i restored my last fullbackup from my previous rpi3. Since then i cant seem to find Supervisor anymore. The Addons menü does not list it anymore but it can still be found in integrations -though all its entities seem to be disabled.
I tried 'ha core rebuild command to restore it but with no luck.
Anyone else having this issue?