Installing Home Assistant OS using Proxmox 7

Anyone using Proxmox that have issues with USB passthrough with an USB UPS?
I tried Eaton and APC

I’ve defined the USB in the VM but it seems that HassOS, but also Ubuntu+HA Supervised, does not show properly the USB in the Supervisor->System->Hardware panel

I have also a Conbee stick for Zigbee and it does work fine (tried to remove the definition from VM and/or from NUC, but no changes).

Any suggestion?


Yes, I installed the Samba share add-on. Now I can access the configuration files with a windows explorer within my network.

could you do it with out the addon ?

No, it didn’t work for me without the add on…

Great work … it worked like charm
could you please explain more about samba install?
should it be installed on proxmox machine or inside home assistant VM ?

Bro, this worked like a charm, thank you very much!
Maybe the part of empty the file is not 100% clear. Since I don’t use nano (I prefer vim) it is not obvious what the c-x and then answer yes mean. It will be better if you just say “make the file empty and then save, if you are using nano do it like this”.
Apart from that, terrific work, awesome, thanks, thanks, thanks.

1 Like

Thanks for the tutorial!
Worked perfectly fine, though I have a little question
My HA is now up and running and I wanted to ask, if I can just log out of the interface and relog as the created user instead of root. Does that shut down the HA instance and can I manage it completely with the user that I created throughout the tutorial?

1 Like

@kanga_who I just want to say thank you! Hats off

1 Like

To start off with over the last few years I have run HA on a Pi, upgraded to unRaid, then Synology and now using Ubuntu Server. Now that all the ado over being supported or not is picking up steam again I think it is time for a change AGAIN. Though I have a question.

In the Debian install directions you mention this “If you install Open-SSH you will not be adhering to the guidelines of [ADR-14]…”

As I see this as a gotcha. What are any gotcha in using the Proxmox method.
Would be nice if there was a spreadsheet comparison chart of install methods and pluses and minuses of each. (Maybe there is but have never seen it)

None really. Following the guide will give you a HA OS image based VM (Similar to what would be used on a Pi), so as long as you use add-ons available within the HA store, you will have a full supported install.

Thanks. I will give it a go

It’s a great script. That being said, I will go back to an lxc container based on Ubuntu and a python venv for running Home Assistant.
The reason is the resource consumption of the lxc container compared to the VM installation:

lxc container:
Idle CPU Usage: 0.5%
Idle RAM Usage: 140MB

Idle CPU Usage: 9%
Idle RAM Usage: 1.9GB

(Intel J4005 CPU)
Unfortunately I have to go without the Supervisor/Add-Ons now, but it seems that this is not so crucial…

Does that matter? Are you running anything else on the machine that is affected by those numbers?

Yes, I have multiple other containers running on the Intel NUC I use with Proxmox. Therefore I try to not run into any resource bottlenecks. While the CPU still has enough free resources, the RAM (4GB) is at its capacity limit when I use the VM approach for Home Assistant.

Fair enough. Maybe a RAM upgrade is in order :wink:

Thank you for this guide. Just used this guide to switch my HA OS install from a rasperry pi to a dell optiplex 3020m I purchased on ebay. Worked like a charm and got HA up an running with everything restored in short order. I had zero experience with Proxmox and the only area I stumbled on was the username for SSH and web interface. Once I figured out the username was “root” for the password I created in the Proxmox setup I was off to the races.

Now to figure out what to do with the rest of the resources available on the 3020m and my unused Rpi.


Whiskerz007 has a great lxc script, Debian base that is supported. (doesn’t say “You are running an unsupported installation” )

Forgot to mention, it has the Supervisor/Add-Ons


Nice, thanks for the Info!

It’s interesting because the devs have stated the LXC container is definitely not recommended or supported and will cause problems.

I’ve heard the same. I’ve been running it since it was created without any problems, and will continue until those said problems exist :slightly_smiling_face:

1 Like