Installing Home Assistant OS using Proxmox 7

Following the guide I run into problems with the Hass.io VM. It does not get an IP-adress. The guest deamon(?) does not start. Any pointers?

Hi. I’m running into the same problem. The guest won’t start.

@MWheeler72 and @Poppe, I’ve run the install script on an existing Proxmox install and can confirm it works as it should and have a new HA VM up and running with IP in under 5 mins.

I would suggest you either have a network problem, or, that you have not set up Proxmox correctly during the install process.

Check to make sure the VM has a MAC address… that did happen to me once. Once I set a valid MAC address all was well. Check in your router as well to make sure DHCP is allocating an IP Address…

Good idea :+1:

Hey, I am getting the same Guest Agent not running. Set up tonight following the guide. I have an IP and Mac for proxmox in my Unifi clients.

The Hassosova-4.15 Mac even shows up in the Unifi client list. I tried to assign it a static IP in Unifi, but I cannot connect to the Home Assistant web interface.

I am very new to proxmox so I could have a config issue, but I am not sure what.

A quick Google shows this for Proxmox guest agent. Have a read through this page and see if anything helps.

https://pve.proxmox.com/wiki/Qemu-guest-agent

I looked at that before, but since you brought it up again I gave it a shot.

Probably beyond the scope of this thread, but I installed that in proxmox through ssh and when I try to start the guest agent I get errors.

Journalctl gives me the following:
Oct 31 21:40:14 pve pvedaemon[24113]: VM 100 qmp command failed - VM 100 qmp command 'guest-ping' failed - unable to connect to VM 100 qga socket - timeout after 31 retries

From the article you linked it seemed to me like the guest agent needed to be installed into the VM, but I don’t have a clue as to how to go about that.

When I open the Home Assistant VM console (shell I guess) it does not accept apt-get.

Proxmox says the VM is running, I just cannot access it.

What do you get when you run this in Proxmox?

qm agent <id> ping
[email protected]:~# qm agent 100 ping
QEMU guest agent is not running

Have you tried to stop, then restart the HA VM?

It doesn’t respond to reboot or shutdown commands. I have been resetting it. Not sure if that is the right thing to do.

Edit: Probably because the guest agent isnt running so the VM doesn’t respond to ACPI commands.

Perhaps delete the VM altogether, then in Proxmox run;

apt-get install qemu-guest-agent
systemctl start qemu-guest-agent

then re-run the installer script

sudo bash -c "$(wget -qLO - https://github.com/whiskerz007/proxmox_hassos_install/raw/master/install.sh)"
[email protected]:~$ sudo apt-get install qemu-guest-agent
[sudo] password for moxmanager:
Reading package lists... Done
Building dependency tree
Reading state information... Done
qemu-guest-agent is already the newest version (1:3.1+dfsg-8+deb10u8).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
[email protected]:~$ sudo systemctl start qemu-guest-agent
A dependency job for qemu-guest-agent.service failed. See 'journalctl -xe' for details.
[email protected]:~$ sudo journalctl -xe
Oct 31 22:11:00 pve systemd[1]: pvesr.service: Succeeded.
-- Subject: Unit succeeded
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- The unit pvesr.service has successfully entered the 'dead' state.
Oct 31 22:11:00 pve systemd[1]: Started Proxmox VE replication runner.
-- Subject: A start job for unit pvesr.service has finished successfully
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- A start job for unit pvesr.service has finished successfully.
--
-- The job identifier is 105419.
Oct 31 22:11:07 pve systemd[1]: dev-virtio\x2dports-org.qemu.guest_agent.0.device: Job dev-virtio\x2dports-org.qemu.guest_agent.0.device/start timed out.
Oct 31 22:11:07 pve systemd[1]: Timed out waiting for device /dev/virtio-ports/org.qemu.guest_agent.0.
-- Subject: A start job for unit dev-virtio\x2dports-org.qemu.guest_agent.0.device has failed
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- A start job for unit dev-virtio\x2dports-org.qemu.guest_agent.0.device has finished with a failure.
--
-- The job identifier is 105346 and the job result is timeout.
Oct 31 22:11:07 pve systemd[1]: Dependency failed for QEMU Guest Agent.
-- Subject: A start job for unit qemu-guest-agent.service has failed
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- A start job for unit qemu-guest-agent.service has finished with a failure.
--
-- The job identifier is 105274 and the job result is dependency.
Oct 31 22:11:07 pve systemd[1]: qemu-guest-agent.service: Job qemu-guest-agent.service/start failed with result 'dependency'.
Oct 31 22:11:07 pve systemd[1]: dev-virtio\x2dports-org.qemu.guest_agent.0.device: Job dev-virtio\x2dports-org.qemu.guest_agent.0.device/start failed with result 'timeout'.
Oct 31 22:11:07 pve sudo[2306]: pam_unix(sudo:session): session closed for user root
Oct 31 22:11:17 pve sudo[2545]: moxmanager : TTY=pts/0 ; PWD=/home/moxmanager ; USER=root ; COMMAND=/usr/bin/journalctl -xe
Oct 31 22:11:17 pve sudo[2545]: pam_unix(sudo:session): session opened for user root by moxmanager(uid=0)
lines 3713-3748/3748 (END)

Have you checked to confirm your apt source list is correct as per section 2.3 of the guide? Just wondering if it’s a dependency issue from Proxmox not updating. I may be completely wrong, but worth checking.

image

pve-enterprise.list is blank, per the instructions.

Here is my sudo apt update return:

[email protected]:~$ sudo apt update
Hit:1 http://security.debian.org/debian-security buster/updates InRelease
Hit:2 http://download.proxmox.com/debian/pve buster InRelease
Hit:3 http://ftp.debian.org/debian buster InRelease
Hit:4 http://ftp.debian.org/debian buster-updates InRelease
Reading package lists... Done
Building dependency tree
Reading state information... Done
All packages are up to date.
[email protected]:~$

I can not reproduce the problem on an existing Proxmox install. I have re-run the install script on 2 different machines in 2 different locations, one at home, one in my business.

I have a spare machine at home, so will try a fresh install of Proxmox this evening, or tomorrow and report back.

Thanks. I am going to try and restart from scratch as well.

1 Like

Is guest agent enabled in the vm options?

2 Likes

It is enabled. I have tried disabling and reenabling with no change in behavior.

1 Like