Installing Home Assistant Supervised on a Raspberry Pi with Debian 11

As part of the installation (Debian) provided you DON’T enter a root password it will install sudo. It will also prompt you to create a user. It’s quite simple and well thought out actually.

There is a REASON supervised installations are referred to as advanced so maybe as a self identified clueless noob this method isn’t for you.

1 Like

Hi - I get an error during the Partition disks section of the install. ‘This probably happened because there are too many (primary) partitions in the partitions table. Can someone guide me on how to do this part manually ?

  • Configure software RAID
  • Configure the Logical Volume Manager
  • Configure encrypted volumes
  • Configure iSCSI volumes
    I got a Kingston A400 - 120GB.
    Thank you for your guidance.

So, an update… I never did get this install to work properly - so I caved and just installed Home Assistant OS. It works fine, but now my pi is stuck with only Home Assistant. I was hoping buying a pi4, a more powerful device, that I could run Motion Eye and not bog down the processor too much. Now I can only install MotionEye as a Home Assistant add-on; which doesn’t work either - I just get “Bad Gateway” errors all the time… a long running problem with that addon. But that’s for another forum topic.

Thanks all the same for all your help.

On Raspberry Pi 3, The HA OS was causing the RasPi to freeze in less than 24 hours, so I am trying Debian 10 type supervised install. The first installation did not work with wifi, because before I started HA in web, I installed wicd-curses and set up wifi access in host and changed the hostname as well. Then the wifi setup did not work from Supervisor. I also could not upload backup image, right after upload the HA restarted and after reboot the backup image was not uploaded.

My last problem was that during installation, I always get many warnings that locale and all those LC… variables are not configured. Is there some very easy way to set it up?

Be careful … today after debian update (kernel 5.10) RPI4 with ssd not boot for me :frowning:
Noob question: How to boot rpi-debian with old kernel (5.9) after apt update&upgrade? Recovery mode or something like that.

1 Like

Just experienced the same. Latest Kernel for Debian on Raspi 4 renders the device unbootable!

I tried this with 2 different Raspberry 4 4GB but as soon as the Kernel updates to the latest, boot process will stop at:

vcc-sd: disabling

This also happens on new installs onto a freshly formatted SSD but also with existing installations!
Just avoid updating the kernel (for the time being).

To put the kernel update on hold type the following at the CLI:

sudo apt-mark hold linux-image-arm64

I hope this notice will help others from disaster (luckily I did a full snapshot today)

To avoid “Unattended Upgrades” (if you have that activated) updating the kernel silently in the background do:

sudo nano /etc/apt/apt.conf.d/50unattended-upgrades

Add following into blacklist.

linux-headers*
linux-image*
linux-generic*
linux-modules*

The blacklist section should look like the following:

Unattended-Upgrade::Package-Blacklist {
      "linux-headers*";
      "linux-image*";
      "linux-generic*";
      "linux-modules*";
};

I was able to update my fresh debian installation from 5.9 to 5.10 but before the update:

echo reset-raspberrypi > /usr/share/initramfs-tools/modules.d/raspi-firmware.conf

The bug is related to “initramfs-tools” (https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=977694#67)

2 Likes

Wondering why initramfs-tools v0.140 which fixes the issue is not available before kernel 5.10 for Buster got released because this is not a I-wanna-be-on-the-bleeding-edge-Update but gets installed during a regular system upgrade through:

sudo apt update && sudo apt upgrade -y && sudo apt autoremove –y

which I run once a week to download security patches and keep the OS up to date.

As for buster (stable) the latest is still v.0.133 but v0.140 is available for sid (unstable) only.

I will refrain from using the proposed workaround and keep the kernel update on hold until initramfs-tools v0.140 comes with a regular update to Buster.

1 Like

Hi,
I’m trying to do a fresh install and I’m receiving the same error. How would you recommend I modify the reinstall based on the developer’s instructions. Thank you

Today was the day that I chose to leave Raspbian and move to Debian :sweat_smile: .
As @Tamsy mentioned above after you login to your fresh install before any update
To put the kernel update on hold type the following at the CLI:

sudo apt-mark hold linux-image-arm64

Did it earlier. Tested.

2 Likes

Thank You @thanoskas and @Tamsy.

For what it’s worth if you still need it or others.

I was able to edit the boot.cfg file and change the 5.10 references to 5.9 filenames. You can connect your usb/ssd drive via another computer and edit that file easily

2 Likes

Few things that are missing : enable SSH, root SSH login allow, after install network manager is good to configure your WiFi using NMCLI. On precompiled image for Rpi3, there is issue with built-in voltage sensor Fe missing (thus Rpi power checker add-on doesn’t work) and with Esphome xtensa toolchain. I made my own tutorial for Rpi3, if anyone interested .

Please let us know if this bugs fixed and how do we change the hold command?

Whenever you want to change the package hold comand, just execute through CLI:

sudo apt-mark unhold package_name

got it…thanks

What I do is edit the source.list file and add # to the unstable branch line:

sudo nano /etc/apt/sources.list

# deb http://deb.debian.org/debian/ unstable main contrib non-free

How did that get in there in the first place?

As for the standart Debian 10 Buster installation for the pi4 sources.list contains by default:

deb http://deb.debian.org/debian buster main contrib non-free
deb http://deb.debian.org/debian-security buster/updates main contrib non-free
# Backports are _not_ enabled by default.
# Enable them by uncommenting the following line:
# deb http://deb.debian.org/debian buster-backports main contrib non-free

The official Debian image for raspberry 4:

https://raspi.debian.net/tested-images/

raspi 4 needs the latest kernel (5.5 or higher) and raspi-firmware newer than buster’s

P.d.: I think I remember that the default image had this activated, but I’m not sure about it.
maybe I added it to update something.

The latest image for Raspi4 comes with kernel 5.5.9 and works well with it. No problems with booting from SSD.

But kernel 5.5.10 which Debian tries to update to through sudo apt upgrade brings trouble because initramfs-tools needs to be v0.140 but the original image which comes with initramfs-tools v0.133 makes booting from ssd fail with the latest kernel 5.5.10.