Installing Home Assistant Supervised on a Raspberry Pi with Debian 11

Not sure about setting quirks for the StarTech controller. It was listed as a good one.

Worth a try?

I see you mentioned about the MAC being randomized after a reboot on an Ethernet connection, is that correct?

Yes. I’m going to try it now. I think a bigger issue is the MAC being randomized after a reboot on an Ethernet connection. Any idea on how to fix it. My router assigns the ip address to the pi based on the mac address

That is very odd and not expected behavior. I don’t have that issue on my testing unit Pi4 using this guide external SSD.

Might be worth submitting a ticket on Github for the issue, or finding an existing ticket if there is one, that is addressing the same issue with WiFi.

I think it has to do with the router is assigning the address? I do not know Debian well enough. How do I edit the network file and set the DNS, gateway, IP, etc?

Have you given the Pi and fixed IP in your router? If the MAC is being randomized on reboot this won’t really help though.

It does not do this with HA OS. I set it there for static IP for duck dns connection.
What file do I need to edit for Debian for static IP

Easiest is to just use the IP setting in Supervisor as it will write to the same file itself for you.

1 Like

As David suggested, try this, obviously change to suit your network config.

This is after Home Assistant is installed. Correct? The problem here is that I have lost my network after a reboot. I need to do this early in the process.

I just tried a new Debian and before a reboot I followed the directions to add Samba (doing this before installing docker and HA). It errors with
sudo service smbd restart
unable to resolve host rpi4-20210210: Name or service not known.
I have fixed this by modifying the host (s) files. Not sure why I need this.

Don’t worry about Samba for now, just do a clean Debian install and get HA running and test stability. You can use the Samba add-on in the store if needed, but later.

The reason for this is that this is very quick test. And it does not work for me. Doesn’t make much sense to try and install HA if I can’t get easy stuff in Debian working?

I will try and continue with the Debian install directions, load HA and change the network. Maybe this will fix the issues?

I booted and in system it will not let me save the address.

I assume the network config you have input is within your network range? If so, I have no idea what your issue is. My Pi does not have this problem.

You’re definitely using the Debian 10 Buster image from the download link, and not the Debian 11 Bullseye image, correct?

I am using the correct buster image. Tamsy recommended that I do a sign out / reboot after I add the new user and assign the user sudo properties.
I’ll try this later and see if it works.

I have the StarTech 3.1 (also a 3.0) which is supposedly supported as is. What do you recommend?

Well, you can check my script and see if you do something wrong doing the installation if you dont wanna used it.

So far using that script I have no problem with HA + Supervised version on Debian 10. Which also have installation for Docker, Samba, Nginx, and portainer if needed to check the logs.

I had this odd behaviour with Raspbian (every 24h or so, losing ethernet connection and also the USBs) moved to Debian following that post, things got better and solved when used orico hub with external power always plugged and with no USBs attached outside my hub. I am stable for more than a week now so I consider it solved.

After all that I think it is a usb power issue (In my case maybe yours too).

I have an in line meter and don’t see the power issues that people are claiming. The most I have seen being drawn was under an amp and a half. I have tried two different supplies that are rated at 3.5 A and 3 amps respectively. I think the issue for you got resolved by changing controllers. I see some people tested using a lab supply that was rated for 5V / 50A . Of course the PI can never draw this amount of power. It made no difference. It still locked up for them.

Which Orico hub did you end up purchasing?

I am refering to usb power issues/ limitations, not main power. I had measured input voltage and seemed nominal.

I have TWU3-4A hub with M2PV-C3 nvme enclosure.