Installing Home Assistant Supervised on a Raspberry Pi with Debian 11

Lay back, chill and let the HA devs do their work. They will tell us whether Debian 11 meets the requirements of the supervisor :+1:t4:

1 Like

The reason that I want to update is that it now has the same kernel as the HAOS. I want to see if that is what is causing my PI to freeze or if the HAOS is. As you know, I have no issues with Debian 10.

Hello, I need some help. I decided to follow your guide but I cannot install debian. The installation process gives me this error.

Gave up waiting for root file system device. Stuck at Busybox

Debian is obviously installed but unable to boot?

  • On what hardware storagewise (sd-card or external ssd)?
  • Which image exactly did you download/install?

Unfortunately I am unable to help if you have downloaded/installed Debian 11 at this time.

I am trying to install it on a Raspberry Pi 4 8GB with a M.2 Samsung SSD (Argon Case). I have downloaded the correct version of Debian 10 image

It gives me an error, something like

Begin: Running /scripts/local-block … done.
Gave up waiting for root file system device.
ALERT! LABEL=RASPIROOT does not exist. Dropping to a shell!
BusyBox v1.30.1
(initramfs)

Looks to me like the M.2 Samsung SSD is not detected thus not initialized during boot.

This indicates that you need a newer image which contains initramfs-tools version 0.140 because with initramfs-tools version < v.0.140 the reset_raspberrypi module does not get included.

Since you have installed the Debian 10 image it looks have you run
apt update && apt upgrade -y
without setting
apt-mark hold linux-image-arm64
beforehead!

During that update Debian upgraded kernel v. 5.5.9 to v.5.5.10 which is not compatible with initramfs-tools v0.133 (which is the default for Debian 10 on RPI4) because kernel v.5.5.10 needs initramfs-tools v0.140. More information about the latter here.

Check @Koal4’s post #222 above on how to solve the issue.

Hey there,

I’m having the exact same problem like djacid. I followed the guide, flashed the image on an SSD and get the same error. Flashing the image on an SD card works like a charm.

The problem is, I don’t event get far enough to install debian, so I can’t try your solution. So I flashed it all new again and followed the linked solution by Koal4, but I can only find the 5.10 files on the drive. Is it possible that the newest images are already coming with the 5.10 kernel?

I’d like to try again with an older image, but can’t find any.

1 Like

Thanks. This image definitively works better. Well…at least it starts to install. The error from the other image is gone, but now it was stuck when resizing the partition. Perhaps it just needs more time since I use a 120GB SSD, but unfortunately for now I’m out of time tor today. Family is calling.
Tomorrow evening, at the latest, I can give it another try.

You are welcome. I will remove the dl-link by tomorrow.

Best is to stick 100% to the instructions on the 1st. post and you should be good.

1 Like

This is the problem. I have not installed debian. I got this message during the installation procedure

If the installation procedure is succesful, please give me a feedback to know it

Try to do a fresh install with the Debian 10 image I shared further up. 20210210 comes still with kernel 5.9 and should work.

1 Like

So, just now I plugged the yesterday used SSD back in. To my surprise it booted up, although i killed it yesterday.
But now, when trying to install HA, following error shows up:

[email protected]:~# apt-get install -y software-properties-common apparmor-uti ls apt-transport-https ca-certificates curl dbus jq network-manager
Reading package lists… Done
Building dependency tree
Reading state information… Done
dbus is already the newest version (1.12.20-0+deb10u1).
dbus set to manually installed.
Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
linux-image-arm64 : Depends: linux-image-5.9.0-0.bpo.5-arm64 (= 5.9.15-1~bpo10+ 1) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

So, tried again with an 16GB USB Drive to exclude the killing of the SSD as source for the error, but that didn’t help.

Although I’m a noob in Linux, I’m able to read and can see the 5.9 like the one from the kernel version. For me it looks like there still is something going wrong with the kernel.
Sure, I can’t really help with knowledge, but at least I don’t mind trying different setups :sweat_smile:

But I have a small question on the side: What do you think how likely it is for me to get my HA running on an SD cloned to the SSD? It’s build up on the newer 20210718 image, which wouldn’t boot from SSD. Or should I consider creating a snapshot, flash the SSD with a booting image and then restore the snapshot? Whereas there currently is no working image :joy:

Reinstall debian 10 to your SSD and be sure after you run Debian on your first boot and run apt-mark hold linux-image-arm64 Once you do that then you need to apt-get update && apt-get dist-upgrade -y && apt autoremove -y and then you can install the rest.

It should working correctly

… will upgrade Debian 10 to Debian 11.

2 Likes

Did you logged-out as root user and run above command as non-priviledged user by

sudo -i

before apt-get install -y .... as described with the instructions?

Please also show what
sudo uname -a
is saying.

Yes, I followed the guide step by step. Right after connecting with putty it says ‘[email protected]’ while marius is my username. After sudo -i it says ‘[email protected]’.

sudo uname -a says

Linux rpi4-20210210 5.9.0-0.bpo.5-arm64 #1 SMP Debian 5.9.15-1~bpo10+1 (2020-12-31) aarch64 GNU/Linux

The kernel version is correct, that shouldn’t be the culprit. Did you start with a clean install on a “virgin” SSD? Did you install the latest RPI4 firmware before?

Yes, always deleted the volumes on the SSD and then flashed the image using etcher v1.5.115

In the meantime I flashed Raspberry OS on an USB stick, updated the firmware from 2021-04-29 to 2021-07-06 and changed the boot order to USB->SD->Network.
After this, the SSD gets reset several times during boot without making any progress. So I now use another USB stick for testing, but with the same results as before the updated firmware.