Installing Home Assistant Supervised on a Raspberry Pi with Debian 11

Hi everyone,
I’m experiencing the same behavior with a fresh install of Debian on rpi4 2G / SSD (linked by argonOne M2)
Linux rpi4-20210210 5.9.0-0.bpo.5-arm64 #1 SMP Debian 5.9.15-1~bpo10+1 (2020-12-31) aarch64
Everything’s fine until point 2.1 and the apt-get command. Then same error than @Eiskonfekt

Edit : did apt-get one by one and error is raised by network-manager :
[email protected]:~# apt-get install -y network-manager Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
linux-image-arm64 : Depends: linux-image-5.9.0-0.bpo.5-arm64 (= 5.9.15-1~bpo10+1) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Is the problem I had and as I was using this guide trying to just run frigate in docker but I went with Raspberry Pi OS Lite as it’s the only way to get FFmpeg Hardware Acceleration to work on rpi4.

Are you using the same hardware as @djacid (Raspberry Pi 4 8GB with a M.2 Samsung SSD (Argon Case))?

As for the Argon ONE M.2 this hardware should be compatible for RPI4 SSD-boot. A extensive list of compatible Raspberry Pi 4 USB controllers / SSD / Flash Drives can be found here.

For the Argon casing I have no experience with this one but there are quite a few threads on the HA forum discussing this hardware. Maybe you want to take a look here?

I’m using an Pi4 8GB with an Intenso Premium 128GB SSD. Now that I know about the potential USB drive issues I searched for this drive in combination with a Pi4 and yes, seems like I need the USB quirks to get in working. Gonna try this out later.
At least this might explain my problem with the SSD getting reset and reset and reset again. But as I’m not the only one with the error after apt-get, I don’t think that the usb problems are causing the failing installation

Edit: Applied the USB quirks. SSD works again, but as expected it did not effect the installation

What do you mean? Do you mean that with this distribution of Debian installation of frigate is impossible?

No it does work but out of the box but frigate FFmpeg Hardware Acceleration doesn’t work with

hwaccel_args:
- -c:v
- h264_v4l2m2m

and causes the feed to green screen and gets this error.

ERROR : [h264_v4l2m2m @ 0xaaaacfd8bbe0] Could not find a valid device`

and I don’t know why or how to get it to work on Debian.

But when installing the requirements in this guide it can’t install the network-manager as it can’t find the version for the 5.9 as I went through the requirements one at a time and network-manager was the one causing it to fail to install the requirements.

So maybe all we need to do is not to install the latest network manager but install an older one? I’m not this far into Linux to know the needed shell command.

On the other hand, when I first tried to install HA following this guide, it didn’t work using a SSD or an USB Stick, but flashing on an SD card did work. Right now I just don’t understand why it would make any difference in the used media, when an wrong software version seems to be the problem.

Same but as I used this guide to get just frigate in docker for testing and hardware acceleration not working I gave up used Raspberry Pi OS Lite.

It’s something to do with the latest image build dated 2021.07.18 some things not right with booting with USB at a guess.

I tried another box (startech), same issue.
Looks like the command apt-mark hold linux-image-arm64 is blocking installation of network-manager

So…has anyone made any progress with getting rid of the issue?

Something you have to do anyway between now and 4 months : upgrade to Debian 11 (Bullseye)

Just wanted to let you know that using this guide on Debian 11 works without any problems even on my SSD. But for now I’ll stay on Debian 10 and my installation on the SD Card as pi-hole doesn’t officially supports Debian 11 yet.

1 Like

You might be interested in trying out the AdGuard Home add-on. I switched to it from PiHole some time ago and it does a great job.

Successfully installed; thank you so much for this guide. Setup - Pi4 8GB with Debian 11 on a 125GB Kingston SSD external drive and also utilizing the CanaKit 3.5A power adapter makes a difference.

1 Like

Just a quick note to save others some time and effort.

I tried but failed to make an RPi 3B boot from a Western Digital My Passport SSD (external 256 Mb SSD, USB 3.0). It appears that published instructions aren’t kidding when they say the device must be USB 2.0.

  • I programmed the 3B to support USB booting and confirmed it did by booting from a USB2 flash drive loaded with Bullseye.

  • I connected the external SSD and the 3B refused to boot.

  • I added an SD card equipped with bootcode.bin but that didn’t help the 3B boot from the My Passport SSD.

As a final sanity check, I loaded the latest Ubuntu image on the SSD, plugged it into a USB3 port on my Windows PC, restarted it and it booted into Ubuntu (i.e. nothing inherently wrong with the My Passport SSD device).

tl;dr
3B’s USB booting is constrained to USB2 (just like the documentation states).

1 Like

Upgrade from 10 to 11 was without problems. Fresh install was also flawless. Raspberry pi 4 2G with argon m2. Thanks @kanga_who @Tamsy !

2 Likes

I used this tutorial to install ha supervised on rasperry pi 3b+ with Debian 10 but have problem with system crashes after some time of working, without any info in logs and independently from load/memory usage. I already tried eliminate described possibility of failure - wrong adapter, by installing on sd card instead ssd disc, but same problem - system freeze without warning. Everything have been working properly when I was using rasbian instead debian. Any idea how to eliminate those freezes? Or how to easy migrate from this configured installation to new raspbian installation (which files and directories should I copy on newly installed raspbian)?

Migrating is as simple as taking a snapshot (backup I have to say these days), and restoring on a new install.

But before you do: create a swapfile, the freeze could be caused by memory full.

I already have swap partition, and swap wasn’t full during freeze (same as memory).

People sometimes tend to “forget” about the exit-part at the end of 1.5 from the instructions at the 1st. post:

but simply continue straight to 2.1 as root-user from the keyboard connected to the RPI instead of continuing as the unprivileged user just created before through:

although the instructions is saying:

Continuing with Section 2 as root is discouraged because of various sorts of errors which might pop up caused by screwed permission settings due to having executed the install-script etc. directly as root.

All steps beginning from Section 2 should be done as an unprivileged user by prepending sudo to each and every command.

1 Like