Installing Home Assistant Supervised on a Raspberry Pi with Debian 11

I’m not 100% sure if i ran it as unprivileged user, but rather yes (for sure I have user with access to sudo, so i rather did not skip this step). Anyway what in this script may cause system freezes after few days of working? I understood that something might work or not because of wrong privileges but it shouldn’t cause total system freez after day or week of working…

So it is dubious at best, maybe yes but maybe no.

If you have followed the instructions by the book you certainly have added that unprivileged user. But it does not look like you are knowing what that user was created for.

If you take a closer look at 2.1 you might notice that it is not only a single bash script you have to execute but you are also installing other applications (as non-root, therefore that sudo -i at the beginning). What makes you think that only “this script” is causing system freezes etc.? Be assured that this thread wouldn’t exist anymore if it offers a buggy installation script.

BTW, since you are installing on a RPI3 you did follow this, did you?

There have been other users who did experience a similar behaviour after installing HA Supervised on RPI and eventually got it sorted out by really and doubtlessly following the instructions. Like i.e. read here and a few posts down.

1 Like

I am one of the users that had issues. Both @kanga_who and @Tamsy were able to help me resolve my issues. My system once working has not crashed ever. I went to Debian as I was having issues with HAOS after it updated from 5.4 and beyond. My system below 5.4 also never crashed.
To get me through the install I printed it out and checked off each step. If I was seeing anything that did not seem correct I would ask.
I also had a second ssd with HAOS 5.4 installed and if Debian crashed I would go back to that drive untill I got everything sorted out.

1 Like

Problems seems to be different than bschatzow’s problem:
I don’t have monitor connected, HDMI port unused
I was trying quirks when I was running on ssd - it’s not this case

I understood, that script is doing many things, but as far as I understood linux, problem should appear during installation/start of installed applications, not after few days of working. Anyway I wanted to check that to be 100% sure, but owner of files in both cases (sudo su - and sudo -i) are root so I have no idea how to check how it was ran. Any idea?
I’m 100% sure that i changed instruction from pi4 to pi3.

Which image did you choose? Why Debian 10 since Debian 11 is already officially supported by HA Supervised?

Honestly? If I were you I would start all over and use this image on a clean formatted branded quality SD-card (not on a SSD for now!). I would strictly stick to the instructions without getting tempted to let my bitty Linux knowledge aquired through different search results on the web mixing (and screwing) things up.

Don’t forget to make a full snapshot (full backup) before. The whole process shouln’t take much longer than 20 - 30 minutes to get all up an running.

I choose debian 10 because when I was doing that it was recommended version. I spend lot of time reading this thread and trying to find possible cause of problems, before I asked my question. Recommended version changed in meantime from 10 to 11.
you full snapshot do you mean supervisor → backups → create backup → full backup?

I did everything like described but I can not connect to the IP it spits out (HTTP://192.168.69.3:8123)

That is correct. And don’t forget to copy the resulting *.tar file over to your PC for later restore.

I reinstaled os. Going with instruction step by step, and for sure running mentioned command after second login to shell and sudo -i.
After:
[email protected]:~# curl -fsSL get.docker.com | sh
A get some warnings and errors:

[email protected]:~# curl -fsSL get.docker.com | sh
# Executing docker install script, commit: 93d2499759296ac1f9c510605fef85052a2c32be
+ sh -c apt-get update -qq >/dev/null
+ sh -c DEBIAN_FRONTEND=noninteractive apt-get install -y -qq apt-transport-https ca-certificates curl gnupg >/dev/null
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = (unset),
	LC_ALL = (unset),
	LC_TIME = "pl_PL.UTF-8",
	LC_MONETARY = "pl_PL.UTF-8",
	LC_ADDRESS = "pl_PL.UTF-8",
	LC_TELEPHONE = "pl_PL.UTF-8",
	LC_NAME = "pl_PL.UTF-8",
	LC_MEASUREMENT = "pl_PL.UTF-8",
	LC_IDENTIFICATION = "pl_PL.UTF-8",
	LC_NUMERIC = "pl_PL.UTF-8",
	LC_PAPER = "pl_PL.UTF-8",
	LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
+ sh -c curl -fsSL "https://download.docker.com/linux/debian/gpg" | gpg --dearmor --yes -o /usr/share/keyrings/docker-archive-keyring.gpg
+ sh -c echo "deb [arch=arm64 signed-by=/usr/share/keyrings/docker-archive-keyring.gpg] https://download.docker.com/linux/debian bullseye stable" > /etc/apt/sources.list.d/docker.list
+ sh -c apt-get update -qq >/dev/null
+ sh -c DEBIAN_FRONTEND=noninteractive apt-get install -y -qq --no-install-recommends  docker-ce-cli docker-ce >/dev/null
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = (unset),
	LC_ALL = (unset),
	LC_TIME = "pl_PL.UTF-8",
	LC_MONETARY = "pl_PL.UTF-8",
	LC_ADDRESS = "pl_PL.UTF-8",
	LC_TELEPHONE = "pl_PL.UTF-8",
	LC_NAME = "pl_PL.UTF-8",
	LC_MEASUREMENT = "pl_PL.UTF-8",
	LC_IDENTIFICATION = "pl_PL.UTF-8",
	LC_NUMERIC = "pl_PL.UTF-8",
	LC_PAPER = "pl_PL.UTF-8",
	LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
+ version_gte 20.10
+ [ -z  ]
+ return 0
+ sh -c DEBIAN_FRONTEND=noninteractive apt-get install -y -qq docker-ce-rootless-extras >/dev/null
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = (unset),
	LC_ALL = (unset),
	LC_TIME = "pl_PL.UTF-8",
	LC_MONETARY = "pl_PL.UTF-8",
	LC_ADDRESS = "pl_PL.UTF-8",
	LC_TELEPHONE = "pl_PL.UTF-8",
	LC_NAME = "pl_PL.UTF-8",
	LC_MEASUREMENT = "pl_PL.UTF-8",
	LC_IDENTIFICATION = "pl_PL.UTF-8",
	LC_NUMERIC = "pl_PL.UTF-8",
	LC_PAPER = "pl_PL.UTF-8",
	LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
+ sh -c docker version
Client: Docker Engine - Community
 Version:           20.10.8
 API version:       1.41
 Go version:        go1.16.6
 Git commit:        3967b7d
 Built:             Fri Jul 30 19:55:35 2021
 OS/Arch:           linux/arm64
 Context:           default
 Experimental:      true

Server: Docker Engine - Community
 Engine:
  Version:          20.10.8
  API version:      1.41 (minimum version 1.12)
  Go version:       go1.16.6
  Git commit:       75249d8
  Built:            Fri Jul 30 19:53:48 2021
  OS/Arch:          linux/arm64
  Experimental:     false
 containerd:
  Version:          1.4.9
  GitCommit:        e25210fe30a0a703442421b0f60afac609f950a3
 runc:
  Version:          1.0.1
  GitCommit:        v1.0.1-0-g4144b63
 docker-init:
  Version:          0.19.0
  GitCommit:        de40ad0

================================================================================

To run Docker as a non-privileged user, consider setting up the
Docker daemon in rootless mode for your user:

    dockerd-rootless-setuptool.sh install

Visit https://docs.docker.com/go/rootless/ to learn about rootless mode.


To run the Docker daemon as a fully privileged service, but granting non-root
users access, refer to https://docs.docker.com/go/daemon-access/

WARNING: Access to the remote API on a privileged Docker daemon is equivalent
         to root access on the host. Refer to the 'Docker daemon attack surface'
         documentation for details: https://docs.docker.com/go/attack-surface/

================================================================================

After

curl -sL "https://raw.githubusercontent.com/Kanga-Who/home-assistant/master/supervised-installer.sh" | bash -s -- -m raspberrypi3-64

It asked about overwrite so i agree:

[warn] Changes are needed to the /etc/network/interfaces file

[info] If you have modified the network on the host manualy, those can now be overwritten

[info] If you do not overwrite this now you need to manually adjust it later

[info] Do you want to proceed with overwriting the /etc/network/interfaces file? [N/y]

y

[info] Replacing /etc/network/interfaces

[info] Restarting NetworkManager

[info] Install supervisor Docker container

Unfortunately this time docker container even didn’t start :

[email protected]:~# docker images -a         
REPOSITORY                                TAG         IMAGE ID       CREATED       SIZE
homeassistant/aarch64-hassio-supervisor   2021.09.0   d3bef0e161db   3 weeks ago   322MB
homeassistant/aarch64-hassio-supervisor   latest      d3bef0e161db   3 weeks ago   322MB


[email protected]:~# docker container ls -a
CONTAINER ID   IMAGE                                     COMMAND   CREATED          STATUS                     PORTS     NAMES
ead54a52941a   homeassistant/aarch64-hassio-supervisor   "/init"   36 minutes ago   Exited (0) 5 seconds ago             hassio_supervisor
[email protected]:~# docker container ls -a
CONTAINER ID   IMAGE                                     COMMAND   CREATED          STATUS         PORTS     NAMES
ead54a52941a   homeassistant/aarch64-hassio-supervisor   "/init"   36 minutes ago   Up 6 seconds             hassio_supervisor
[email protected]:~# docker container ls -a
CONTAINER ID   IMAGE                                     COMMAND   CREATED          STATUS                     PORTS     NAMES
ead54a52941a   homeassistant/aarch64-hassio-supervisor   "/init"   37 minutes ago   Exited (0) 8 seconds ago             hassio_supervisor
[email protected]:~# 

I rebooted raspberry to check if it will help, but not:

[email protected]:~# docker container ls -a
CONTAINER ID   IMAGE                                     COMMAND   CREATED         STATUS    PORTS     NAMES
03084811149e   homeassistant/aarch64-hassio-supervisor   "/init"   7 seconds ago   Created             hassio_supervisor
[email protected]:~# date
Sun Sep 26 00:06:31 UTC 2021
[email protected]:~# docker container ls -a
CONTAINER ID   IMAGE                                     COMMAND   CREATED         STATUS    PORTS     NAMES
5a5c775c006a   homeassistant/aarch64-hassio-supervisor   "/init"   3 seconds ago   Created             hassio_supervisor
[email protected]:~# date
Sun Sep 26 00:07:02 UTC 2021
[email protected]:~# date
Sun Sep 26 00:13:46 UTC 2021
[email protected]:~# docker container ls -a
CONTAINER ID   IMAGE                                     COMMAND   CREATED         STATUS    PORTS     NAMES
7f9fae92c5ff   homeassistant/aarch64-hassio-supervisor   "/init"   2 seconds ago   Created             hassio_supervisor
[email protected]:~# 

Any idea what is wrong? I used os image which you pointed.

You should have stopped after the failure of "curl -fsSL get.docker.com | sh" instead of continuing to the next steps despite the latter has obviously failed!

Try to completely uninstall Docker.

First identify what docker-packages are installed (if any) by executing:

dpkg -l | grep -i docker

Take a note of the installed packages.

Now execute:

sudo apt-get purge -y noted-docker-package1 noted-docker-package2 etc.
sudo apt-get autoremove -y --purge noted-docker-package1 noted-docker-package2 etc.

sudo rm -rf /var/lib/docker /etc/docker
sudo rm /etc/apparmor.d/docker
sudo groupdel docker
sudo rm -rf /var/run/docker.sock

With the above commands you should have removed Docker completely from the system.

Now we try to fix the following:

Go to the CLI and execute:

sudo sed -e '/SendEnv LANG LC_*/ s/^#*/#/' -i /etc/ssh/ssh_config
sudo systemctl restart sshd

Log-off from Putty and re-login to your RPI3-CLI.

Try to start over as per instructions at the OP beginning from 2.1, but leave out the first 4 commands (since those have been successfully executed before):

sudo -i
curl -fsSL get.docker.com | sh
curl -sL "https://raw.githubusercontent.com/Kanga-Who/home-assistant/master/supervised-installer.sh" | bash -s -- -m raspberrypi3-64

With some luck you can now continue to 2.2 :ok_hand:t3:

1 Like

no lock

[email protected]:~$ dpkg -l | grep -i docker
ii  docker-ce                     5:20.10.8~3-0~debian-bullseye  arm64        Docker: the open-source application container engine
ii  docker-ce-cli                 5:20.10.8~3-0~debian-bullseye  arm64        Docker CLI: the open-source application container engine
ii  docker-ce-rootless-extras     5:20.10.8~3-0~debian-bullseye  arm64        Rootless support for Docker.

[email protected]:~$ sudo apt-get purge -y docker-ce docker-ce-cli docker-ce-rootless-extras
[email protected]:~$ sudo apt-get autoremove -y --purge docker-ce docker-ce-cli docker-ce-rootless-extras
sudo: unable to resolve host rpi3-20210823: Name or service not known
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Package 'docker-ce-cli' is not installed, so not removed
Package 'docker-ce-rootless-extras' is not installed, so not removed
Package 'docker-ce' is not installed, so not removed
The following packages will be REMOVED:
  containerd.io* libslirp0* slirp4netns*
0 upgraded, 0 newly installed, 3 to remove and 0 not upgraded.
After this operation, 93.2 MB disk space will be freed.
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = (unset),
	LC_ALL = (unset),
	LC_TIME = "pl_PL.UTF-8",
	LC_MONETARY = "pl_PL.UTF-8",
	LC_ADDRESS = "pl_PL.UTF-8",
	LC_TELEPHONE = "pl_PL.UTF-8",
	LC_NAME = "pl_PL.UTF-8",
	LC_MEASUREMENT = "pl_PL.UTF-8",
	LC_IDENTIFICATION = "pl_PL.UTF-8",
	LC_NUMERIC = "pl_PL.UTF-8",
	LC_PAPER = "pl_PL.UTF-8",
	LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
(Reading database ... 22684 files and directories currently installed.)
Removing containerd.io (1.4.9-1) ...
Removing slirp4netns (1.0.1-2) ...
Removing libslirp0:arm64 (4.4.0-1) ...
Processing triggers for libc-bin (2.31-13) ...
(Reading database ... 22657 files and directories currently installed.)
Purging configuration files for containerd.io (1.4.9-1) ...
[email protected]:~$ 

[email protected]:~$ sudo rm -rf /var/lib/docker /etc/docker
sudo: unable to resolve host rpi3-20210823: Name or service not known
[email protected]:~$ sudo rm /etc/apparmor.d/docker
sudo: unable to resolve host rpi3-20210823: Name or service not known
rm: cannot remove '/etc/apparmor.d/docker': No such file or directory
[email protected]:~$ sudo groupdel docker
sudo: unable to resolve host rpi3-20210823: Name or service not known
[email protected]:~$ sudo rm -rf /var/run/docker.sock
sudo: unable to resolve host rpi3-20210823: Name or service not known
[email protected]:~$ dpkg -l | grep -i docker
[email protected]:~$ 


[email protected]:~$ sudo sed -e '/SendEnv LANG LC_*/ s/^#*/#/' -i /etc/ssh/ssh_config
sudo: unable to resolve host rpi3-20210823: Name or service not known
[email protected]:~$ sudo systemctl restart sshd
sudo: unable to resolve host rpi3-20210823: Name or service not known

$ ssh [email protected]
ssh_exchange_identification: read: Connection reset by peer

reboot of pi

[email protected]:~$ sudo -i
sudo: unable to resolve host rpi3-20210823: Name or service not known
[sudo] password for pi: 
[email protected]:~# curl -fsSL get.docker.com | sh
# Executing docker install script, commit: 93d2499759296ac1f9c510605fef85052a2c32be
+ sh -c apt-get update -qq >/dev/null
+ sh -c DEBIAN_FRONTEND=noninteractive apt-get install -y -qq apt-transport-https ca-certificates curl >/dev/null
+ sh -c curl -fsSL "https://download.docker.com/linux/debian/gpg" | gpg --dearmor --yes -o /usr/share/keyrings/docker-archive-keyring.gpg
+ sh -c echo "deb [arch=arm64 signed-by=/usr/share/keyrings/docker-archive-keyring.gpg] https://download.docker.com/linux/debian bullseye stable" > /etc/apt/sources.list.d/docker.list
+ sh -c apt-get update -qq >/dev/null
+ sh -c DEBIAN_FRONTEND=noninteractive apt-get install -y -qq --no-install-recommends  docker-ce-cli docker-ce >/dev/null
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = (unset),
	LC_ALL = (unset),
	LC_TIME = "pl_PL.UTF-8",
	LC_MONETARY = "pl_PL.UTF-8",
	LC_ADDRESS = "pl_PL.UTF-8",
	LC_TELEPHONE = "pl_PL.UTF-8",
	LC_NAME = "pl_PL.UTF-8",
	LC_MEASUREMENT = "pl_PL.UTF-8",
	LC_IDENTIFICATION = "pl_PL.UTF-8",
	LC_NUMERIC = "pl_PL.UTF-8",
	LC_PAPER = "pl_PL.UTF-8",
	LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
+ version_gte 20.10
+ [ -z  ]
+ return 0
+ sh -c DEBIAN_FRONTEND=noninteractive apt-get install -y -qq docker-ce-rootless-extras >/dev/null
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = (unset),
	LC_ALL = (unset),
	LC_TIME = "pl_PL.UTF-8",
	LC_MONETARY = "pl_PL.UTF-8",
	LC_ADDRESS = "pl_PL.UTF-8",
	LC_TELEPHONE = "pl_PL.UTF-8",
	LC_NAME = "pl_PL.UTF-8",
	LC_MEASUREMENT = "pl_PL.UTF-8",
	LC_IDENTIFICATION = "pl_PL.UTF-8",
	LC_NUMERIC = "pl_PL.UTF-8",
	LC_PAPER = "pl_PL.UTF-8",
	LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
+ sh -c docker version
Client: Docker Engine - Community
 Version:           20.10.8
 API version:       1.41
 Go version:        go1.16.6
 Git commit:        3967b7d
 Built:             Fri Jul 30 19:55:35 2021
 OS/Arch:           linux/arm64
 Context:           default
 Experimental:      true

Server: Docker Engine - Community
 Engine:
  Version:          20.10.8
  API version:      1.41 (minimum version 1.12)
  Go version:       go1.16.6
  Git commit:       75249d8
  Built:            Fri Jul 30 19:53:48 2021
  OS/Arch:          linux/arm64
  Experimental:     false
 containerd:
  Version:          1.4.9
  GitCommit:        e25210fe30a0a703442421b0f60afac609f950a3
 runc:
  Version:          1.0.1
  GitCommit:        v1.0.1-0-g4144b63
 docker-init:
  Version:          0.19.0
  GitCommit:        de40ad0

================================================================================

To run Docker as a non-privileged user, consider setting up the
Docker daemon in rootless mode for your user:

    dockerd-rootless-setuptool.sh install

Visit https://docs.docker.com/go/rootless/ to learn about rootless mode.


To run the Docker daemon as a fully privileged service, but granting non-root
users access, refer to https://docs.docker.com/go/daemon-access/

WARNING: Access to the remote API on a privileged Docker daemon is equivalent
         to root access on the host. Refer to the 'Docker daemon attack surface'
         documentation for details: https://docs.docker.com/go/attack-surface/

================================================================================


[email protected]:~# cat /etc/ssh/ssh_config|grep -v ^#




Include /etc/ssh/ssh_config.d/*.conf

Host *
    HashKnownHosts yes
    GSSAPIAuthentication yes
[email protected]:~# ls /etc/ssh/ssh_config.d/
[email protected]:~# 

Show the outputs of:

sudo hostname
sudo cat /etc/hosts
sudo hostnamectl
[email protected]:~# ls /etc/ssh/ssh_config.d/
[email protected]:~# sudo hostname
sudo: unable to resolve host rpi3-20210823: Name or service not known
rpi3-20210823
[email protected]:~# sudo cat /etc/hosts
sudo: unable to resolve host rpi3-20210823: Name or service not known
127.0.0.1	localhost
::1		localhost ip6-localhost ip6-loopback
ff02::1		ip6-allnodes
ff02::2		ip6-allrouters

[email protected]:~# sudo hostnamectl
sudo: unable to resolve host rpi3-20210823: Name or service not known
   Static hostname: rpi3-20210823
         Icon name: computer
           Boot ID: 320c5fd191df4818a4a83b3a6645c683
  Operating System: Debian GNU/Linux 11 (bullseye)
            Kernel: Linux 5.10.0-8-arm64
      Architecture: arm64

I corrected it by adding hostname in /etc/hosts

127.0.0.1	localhost rpi3-20210823

And now it’s:

[email protected]:~$ sudo hostname
[sudo] password for pi: 
rpi3-20210823
[email protected]:~$ sudo cat /etc/hosts
127.0.0.1	localhost rpi3-20210823
::1		localhost ip6-localhost ip6-loopback
ff02::1		ip6-allnodes
ff02::2		ip6-allrouters

[email protected]:~$ sudo hostnamectl
   Static hostname: rpi3-20210823
         Icon name: computer
           Boot ID: 4ec3af10146f4ff3bb345721de248841
  Operating System: Debian GNU/Linux 11 (bullseye)
            Kernel: Linux 5.10.0-8-arm64
      Architecture: arm64

What with this problem with locale? Should I do:

export LANGUAGE=pl_PL.UTF-8
export LANG=pl_PL.UTF-8
export LC_ALL=pl_PL.UTF-8
locale-gen pl_PL.UTF-8
dpkg-reconfigure locales

or there is a different proper solution?
After fixing locale what step should I do as a next?

The easiest way is to just disable SendEnv LANG LC_* which is active by default on newer Linux distros. If commented (set to inactive) a connecting ssh client doesn’t send its Locale (which is Polish in your case) to the RPI thus keeping the default Locale on the RPI untouched.

First I would check manualy whether SendEnv LANG LC_* is commented (prepended with a hashtag (#))

sudo nano /etc/ssh/ssh_config

Scroll down and look for the line:
SendEnv LANG LC_*

and change it to:
# SendEnv LANG LC_*

Save and close the file. Restart the SSHD server:

sudo systemctl restart sshd

Relogin through SSH and try again. The message " perl: warning: Setting locale failed." should be gone now.

If this does not work, add the Locale for Polish to your RPI:

export LANGUAGE=pl_PL.UTF-8
export LANG=pl_PL.UTF-8
export LC_ALL=pl_PL.UTF-8
locale-gen pl_PL.UTF-8
dpkg-reconfigure locales

After the above is solved continue with the instructions I wrote this morning.

as I showed everything except it (including SendEnv LANG LC_*) was already commented. I tried with exports locale-gen and dpkg-reconfigure, but it doesnt work:

[email protected]:~# export LANGUAGE=pl_PL.UTF-8
export LANG=pl_PL.UTF-8
export LC_ALL=pl_PL.UTF-8
locale-gen pl_PL.UTF-8
dpkg-reconfigure locales
-bash: warning: setlocale: LC_ALL: cannot change locale (pl_PL.UTF-8)
-bash: locale-gen: command not found
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = "pl_PL.UTF-8",
	LC_ALL = "pl_PL.UTF-8",
	LC_ADDRESS = "pl_PL.UTF-8",
	LC_NAME = "pl_PL.UTF-8",
	LC_MONETARY = "pl_PL.UTF-8",
	LC_PAPER = "pl_PL.UTF-8",
	LC_IDENTIFICATION = "pl_PL.UTF-8",
	LC_TELEPHONE = "pl_PL.UTF-8",
	LC_MEASUREMENT = "pl_PL.UTF-8",
	LC_TIME = "pl_PL.UTF-8",
	LC_NUMERIC = "pl_PL.UTF-8",
	LANG = "pl_PL.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
dpkg-query: package 'locales' is not installed and no information is available
Use dpkg --info (= dpkg-deb --info) to examine archive files.
/usr/sbin/dpkg-reconfigure: locales is not installed
sudo apt-get install -y locales

Also please show the detailed output of:

sudo lsusb

I am trying to do a fresh install of Debian 11 with this guide. I have the debian 10 docker install running my production home assistant. I was trying to do a fresh install on a rpi4 of debian 11 and then do a restore of home assistant on new system. I downloaded image and used Balena Etcher to install on my ssd. when I start up the rpi4 it boots to the command prompt rpi4-20210823 login: but then get this repeating message

[ 1481.461117] mmc1: Timeout waiting for hardware cmd interrupt.
 1481.463853] mmc1: sdhci: ============ SDHCI REGISTER DUMP ===========
 [ 1481.466906] mmc1: sdhci: Sys addr:  0x00000000 | Version:  0x00001002
 [ 1481.469956] mmc1: sdhci: Blk size:  0x00000000 | Blk cnt:  0x00000000
[ 1481.473005] mmc1: sdhci: Argument:  0x80000c08 | Trn mode: 0x00000000
[ 1481.476055] mmc1: sdhci: Present:   0x1fff0001 | Host ctl: 0x00000001
[ 1481.479104] mmc1: sdhci: Power:     0x0000000f | Blk gap:  0x00000080
[ 1481.482153] mmc1: sdhci: Wake-up:   0x00000000 | Clock:    0x0000f447
[ 1481.485202] mmc1: sdhci: Timeout:   0x00000000 | Int stat: 0x00000000
[ 1481.488251] mmc1: sdhci: Int enab:  0x00ff1003 | Sig enab: 0x00ff1003
[ 1481.491300] mmc1: sdhci: ACmd stat: 0x00000000 | Slot int: 0x00000000
[ 1481.494350] mmc1: sdhci: Caps:      0x45ee6432 | Caps_1:   0x0000a525
[ 1481.497399] mmc1: sdhci: Cmd:       0x0000341a | Max curr: 0x00080008
 [ 1481.500449] mmc1: sdhci: Resp[0]:   0x00000000 | Resp[1]:  0x00000000
 [ 1481.503498] mmc1: sdhci: Resp[2]:   0x00000000 | Resp[3]:  0x00000000
 [ 1481.506547] mmc1: sdhci: Host ctl2: 0x00000000
 [ 1481.508650] mmc1: sdhci: ADMA Err:  0x00000000 | ADMA Ptr: 0x00000000
 [ 1481.511699] mmc1: sdhci: ============================================ 

I know it has something to do with no SD card, I have googled and searched a few things but none have helped to resolve the issue.
I did not have this problem with the Debian 10 install and not sure what I done different.

@bsmith76s: I have the same issue.

I tried some suggested solutions from other forums, but they don’t work: ‘dtparam=sd_poll_once’ line should be added to /boot/config.txt, but there isn’t /boot/config.txt. It does not work even if I create the file. Another solution is if the boot order will be changed, but I haven’t wanted to modifiy eeprom. So I wait for a good solution too.

Thanks, problem with locales solved, I one more time removed docker as you described

First identify what docker-packages are installed (if any) by executing:

dpkg -l | grep -i docker

Take a note of the installed packages.

Now execute:

sudo apt-get purge -y noted-docker-package1 noted-docker-package2 etc.
sudo apt-get autoremove -y --purge noted-docker-package1 noted-docker-package2 etc.

sudo rm -rf /var/lib/docker /etc/docker
sudo rm /etc/apparmor.d/docker
sudo groupdel docker
sudo rm -rf /var/run/docker.sock

and rerun, but get another error:

[email protected]:~$ sudo -i
[email protected]:~# curl -fsSL get.docker.com | sh
# Executing docker install script, commit: 93d2499759296ac1f9c510605fef85052a2c32be
+ sh -c apt-get update -qq >/dev/null
+ sh -c DEBIAN_FRONTEND=noninteractive apt-get install -y -qq apt-transport-https ca-certificates curl >/dev/null
+ sh -c curl -fsSL "https://download.docker.com/linux/debian/gpg" | gpg --dearmor --yes -o /usr/share/keyrings/docker-archive-keyring.gpg
+ sh -c echo "deb [arch=arm64 signed-by=/usr/share/keyrings/docker-archive-keyring.gpg] https://download.docker.com/linux/debian bullseye stable" > /etc/apt/sources.list.d/docker.list
+ sh -c apt-get update -qq >/dev/null
+ sh -c DEBIAN_FRONTEND=noninteractive apt-get install -y -qq --no-install-recommends  docker-ce-cli docker-ce >/dev/null
E: Sub-process /usr/bin/dpkg returned an error code (1)
[email protected]:~# 

usb devices:

[email protected]:~$ sudo lsusb
Bus 001 Device 004: ID 0658:0200 Sigma Designs, Inc. Aeotec Z-Stick Gen5 (ZW090) - UZB
Bus 001 Device 005: ID 0451:16a8 Texas Instruments, Inc. CC2531 ZigBee
Bus 001 Device 006: ID 0424:7800 Microchip Technology, Inc. (formerly SMSC) 
Bus 001 Device 003: ID 0424:2514 Microchip Technology, Inc. (formerly SMSC) USB 2.0 Hub
Bus 001 Device 002: ID 0424:2514 Microchip Technology, Inc. (formerly SMSC) USB 2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I also ran the EEPROM USB Boot update with SD before I started process.