Installing Home Assistant Supervised on a Raspberry Pi with Debian 11

Maybe paste the command your trying to use?

I found the issue - Was using a never before used wall jack for ethernet that doesn’t work.
Sorry to bother for this

I am running 32bit Raspbian Buster on a Pi4 8gb. I have used this script before, and it worked fine. A recent power outage caused the Docker images to not load. In fact, this is not the first time, so I am looking into a UPS, or just be done with this Docker method.

I successfully removed the images, then ran this Kango-Who script to get HA back up and running. All was fine, until a reboot. All my settings, Mate desktop tweaks, themes, my Unifi Network controller, Samba share, Bluetooth manager, and lots more were gone. I have a feeling the author has snuck in this command, since the last time I ran it:

sudo apt install git-all

I doubt running this before running the script was the culprit:

sudo apt update && sudo apt upgrade -y && sudo apt autoremove –y

This command will ruin everything, and delete many Gnome parts of the system. Just look at this Ubuntu thread:

I keep backups, but hadn’t backed up my USB boot drive to SD in a few weeks. This problem happened before when I was following instructions for setting up a Wireguard container, so I know what happened when my entire desktop was gone upon reboot.

So, is the git command the culprit? Would this have happened on a plain Debian install?

Well, after recovering on the backup, then re-runnning the script, it worked. All I can think of is I might not have entered sudo -i first. Can’t see how that would strip all my settings and software off the system.

that the driver does not know how to drive the vehicle does not mean that the vehicle is bad, perhaps that vehicle is too much for that driver

1 Like

I’m curious who that smartass comment is for? I posted a result of using this script. Using it stripped my system. I might have skipped sudo -i, but I’m not sure. Maybe running it on Raspbian is the problem. I’m not sure of that either. It’s worked before…

I’m hoping my post will help and enlighten anyone doing it the way I did. That’s what forums are for: to give and get advice. Telling people they shouldn’t even be attempting this helps no one. If your comment was for @realjax, why even bother? He needed to vent. He also can’t login via SSH. Either comment with help or don’t comment at all.

I’m sure there was a time when you knew nothing of this, and needed help. How’d it feel when some punk came on the thread and told you you weren’t capable of figuring it out?

I think you misinterpreted what he said… he was referring to the post directly above his not yours. And he’s right. A lot of people don’t have the needed skills.

Root access is a bad idea which is why there is no password by default. You should install sudo and add your user to the sudo group instead.

1 Like

Maybe the don’t like you calling them clueless nerds so they choose not to babysit you

Yeah that is probably it.

This is an install guide, not a place for you to voice your displeasure with Linux in general, or those who may or may not choose to help you. Start your own thread for that.

1 Like

As part of the installation (Debian) provided you DON’T enter a root password it will install sudo. It will also prompt you to create a user. It’s quite simple and well thought out actually.

There is a REASON supervised installations are referred to as advanced so maybe as a self identified clueless noob this method isn’t for you.

1 Like

Hi - I get an error during the Partition disks section of the install. ‘This probably happened because there are too many (primary) partitions in the partitions table. Can someone guide me on how to do this part manually ?

  • Configure software RAID
  • Configure the Logical Volume Manager
  • Configure encrypted volumes
  • Configure iSCSI volumes
    I got a Kingston A400 - 120GB.
    Thank you for your guidance.

So, an update… I never did get this install to work properly - so I caved and just installed Home Assistant OS. It works fine, but now my pi is stuck with only Home Assistant. I was hoping buying a pi4, a more powerful device, that I could run Motion Eye and not bog down the processor too much. Now I can only install MotionEye as a Home Assistant add-on; which doesn’t work either - I just get “Bad Gateway” errors all the time… a long running problem with that addon. But that’s for another forum topic.

Thanks all the same for all your help.

On Raspberry Pi 3, The HA OS was causing the RasPi to freeze in less than 24 hours, so I am trying Debian 10 type supervised install. The first installation did not work with wifi, because before I started HA in web, I installed wicd-curses and set up wifi access in host and changed the hostname as well. Then the wifi setup did not work from Supervisor. I also could not upload backup image, right after upload the HA restarted and after reboot the backup image was not uploaded.

My last problem was that during installation, I always get many warnings that locale and all those LC… variables are not configured. Is there some very easy way to set it up?

Be careful … today after debian update (kernel 5.10) RPI4 with ssd not boot for me :frowning:
Noob question: How to boot rpi-debian with old kernel (5.9) after apt update&upgrade? Recovery mode or something like that.

1 Like

Just experienced the same. Latest Kernel for Debian on Raspi 4 renders the device unbootable!

I tried this with 2 different Raspberry 4 4GB but as soon as the Kernel updates to the latest, boot process will stop at:

vcc-sd: disabling

This also happens on new installs onto a freshly formatted SSD but also with existing installations!
Just avoid updating the kernel (for the time being).

To put the kernel update on hold type the following at the CLI:

sudo apt-mark hold linux-image-arm64

I hope this notice will help others from disaster (luckily I did a full snapshot today)

To avoid “Unattended Upgrades” (if you have that activated) updating the kernel silently in the background do:

sudo nano /etc/apt/apt.conf.d/50unattended-upgrades

Add following into blacklist.

linux-headers*
linux-image*
linux-generic*
linux-modules*

The blacklist section should look like the following:

Unattended-Upgrade::Package-Blacklist {
      "linux-headers*";
      "linux-image*";
      "linux-generic*";
      "linux-modules*";
};

I was able to update my fresh debian installation from 5.9 to 5.10 but before the update:

echo reset-raspberrypi > /usr/share/initramfs-tools/modules.d/raspi-firmware.conf

The bug is related to “initramfs-tools” (https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=977694#67)

2 Likes

Wondering why initramfs-tools v0.140 which fixes the issue is not available before kernel 5.10 for Buster got released because this is not a I-wanna-be-on-the-bleeding-edge-Update but gets installed during a regular system upgrade through:

sudo apt update && sudo apt upgrade -y && sudo apt autoremove –y

which I run once a week to download security patches and keep the OS up to date.

As for buster (stable) the latest is still v.0.133 but v0.140 is available for sid (unstable) only.

I will refrain from using the proposed workaround and keep the kernel update on hold until initramfs-tools v0.140 comes with a regular update to Buster.

1 Like

Hi,
I’m trying to do a fresh install and I’m receiving the same error. How would you recommend I modify the reinstall based on the developer’s instructions. Thank you

Today was the day that I chose to leave Raspbian and move to Debian :sweat_smile: .
As @Tamsy mentioned above after you login to your fresh install before any update
To put the kernel update on hold type the following at the CLI:

sudo apt-mark hold linux-image-arm64

Did it earlier. Tested.

2 Likes