Installing Home Assistant Supervised on Debian 11

if it working dont change it…

Oh, so it won’t wipe out my HA install?

Well, I was wondering about security updates, that kind of thing.

just do this apt-get update && apt-get dist-upgrade -y && apt autoremove -y

Just updated Debian Os under my HA installation.
Now RPi4 hangs on “random crng init done” while booting.
Any idea?

RPi4, ssd disk over usb3 cable/adapter, no microsd

This guide isn’t for a Pi.

Fix here from Tamsy for SSD booting Pi.

1 Like

It will not wipe the HA install, it will upgrade any packages that have more recent versions then what is present on your system.


[3356]: **21-05-02 18:31:29 WARNING (MainThread) [supervisor.jobs] 'Updater.fetch_data' blocked from execution, no supervisor internet connection**

[3356]: **21-05-02 18:31:29 WARNING (MainThread) [supervisor.plugins.dns] Error on install CoreDNS plugin. Retry in 30sec**

This error keeps on repeating over and over. Is it because I have PiHole for DNS?

If you think it might be piHole, just change the dns and see if that fixes the problem…probably much faster than waiting for an answer here

It is not that lookups are not working, which they are. If you look closely the CoreDNS plugin is failing install.

Error on install CoreDNS plugin

So, my question was around a potential service conflict.

I am guessing you are focussed around the no-internet log entry, which I think is a by-product of CoreDNS not being there.

I hope this helps.

Update:
Correction!!!

The hassio-supervisor container is unable to access localnetwork DNS server answering on host IP address aka Pihole. Provided below is my reasoning why I think so. Happy to be proven wrong if you have additional info.

-Tried with PiHole but pointed /etc/resolv.conf to an host PiHole DNS server — Did not work
-Tried with PiHole but pointed /etc/resolv.conf to an internal DNS server which performs lookups from host PiHole server — Worked

Any dev wishes to weigh in on this?

1 Like

Hi everyone,

I have been trying (for the last 2 dys) to refurbish an old Lenovo Q180 to act as my HA server. I’m getting stuck as the same place on trying to install the Debian (debian-10.9.0-i386-DVD-1.iso) via a USB formated using Rufus. I have followed the steps and note the following issues, which I suspect is causing the eventual failiure of the installation. The issue is the Non-Free updates that the Debian installer asks for. I could not find any excting instructions for how to prepare the required ones so tht the installer can locate them when I select “YES” to including them. I have downloded this folder containng firmware files and tried unzipping them all in to the firmware folder on the Rufus USB but the installer just loops round unable to locate them.

Does anyone have any suggestions to get past this point? If I select NO to having the firmeware then the install of Debian goes to the end, then I unplug the USB before rebooting the machine. Then on Debian start up it complains of a Kernal error and the Wifi hardware error: “rtl8821ae: Polling FW fail!! REG_MCUFWDL: 0x00000006” then scrolls through a long list of STARTING and [OK] until it gets to the started GNOME Display Manager where everything stops but the cursor is still flashing in the bottom left corner.

Any one can offer some advise please…its driving me mad after 2 days :frowning:

during the install, I think it tells you what firmware it’s looking for. In my case it’s wireless drivers, so I can say no, I don’t have them and load them later. If you need graphics or other critical drivers, you may have to download them yourself and add them during the install. One approach that might work would be to install debian with no desktop and use command line to add non-free to all the sources in /etc/apt/sources.list (and remove any lines that refer to your install CD or wherever you had that iso). Then add gnome: How To Install GNOME Desktop on Debian 10 - idroot

1 Like

I’m not familiar with coreDNS, but It appears you are trying to install two DNS servers on this box? Both use port 53 by default? I don’t think that works…

I am not trying to install two, I installed only 1. Which is PiHole. Rest is whatever Home Assistant install script is doing.

CoreDNS is part of what HA supervisor tries to install after the first container goes online.

In either case seems to be a compatibility issue with pihole at this point.

Yes, CoreDNS is broken in more than 1 way. Nothing us lowly users can do about it, the devs do not want to help.

@TheEngineerGuy
As a workaround, try installing PiHole as a HA add-on? Or AdGuard ?

1 Like

Agreed. I looked into the PiHole add-on, and I saw the post about it being deprecated. The AdGuard addon is not as full featured as PiHole. Sad stuff. Where is that violin when you need it.

As you pointed out, CoreDNS conflict needs to be looked into by the Devs.

1 Like

I am running home assistant and pi-hole on a NUC, both installed under Debian 10 with docker. No issues.

my pi-hole install:

docker run \
--name=pihole \
--privileged \
-e TZ=America/New_York \
-e WEBPASSWORD=youpickit \
-e SERVERIP=192.168.254.220 \
-v pihole:/etc/pihole \
-v dnsmasq:/etc/dnsmasq.d \
-p 80:80 \
-p 53:53/tcp \
-p 53:53/udp \
--restart=unless-stopped \
pihole/pihole

I think installing PiHole as a container is a viable option as you suggested. I have PiHole installed natively.

Are there any limitations or deviations from standard procedures that you faced with PiHole as a container?

nope…just used that docker run and all works as expected

Ok, I will look into this workaround and see how it plays out. Thanks for this suggestion.

As for the main issue with CoreDNS conflict, I hope the devs look into it. A little beyond me.