Installing Home Assistant Supervised on Debian 11

That script is a different script. Use this to install supervised on debian 11:

wget https://github.com/home-assistant/supervised-installer/releases/latest/download/homeassistant-supervised.deb

dpkg -i homeassistant-supervised.deb

Ahhh, yes it does.

You are trying to run the HA OS script on Debian - it won’t work.

Either follow the Debain 11 install guide, or, the Proxmox + HA OS guide.

I agree, that’s why I‘m running HA supervised as a VM on Proxmox. I use supervised only to run ser2net (although still in planning phase).

I’m in the planning phase right now. Switching from IoBroker. What is the exact difference.
What is different with HA supervised?

Where can I find the correct installation instructions?

You need to do some reading my friend. Start on the HA website.

This guide is to install HA Supervised using Debian 11 as the OS.

If you want to run a VM, using Proxmox, follow this guide.

1 Like

oh yes i read it before and test it
Error on this point

Now i testet Proxmox Helper Scripts

bash -c "$(wget -qLO - https://raw.githubusercontent.com/tteck/Proxmox/main/pve6_ha_container.sh)"

and now lxc is locked

pct unlock 107 

don´t unlock :man_shrugging:t2:

You ran a pve6 script, you’re on pve7

This has nothing to do with the OP topic

1 Like

pve server reboot…its ok… what is login password

:see_no_evil:sorry its not my day

1 Like

This is a strange decision. Docker isolates containers, that’s the whole point. Why on earth would installing another container would invalidate an install?

That and blacklisting Ubuntu… Debian hardware support is quite lacking and won’t enable the display adapter on my small server where I was running supervised HA on Ubuntu until some dev decided they hated Ubuntu. I can’t install Debian on that server. I’m now running the VM but I get random problems with home assistant dockers crashing and stopping for no reason. It’s very unstable compared to my previous Ubuntu setup.

Sad to see a successful open source project like this take the wrong track.

Maybe it’s time to fork the project.

3 Likes

Hello everyone.
I was using HA supervised version for quite some time on RPI4 4GB. until recently i got my RPI SD -Card crash. Since then i am trying all available things to reinstall HA supervised on both Debian 10 and 11 but unfortunately was unsuccessful. recent, the following installation guide i followed on for Debian 11

Everything went well as per the guide. but after the installation was unable to connect to the HA frontend. After diagnosing, i found the HA core is keep crashing in HA supervised.

21-12-04 23:57:24 INFO (MainThread) [supervisor.resolution.evaluate] System evaluation complete
21-12-04 23:57:24 INFO (MainThread) [supervisor.resolution.fixup] Starting system autofix at state CoreState.RUNNING
21-12-04 23:57:24 INFO (MainThread) [supervisor.resolution.fixup] System autofix complete
21-12-04 23:57:24 INFO (MainThread) [supervisor.host.services] Updating service information
21-12-04 23:57:24 INFO (MainThread) [supervisor.host.network] Updating local network information
21-12-04 23:57:25 INFO (MainThread) [supervisor.host.sound] Updating PulseAudio information
21-12-04 23:57:25 INFO (MainThread) [supervisor.host.manager] Host information reload completed
21-12-05 00:01:14 INFO (MainThread) [supervisor.homeassistant.module] Update pulse/client.config: /data/tmp/homeassistant_pulse
21-12-05 00:01:15 INFO (SyncWorker_3) [supervisor.docker.homeassistant] Starting Home Assistant ghcr.io/home-assistant/raspberrypi4-64-homeassistant with version 2021.11.3
21-12-05 00:01:15 INFO (MainThread) [supervisor.homeassistant.core] Wait until Home Assistant is ready
**21-12-05 00:01:20 ERROR (MainThread) [supervisor.homeassistant.core] Home Assistant has crashed!**

I also tried to roll back to the previous core versions and later to the dev channel. But nothing worked out. I would really appreciate if someone can help me to understand where exactly is the problem and how i can get it fixed.

Many thanks in advance
Simer

I’d suggest to log an issue in the HA Supervised section on Github.

Further to this, since there is no way to get back to supported again, I decided to add back watchtower to manage non-HA containers as I had been running before it made my system ‘unhealthy’ despite watchtower ignoring HA related addons etc. I have already set HA to ignore the unhealthy flag so now I am unsupported AND unhealthy but hopefully this won’t block any updates.
I note this week they have pulled the portainer addon from the addon store too. Lucky my system was already running the native portainer and displaying it in HA anyway via an iFrame. Let the games begin. I wonder what they will block next? ssh on the host maybe… cos that is WAY dangerous.

4 Likes

Yea there was a long and semi heated discussion about the portainer add-on on GitHub. I ended up installing portainer from a different addon respository (alexbelgium), which is actually updated and maintained.

Yeah I never wanted it running as an addon anyway because if Supervisor had issues I couldn’t access it so I always ran the official portainer and it’s served me well. A third party repo isn’t that bad of an idea anyway. It would just be nice if user needs were considered and we were treated like adults. I don’t understand why dumbing this down is the highest objective. Novice users shouldn’t be using supervised anyway and if they do that’s on them.

recommend to run portainer on different VM or server and remote access to HA. That what I did, portainer is a great tools when handling error, especially when HA fail to run. I also hate this new supervisor version since now I cant even run NGINX Proxy Manager on the same machine.

It is a bad direction, but I guess they really want to down the number of users of supervised, so there is a reason to stop with it.

1 Like

I am trying to install in on Debian WSL2. It is not working

[email protected]:~# dpkg -i os-agent_1.2.2_linux_x86_64.deb
Selecting previously unselected package os-agent.
(Reading database ... 84584 files and directories currently installed.)
Preparing to unpack os-agent_1.2.2_linux_x86_64.deb ...
Unpacking os-agent (1.2.2) ...
Setting up os-agent (1.2.2) ...
System has not been booted with systemd as init system (PID 1). Can't operate.
Failed to connect to bus: Host is down
Created symlink /etc/systemd/system/multi-user.target.wants/haos-agent.service → /lib/systemd/system/haos-agent.service.
System has not been booted with systemd as init system (PID 1). Can't operate.
Failed to connect to bus: Host is down
dpkg: error processing package os-agent (--install):
 installed os-agent package post-installation script subprocess returned error exit status 1
Processing triggers for dbus (1.12.16-2ubuntu2.1) ...
Errors were encountered while processing:
 os-agent

Is it fixible?

1 Like