Installing Home Assistant Supervised on Ubuntu 18.04.4

Tags: #<Tag:0x00007fc40b34d1c8>

Someone who has an old PC laying about might want a simple install to just run Home Assistant. Supervised is perfect for that - no hardware investment and up and running with the Supervisor and Add-ons in well under an hour, so your point is not entirely accurate.

A new user who may wish to get support from the HA team on Github or Discord.

That’s not what I am implying at all. I am directing people to use my other guide/s for Debain and Proxmox as these are supported installation methods. If you wish to use Ubuntu and support yourself, there is nothing wrong with that, and this guide helps you with the install. For a new user though, this is not the best approach.

I’m glad you have found it useful and thanks for the feedback.

1 Like

Do you remember what you did? I tried to install HA Supervised too and everything worked great except DNS. Couldn’t figure out what to do.

@kanga_who: Thanks for the clarification, sorry if I was misinterpreting anything :slight_smile:

@krisjanis2000: To clarify - are you having a general Ubuntu 20.04 DNS setup issue, or something with HA Supervised internal DNS setup?

I wish I had documented it better when I did it, but poking through my command history… it basically revolves around systemd.resolved & the whole local caching DNS setup in Ubuntu 20.04 server is kind of a complicated mess and wasn’t working for me at first. Basically DNS uses a local server @ as a cache, which then is supposed to use the DHCP configured server.

Try “nslookup HOSTNAME” and see what server it uses (and see if DNS worked). Then try “nslookup HOSTNAME REALDNS_IP”

In the end I tried a few things, including effectively disabling the systemd.resolved proxy by mesing with some configs and symlinking /etc/resolv.conf from /run/systemd/resolve/resolv.conf instead of resolv-stub.conf. Then I installed network-manager (which the docs say is highly recommended for HA Supervised) - and disabled the ModemManager and wpa_supplicant services since I am using Ethernet.

But: I now see after updating the OS and rebooting the device the symlink I changed is reverted and the proxy is being used again! (I assume some package update overwoite my changes, oh well). And of course it’s now all working fine… so I’m not sure how helpful all of the above is, but maybe something can point you in the right direction.

Hmm - one more possibility is I also added an internal domain name on my router’s DNS so clients would get it via DHCP. I think there was some issue with search path but can’t say for sure (in case your issue is DNS resolution of other local machines on your network).

Thank you very much for your detailed explanation. Sounds similar to my issue. I will try to follow the ideas you provided. To make sure, I have the same issue - when trying to ping a website, did you notice an error like this: “ping: Temporary failure in name resolution”?

I don’t think it was ever completely broken for me - just seemed inconsistent, like the caching wasn’t working, some hosts resolved and some didn’t.

As a quick sanity check, can you change /etc/resolv.conf (either change symlink to a different file, or just edit it… it’s a symlink for me right now):

ls -l /etc/resolv.conf
lrwxrwxrwx 1 root root 37 Jul  4 23:50 /etc/resolv.conf -> /run/systemd/resolve/stub-resolv.conf

Inside it will look like:

options edns0
search your.domain.if.specified

I think there should also be a file: /run/systemd/resolve/resolv.conf that has your “real” DNS IP (form DHCP, etc) in it [note is just my router’s IP, probably different for you]:

search your.domain.if.specified

So, this will link to the one that doesn’t use systemd.resolv proxy:

sudo rm /etc/resolv.conf && sudo ln -s /run/systemd/resolve/resolv.conf /etc/resolv.conf

(alternatively edit the existing one and add something like “nameserver” before the other nameserver line, just for testing…)

If everything now works, it’s definitely systemd.resolv related.

Being that this guide is discussing 18.04, perhaps starting a new thread on 20.04 would be a good idea to discuss the issues with that version.

Kanga_who’s topic describes how to install Home Assistant Supervised. Your link describes how to install Home Assistant Core in a python virtual environment. It’s a completely different topic and belongs in a separate Community Guides page.

I’ve removed the offending post.

Hi, nice tutorial fully working over here!

One question, how to update?

sudo apt update && sudo apt dist-upgrade -y && sudo apt autoremove –y

Is this enough?


I use this Installer script. Works fine with ubuntu 20.04. THANKS! But, how can I add my USB stick (/dev/ttyACM0) to docker? HA integration page can’t find it.

Best to start a new thread. This post covers installs using 18.04.

Installation went fine, but I only got the hassio containers, no container for the Home Assistant itself, and thus there is no application listening on port 8123. Installation done on my nuc running Ubuntu 18.04.4.

I got the following containers in docker:

I guess one container for Home Assistant is missing?

On 8/8/20, followed this guide to successfully get HA running on Ubuntu 20.04 LTS on i5 quadcore.

@kanga_who. Hi. Thanks for this guide, it was exactly what I was looking for and worked perfectly. Really appreciate it! A couple questions I have and would be great if you could guide me:

  1. Your disclaimer: “[paraphrasing] installation is not official I (the user) am responsible for updates, etc.” The question: are there specific steps to follow to update HA or is it the same I do on my RPI (i.e., use the supervisor pannel - If there are specific steps, could you point me to documentation to follow? (Note that I’m just talking about updating HA, not Ubuntu/Docker)
  2. After following the guide I see that there are 7 HA docker images running. I’m assuming this is expected, could you point me to documentation to read more about why all these images are needed and which is the one actually running HA? (I’m guessing it’s either ‘homeassistant/amd64-hassio-supervisor’ or ‘homeassistant/qemux86-64-homeassistant:0.113.3’)

Thanks again!

Yes, update HA in the same way via the Supervisor panel. You will also need update Ubuntu to keep it up to date with security patches.

Thanks a lot!

@kanga_who First, I appreciate this guide (and its siblings). I have felt constrained in HassOS, so these are a welcome alternative.

While I was able to install this under Ubuntu 20.04 Desktop, I don’t want the overhead of the GUI. So, I installed Server. But I keep getting this in the logs for
systemctl status hassio-supervisor.service

20-08-14 01:14:00 INFO (MainThread) [supervisor.updater] Fetch update data from
20-08-14 01:14:00 WARNING (MainThread) [supervisor.updater] Can't process version data: 'null'
20-08-14 01:14:00 WARNING (MainThread) [supervisor.plugins.dns] Error on install CoreDNS plugin. Retry in 30sec

I have tried 18.04 too; I even used your guide for Debian 10. I get the same error.

The error seems to stem from getting a bad value from (presumably the “dns” value, which is 9). Searching for that error returned 2 results, neither of which helped.

Do you (or anyone) have any suggestions for how to resolve this error?


(FWIW, I have chased this down from the original error, “Error: No such container: hassio_cli”, which I get when trying to run any ha command.)

Edit: While going through it again, I see a preceding CoreDNS error:
20-08-14 01:48:20 INFO (MainThread) [supervisor.plugins.dns] No CoreDNS plugin Docker image homeassistant/amd64-hassio-dns

Also, the only docker container is homeassistant/amd64-hassio-supervisor, with 2 images homeassistant/amd64-hassio-supervisor TAG: 232 and homeassistant/amd64-hassio-supervisor TAG: latest

Update: I went back to Ubuntu desktop and have the same issue now.

I’m having the same problem

It appears the installer script was updated about 20hrs ago by the dev team.

I’m updating the info on my end now, should work again shortly.

@mickjacobsen @ajhutton
Working again now.

1 Like

Hi guys.

I might have messed up.

I’ve had problems updating homeassistant for the last couple of releases, so I thought a fresh install with a restored backup would help.

I tried to stop and remove the containers using portainer, but was only successfull in removing the actual homeassistant-container. dns, supervisor, cli, multicast and audio are all still there.

I also removed everything in the config directory ( /usr/share/hassio/homeassistant )

Could this be fixed by just by building a new container? If so, which one is it? I had a look on dockerhub, but it didn’t make much sense to me.

Any ideas how to fix this? I have other stuff on the machine so hopefully I dont have to reinstall the whole OS.