Installing Home Assistant Supervised on Ubuntu 18.04.4

Tags: #<Tag:0x00007fc411addf18>

Being that this guide is discussing 18.04, perhaps starting a new thread on 20.04 would be a good idea to discuss the issues with that version.

Kanga_who’s topic describes how to install Home Assistant Supervised. Your link describes how to install Home Assistant Core in a python virtual environment. It’s a completely different topic and belongs in a separate Community Guides page.

I’ve removed the offending post.

Hi, nice tutorial fully working over here!

One question, how to update?

sudo apt update && sudo apt dist-upgrade -y && sudo apt autoremove –y

Is this enough?

Hi,

I use this Installer script. Works fine with ubuntu 20.04. THANKS! But, how can I add my USB stick (/dev/ttyACM0) to docker? HA integration page can’t find it.

Best to start a new thread. This post covers installs using 18.04.

Installation went fine, but I only got the hassio containers, no container for the Home Assistant itself, and thus there is no application listening on port 8123. Installation done on my nuc running Ubuntu 18.04.4.

I got the following containers in docker:
hassio_multicast
hassio_cli
hassio_audio
hassio_dns
hassio_supervisor

I guess one container for Home Assistant is missing?

On 8/8/20, followed this guide to successfully get HA running on Ubuntu 20.04 LTS on i5 quadcore.

@kanga_who. Hi. Thanks for this guide, it was exactly what I was looking for and worked perfectly. Really appreciate it! A couple questions I have and would be great if you could guide me:

  1. Your disclaimer: “[paraphrasing] installation is not official I (the user) am responsible for updates, etc.” The question: are there specific steps to follow to update HA or is it the same I do on my RPI (i.e., use the supervisor pannel -https://www.home-assistant.io/hassio/)? If there are specific steps, could you point me to documentation to follow? (Note that I’m just talking about updating HA, not Ubuntu/Docker)
  2. After following the guide I see that there are 7 HA docker images running. I’m assuming this is expected, could you point me to documentation to read more about why all these images are needed and which is the one actually running HA? (I’m guessing it’s either ‘homeassistant/amd64-hassio-supervisor’ or ‘homeassistant/qemux86-64-homeassistant:0.113.3’)

Thanks again!

Yes, update HA in the same way via the Supervisor panel. You will also need update Ubuntu to keep it up to date with security patches.

Thanks a lot!

@kanga_who First, I appreciate this guide (and its siblings). I have felt constrained in HassOS, so these are a welcome alternative.

However…
While I was able to install this under Ubuntu 20.04 Desktop, I don’t want the overhead of the GUI. So, I installed Server. But I keep getting this in the logs for
systemctl status hassio-supervisor.service

20-08-14 01:14:00 INFO (MainThread) [supervisor.updater] Fetch update data from https://version.home-assistant.io/stable.json
20-08-14 01:14:00 WARNING (MainThread) [supervisor.updater] Can't process version data: 'null'
20-08-14 01:14:00 WARNING (MainThread) [supervisor.plugins.dns] Error on install CoreDNS plugin. Retry in 30sec

I have tried 18.04 too; I even used your guide for Debian 10. I get the same error.

The error seems to stem from getting a bad value from https://version.home-assistant.io/stable.json (presumably the “dns” value, which is 9). Searching for that error returned 2 results, neither of which helped.

Do you (or anyone) have any suggestions for how to resolve this error?

Thanks,
Mick

(FWIW, I have chased this down from the original error, “Error: No such container: hassio_cli”, which I get when trying to run any ha command.)

Edit: While going through it again, I see a preceding CoreDNS error:
20-08-14 01:48:20 INFO (MainThread) [supervisor.plugins.dns] No CoreDNS plugin Docker image homeassistant/amd64-hassio-dns

Also, the only docker container is homeassistant/amd64-hassio-supervisor, with 2 images homeassistant/amd64-hassio-supervisor TAG: 232 and homeassistant/amd64-hassio-supervisor TAG: latest

Update: I went back to Ubuntu desktop and have the same issue now.

I’m having the same problem

It appears the installer script was updated about 20hrs ago by the dev team.

I’m updating the info on my end now, should work again shortly.

@mickjacobsen @ajhutton
Working again now.

1 Like

Hi guys.

I might have messed up.

I’ve had problems updating homeassistant for the last couple of releases, so I thought a fresh install with a restored backup would help.

I tried to stop and remove the containers using portainer, but was only successfull in removing the actual homeassistant-container. dns, supervisor, cli, multicast and audio are all still there.

I also removed everything in the config directory ( /usr/share/hassio/homeassistant )

Could this be fixed by just by building a new container? If so, which one is it? I had a look on dockerhub, but it didn’t make much sense to me.

Any ideas how to fix this? I have other stuff on the machine so hopefully I dont have to reinstall the whole OS.

/Hank

Just run the install script again.

Had already tried that without success, but did it again after your response. It worked! Thanks!

However, the initial problem still remains. When I try to upgrade I get an error, when checking the logs is get the following:

20-08-14 16:48:23 ERROR (SyncWorker_1) [supervisor.docker.interface] Can’t install homeassistant/qemux86-64-homeassistant:0.114.0 -> 404 Client Error: Not Found (“no such image: homeassistant/qemux86-64-homeassistant:0.114.0: No such image: homeassistant/qemux86-64-homeassistant:0.114.0”).
20-08-14 16:48:23 INFO (SyncWorker_1) [supervisor.docker.interface] This error is often caused by not having enough disk space available. Available space in /data is: 199.2 GiB
20-08-14 16:48:23 WARNING (MainThread) [supervisor.homeassistant] Update Home Assistant image fails

I have my machine plugged into my TV, and there the following pops up when I try to update:

overlayfs: overlapping upperdir path

Anyone? Please?

I think the only solution is to uninstall docker, and then install back.

Thank you!! SO much better now!

Is this still the only way to install HA Supervised on a linux OS?

Is there still no “official” procedure for a supposedly “officially supported” install method?

I couldn’t find anything on the HA install pages.