Installing Home Assistant Supervised using Debian 12

As for now until HA Supervised fully supports Debian 12 (“Bookworm”) you can use the following links:

1 Like

As for now until HA Supervised fully supports Debian 12 (“Bookworm”)

@Tamsy, can not get it working with Debian 12.
dpkg -i homeassistant-supervised.deb fails, no dependencies are found (systemd-journal-remote, systemd-resolved). When I try to resolve it with apt-get -f install, it fails at

1. [info] Restarting NetworkManager
2. [info] Set up systemd-journal-gatewayd socket file
3. [info] Enable systemd-journal-gatewayd

see the full log at pastebin.

As mentioned HA Supervised does not yet support Debian 12. If you get HA up and running you will get an “Unsupported Installation”.

Either install Debian 11 (“Bullseye”) for now or wait for HA 2023.7.x which as rumor says will support Debian 12.

1 Like

ah, thanks. I’ve read your message incorrectly initially.

Are you sure about that? :slight_smile: I just checked (for an answer in another thread), and it says Debian 12 is supported for Supervised install…???

See here:

Arcording to this writing (19h ago): “[…] for now yes unsupported OS so unsupported system […]”

1 Like

Strange, isn’t it? But in doubt I don’t believe the documentation, I’d rather go with someone who tried it… :rofl:

1 Like

Exactly my thinking too :grin:

1 Like

There is no update mechanism for updating the homeassistant supervised deb or the os agent deb. You need to make sure you have the latest when trying stuff.

I have installed vanilla Debian-12 ob RPi4 and installed HA Supervised.
Does anyone know how I can overclock the PI4B when it is running vanilla Debian?
I have tried adding the overclocking params in /etc/default/raspi-firmware-custom, but they do not seem to have any effect.

Usually /boot/config.txt

You can just install the new version over the top. I have done os-agent multiple times to make sure I was running latest and due to a new bunch of HA instigated incompatibilities I just reinstalled the requirements and ran the deb script file again just a few days ago.

Yes of course, but my point is that it is not just a one-off set-and-forget.

Chicken and egg :
I have HAS installed on Debian 12 but ends up with “Unhealthy system - Not privileged”.
I can not install “Advanced SSH & Web Terminal” because : “AddonManager.install’ blocked from execution, system is not healthy - privileged”
Any clue ?

rerun supervised installer could help

You can also set it to ignore the health check

For those who just want to upgrade from Debian 11 (bullseye) to Debian 12 (bookworm) check out my upgrade guide here. The guide is also valid for x86_64-devices.


Could I have some help please, I am trying to install HA suprvised on a intel based laptop following the official installation instructions on a clean whole disk install of Debian 12.

When I install the dependency “systemd-resolved” I lose internet access. I have tried setting my router to be the DNS server and /etc/resolvr.conf gets populated with nameserver: nameserver: ( gateway address ) so Network Manager is working. But I still have no internet access. I have also tried editing resolvr.conf with

When I disable systemd-resolved ( sudo systemctl disable systemd-resolved.service) internet starts working again and I can get to the stage where home assistant installation takes place but the script enables systemd-resolved and then stalls due to loss of internet.

I am able to open another terminal session and disable / stop systemd-resolved and the installation completes. When I reboot the laptop I have no internet with systemd-resolved active or disabled.

Has anyone done a clean install of Home Assistant Supervised on Debian 12, did you have these issues and how did you get internet working please?

Have you tried this?

1 Like

Thankyou for responding, I have tried this temporary fix but it did not work for me. resolv.conf is a symlink file that is updated by network-manager ( another dependency required by the home assistant installer ). Every time I boot the machine resolv.conf in overwritten.