Installing Home Assistant Supervised using Debian 12

Thank you for this very well explained guide. I managed to install it, but home assistant doesn’t start after a reboot. Could someone guide me in the right direction?

when you run systemctl status hassio-supervisor.service what youre getting?

1 Like

being lazy a.f. and into reinstalling HA a way to often I just scripted the steps.
It’s based on my needs but feel free to include or change it when you think that it is useful. I would be honored.

I got it working following this guide: Autostart using systemd

I’m a tad confused here.

Been running HA on Ubuntu 18.4 LTS, with gnome desktop, for quite a while. Right now I’m thinking about reinstall Ubuntu for a couple of reasons. And noticed this new thing about official and not.

Could anyone help me figure this out. My hardware is an old macbook pro, with desktop. And running more than hass.

If I install Ubuntu again, it’s not officially supported.
If I follow the official installation and then install more software, it’s no more officially supported.

So, since I then will end up with an unsupported installation anyway, are there any other differences between istalling on Ubuntu or Debian?

If you are doing a fresh install, you might as well use Debian. It’s a little lighter weight as an OS than Ubuntu, but it’s not really going to make a massive difference at the end of the day - you’ll be running unsupported anyway.

You could also look at using Proxmox and running HA OS in a VM, and then run another VM with Ubuntu/Other Distro for anything else you want to install, gives you the best of both worlds and is considered fully supported. This is how I run things now and it works very well.

1 Like

can’t get this working on debian 10.6 keep getting errors about apparmor avahi even though they are installed

When was supervised dropped as being supported? Or are you just making the case that it is basically unsupported due to HA lack of help with these types of installs?

Right, so supervised with Debian is still supported as I read it.

Correct supervised on Debian is supported.

1 Like

Here is my info. HA running on a RPI4 2GB on mSata SSD

arch aarch64
dev false
docker true
docker_version 19.03.13
hassio true
host_os Debian GNU/Linux 10 64Bit Beta
installation_type Home Assistant Supervised
os_name Linux
os_version 5.4.72-v8+
python_version 3.8.5
supervisor 2020.10.0
timezone Europe/Amsterdam
version 0.116.4
virtualenv false

Why did you install a beta of Debian? That is asking for trouble. You should have installed Buster…

Oops NVM… 64bit is beta for RPi…

This is a great guide you’ve created, Kanga-Who, but it is not working for me. I’ve tried both the RPi version, and now I’ve moved on to an old laptop running Debian. I’ve followed all the steps, carefully, but always end up unable to connect to the web interface. Further reading makes me wonder if it’s a regional setting? I set for Canada, maybe that confuses something? This is what I see every time I try to install…

Also I CAN reach the Supervisor’s web interface, so something goes right; I just can’t get to the main interface!

Any additional troubleshooting tips would be appreciated!
Thank you! :slight_smile:

Um??? There is no such thing…

It may be a network (internal) or regional issue. I test the guides regularly myself to make sure they work as intended.

There is no Supervisor web interface. Can you provide a screenshot of what you are referring too?

Apologies… wrong nomenclature on my part… the OBSERVER is what I meant…

I got it working! The trick, in my case was to delete 2 lines from the code… basically the if statement around “do you want to proceed” or not. The script never waited for my response in all the previous times I ran it, so it seemed to me the interfaces file was never being overwritten. By removing the option to choose whether or not its overwritten, it seems to have done the trick! :smiley:


Followed this guide and installed onto a 10yr old Acer Revo 3900 with Atom 230 CPU. And it works perfectly.

No issues with restoring config nor USB z wave stick, literally plug and play.

Thank you so much for this wonderful guide :grinning:

1 Like

is it Raspbian 10 or Debian 10 arm64?