Installing Home Assistant Supervised using Debian 12

Something like this.

sudo systemctl stop hassio-supervisor.service
sudo docker rmi -f homeassistant/aarch64-hassio-supervisor:latest

Ah, OK. So it looks like it just completely removes the container and the associated image. I think.

I’ve been wrestling with Debian the past few days. There were still problems with my installation. Somehow, I managed to mess up booting with a running NetworkManager. I could start it manually after a boot, but after spending some time trying to get it working, it seemed easier just to reinstall everything. In going though the exercise again, I have some observations:

I found it difficult to install the correct driver for my network device (Realtek rtl8168g). The interface worked well enough for the installation process, but it complained at every boot. I also have an Intel processor that wants some firmware (or microcode), presumably to mitigate the Spectre/Meltdown security vulnerability. It turns out that 3rd party drivers are designated as “non-free” and are not included in the basic installation images <>. There are various ways of finding the right driver, but they’re typically aggregated by manufacturer into larger archive files which need to be moved over and somehow installed. Without a fully configured system, it becomes cumbersome. The good news is there’s a way of getting a distribution with the non-free binaries included. They’re here:

This is the one I wound up using:

The second observation is that when I installed the latest distribution, it did not allow me to skip the installation of the Package Manager. The installer plows ahead without offering up a choice. I’m not sure what this does to the HA installation guidelines.

My next observation relates to a post I made two days ago. When installing the OS, I saw a specific reference to brltty during the installation. It seemed out of place and I suspected that leaving the USB-to-serial cable connected to the system might’ve triggered it. Before proceeding with the HA installation, I reinstalled Debian with the cable disconnected and my hunch was correct; no brltty process was running after the installation was complete.

My last observation is an issue still unresolved. While HA responds to the CLI, the HTTP sever doesn’t provide a browser interface. I get this information at boot time:

[    4.184767] systemd[1]: Found ordering cycle on hassio-supervisor.service/start
[    4.184776] systemd[1]: Found dependency on docker.service/start
[    4.184783] systemd[1]: Found dependency on
[    4.184791] systemd[1]: Job hassio-supervisor.service/start deleted to break ordering cycle starting with

This is the only issue I see in dmesg. Unfortunately, I don’t know where to go with the information. Any help would be appreciated.

Edit: ‘docker stats’ shows this message:

Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Get http://%2Fvar%2Frun%2Fdocker.sock/v1.24/version: dial unix /var/run/docker.sock: connect: permission denied

Im running HA supervised on an ASUS “nuc”. I’m using an m2 SSD for the OS and all installations and a normal HDD for storage. I would like to move my HA database to the HDD, which is mounted under “storage”, but HA keeps telling me that “the recorder component couldn’t be set up” when trying to follow the documentation. The home-assistant_v2.db is normally found in /usr/share/hassio/homeassistant/, and I would like to run it from the /storage/hass_db/ folder. Adding db_url: sqlite:////storage/hass_db/ under recorder: in my config file doesn’t help.

After asking around I understand that the docker container doesn’t have access to folders outside the “homeassistant” folder, and that you specify accessible folders when setting up the container, which I have experienced while setting up e.g. PLEX.

Since I installed HA supervised using the script in the topic, is there any other way to “add” folders to the container in retrospective? Would it be possible to create a symlink instead, or would the problem remain since a symlink is a shortcut to the folder HA cant access?

What’s your experience?

I hope to get some help troubleshooting a “refused to connect” after following this install guide. I made it to the end with the only error referring to [warn] Changes are needed to the /etc/network/interfaces file". I answer yes to overwrite and get [info] First setup will take some time, when it’s ready you can reach it here: Waiting more than an hour, the connection is still refused from my Win10 PC. I can connect to the system with Putty/SSH and can issue the ip a and sudo docker ps commands. My LAN connection is enp5s0 and the ip address matches the the one produced by the install script. The two docker containers installed are hassio observer and supervisor. “Hello World” works. Looking at the interfaces file with nano, it is empty. Out of desperation, I added the 8123 port to ufw, which didn’t work. I also disabled ufw which also didn’t allow me to connect. What else can I check?

If you have just done a fresh install today, then you most likely have encountered the issue between the recent Docker 20.x update and HA Supervisor.

Try these steps.

sudo apt remove docker-ce
sudo apt autoremove --purge -y
sudo reboot

When the machine comes back online;

sudo apt install docker-ce=5:19.03.13~3-0~debian-buster
sudo reboot

If this is successful, do not do any OS updates until the Supervisor update comes through to address the Docker 20.x issue.

You may also need to re-run the installer script.

sudo -i
curl -sL "" | bash -s

Actually, it was my third “fresh” install of debian today, lol.
Thank you for you quick reply and suggestions. It worked and I’m able to log in through the user interface. I don’t remember why I installed ufw, it wasn’t included in the distro; should I keep it? I’m trying to maintain a minimal “well documented” install of debian and home assistant in an effort to minimize future complications.

Worked for me. That must’ve been the root cause of my frustrations over the last few days. I could get things to work after a fresh install, but they wouldn’t survive a reboot.

Thanks again.

1 Like

Was going to post this yesterday, did 4 installs and got so pissed at the issues and finally downgraded to 5.19 as I had that on the old ubuntu and it just worked.

WARNING: The latest version of docker apparently is not compatible with Home Assistant Supervised. Suggest reading:

The fix is posted by Kanga_who above (thank you). This is posted only to add a graphic to catch people’s eye when they scan the forum instead of reading each item.

This fix is already posted 5 posts above :wink:

@kanga_who, thanks a lot, it made the trick!

1 Like

I’m reinstalling my system because of the docker issue, and decided to switch to Debian to make my installation supported.
I followed every step, but at step 4:

curl -fsSL | sh

I get stuck with the following error:

> # Executing docker install script, commit: 3d8fe77c2c46c5b7571f94b42793905e5b3e42e4
> + sh -c apt-get update -qq >/dev/null
> + sh -c DEBIAN_FRONTEND=noninteractive apt-get install -y -qq apt-transport-https ca-certificates curl gnupg >/dev/null
> + sh -c curl -fsSL "" | apt-key add -qq - >/dev/null
> Warning: apt-key output should not be parsed (stdout is not a terminal)
> + sh -c echo "deb [arch=amd64] buster stable" > /etc/apt/sources.list.d/docker.list
> + sh -c apt-get update -qq >/dev/null
> E: Method https has died unexpectedly!
> E: Sub-process https received a segmentation fault.

I haven’t found anything regarding this error when i search this topic, so I hope somebody can help me with this.


Hi Rick,

I’ve just fudged my way through it reinstalling 4 times thinking I had an issue with HyperV but it was the docker issue the guys have mentioned above. All is well now.

You may need the prerequisites from the Docker Debian page:

$ sudo apt-get install \
    apt-transport-https \
    ca-certificates \
    curl \
    gnupg-agent \

That might get you past that error. then follow on with Kanga’s instructions

Hello… Thank you for the installation procedure. But instead of installing on Debian 10 distribution, I used the Raspberry pi OS 64 bits (still in development but build on Debian 10 so fully compatible) to install Home Assistant supervised (I need to access the Pi via VNC to control remote equipments, easy with Raspbian OS)… It went very well (except as mentioned the docker version to downgrade to 19.03.13). Thank you again !

Unfortunately this didn’t solve the issue, still get the same error.

Raspberry Pi OS is not a supported OS by Home Assistant, you may want to check out this guide instead for installing Debian 10 on a Pi.

This guide and thread is discussing Debian 10, not Raspberry Pi OS :wink:

@kanga_who Raspberry pi OS 64 bits is based on Debian 10… So after installation, it says “supported Yes” !.. :wink:
But I understand and accept that Raspbian OS 64 bits is under development and assume all the risks associated with it but Debian 10 light is so light that it is not meeting my requirements (VNC and browser access)… Nevertheless your procedure is also working for Raspbian OS, that’s my point… So I thank you for that, you saved me time and a lot of goggle search !

same problem here today 12/12/2020.
I try to modify file sources.list…but same resoults…

Ping is ok.
I made sudo update && upgrade.
all packages are update…but can not install network manager -software utilities-app armor - jq