Installing Home Assistant Supervised using Debian 12

Works like a charm. Just installed Debian 11 + HASSIO Supervised on a Dell Laptop.
Thank you!

Is this still relevant - given that these instructions were posted in MAY 2020? (post #1)

It is. The OP keeps it always current (last edit as of today): 10 days ago.


hi @francisp , do you know how to disable portainer so that it won’t start during boot? I could remove it as well, find I sometimes find it useful, that’s why I would like to keep it disabled and just launch it when needed. I guess that HA won’t complain if portainer is not running during boot?

i followed this how-to exactly, just that my raspi is booting with PXE from NFS. Sadly the system losses connection as soon as the supervisor container is started. I’s supecting that the nework is being reset by the supervisor and thus i’m loosing the terminal and hassio is loosing its root fs… :confused:

This guide is not for a Pi, there is a seperate guide for that.

Ouch, yes, sorry. Indeed i followed this other guide, and i meant to comment there. Thanks for the super fast reply though!

1 Like

Worked like a charm on installing Debian 11 on my Intel (Celeron) NUC through PXE.

hi, anyone else with an unsupported install due to connectivity_check? the link takes me here:

But after executing the command on the host and rebooting the problem still exists. Greetings and thank you

it seems that this is already being dealt with

I’m in a similar environment, how do you see this? Does one install proxmox extra or how to go about this? ( I have no experience with that by the way )

What would be the best way to do an actual uninstall?
Are there any scripts for that available?

1 Like

Hi @Tamsy ,
Can you send the link for the cli command.
I don’t find Section 4 paragraph 3 within the OP. I don’t know where to search. it’s ?

You mean the cli* command to supress that “unhealty”-message?

Note 4.3 at the instructions:

4.3) Once logged in you can now execute the following command;

ha jobs options --ignore-conditions healthy

*cli = Command Line Interface

Need a bit help here,
So after an outage my sonoff usb dongle wont get detected

FileNotFoundError: [Errno 2] No such file or directory: '/dev/serial/by-id/usb-ITead_Sonoff_Zigbee_3.0_USB_Dongle_Plus_28bcffbd2f86ec11b67f5b1719c2d21c-if00-port0

As per instruction here

I need to install docker-compose first, however upon installing, it says

The following packages will be REMOVED: docker-ce docker-ce-cli docker-ce-rootless-extras

From my previous experience doing this, it wiped out my entire HA installation.
So how do i fix this ?
Also more importantly how do I permanently attach the zigbee usb to the container so that It’ll retain it even after reboots?

So something strange just happened,
My supervised HA was using different ip with the debian host, (because the old installation was from another machine)
So one of my cams went off and i checked the POE switch, and I accidentally reboot the modem.
Then somehow my supervised HA changes its ip to match the debian host, and
then the zigbee suddenly connected again!
Can anyone explain why?

Just a quick question; This affects existing running docker containers right?
Are they all deleted, or just stopped?
Maybe it is just easier to do a whole docker install and skip the whole supervisor?

Edit: already managed by moving my VMware machine from old W10 to new Debian, so still running my dockers as well as HAos Supervised :grin:
Nevertheless, Still would like to know the answer :thinking:

I followed the instructions but I get error messages and I can’t install addon or restore since the system is unhealthy.
I am attaching two photos for more info, and also how to store all the containers under a single container under portainers?

This thread might help you (amongst many others in the forum discussing the “System is unhealthy” problem). Additionally Frenck’s comment on Github will shed some enlightement on the latter.

Anyone experimented with docker-in-docker??

I have a supervised in debian installed with the help of this guide.
I am trying to update from 2022.11.0b00 to 2022.11.1 but it fails silently,
Os is updated

dvbit@homeassistant:~$ sudo apt-get update
[sudo] password for dvbit: 
Hit:1 bullseye-security InRelease
Hit:2 bullseye InRelease       
Hit:3 bullseye-updates InRelease
Hit:4 bullseye InRelease
Reading package lists... Done
dvbit@homeassistant:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

this is the result of ha resolution info is

dvbit@homeassistant:~$ ha resolution info
- enabled: true
  slug: free_space
- enabled: true
  slug: addon_pwned
- enabled: true
  slug: dns_server
- enabled: true
  slug: supervisor_trust
- enabled: true
  slug: dns_server_ipv6
- enabled: true
  slug: backups
- enabled: true
  slug: network_interface_ipv4
- enabled: true
  slug: core_security
issues: []
suggestions: []
unhealthy: []
- job_conditions

the system details are:

dvbit@homeassistant:~$ ha core info
arch: amd64
audio_input: null
audio_output: null
boot: true
machine: qemux86-64
port: 8123
ssl: false
update_available: true
version: 2022.11.0b0
version_latest: 2022.11.1
watchdog: true
dvbit@homeassistant:~$ ha supervisor info
- icon: true
  name: Home Assistant Google Drive Backup
  repository: cebe7a76
  slug: cebe7a76_hassio_google_drive_backup
  state: started
  update_available: false
  version: 0.108.4
  version_latest: 0.108.4
- icon: true
  name: AppDaemon
  repository: a0d7b954
  slug: a0d7b954_appdaemon
  state: started
  update_available: false
  version: 0.10.0
  version_latest: 0.10.0
- icon: true
  name: ESPHome
  repository: 5c53de3b
  slug: 5c53de3b_esphome
  state: started
  update_available: false
  version: 2022.10.2
  version_latest: 2022.10.2
- icon: true
  name: SSH & Web Terminal
  repository: a0d7b954
  slug: a0d7b954_ssh
  state: started
  update_available: false
  version: 12.1.2
  version_latest: 12.1.2
- icon: true
  name: Studio Code Server
  repository: a0d7b954
  slug: a0d7b954_vscode
  state: started
  update_available: false
  version: 5.4.0
  version_latest: 5.4.0
- name: Local add-ons
  slug: local
- name: Hass.IO Repository for snowzach
  slug: d5f40609
- name: Addons by mKeRix
  slug: 6e66619d
- name: Add-ons by petersendev
  slug: fec04c7c
- name: Add-ons by petersendev
  slug: 79aa6cf0
- name: Home Assistant addons by Arne Gellhaus
  slug: c7744bff
- name: Frigate addons
  slug: ccab4aaf
- name: Hass.IO dianlight add-on repository
  slug: 1a32f091
- name: Moshe's HA Addons
  slug: f82d1e81
- name: Home Assistant add-on repository by Iesus
  slug: 224ec5dd
- name: Home Assistant addons by bertbaron
  slug: 5f3a9361
- name: Double Take Add-ons
  slug: c7657554
- name: Home Assistant Google Drive Backup Repository
  slug: cebe7a76
- name: Asterisk Add-on
  slug: b35499aa
- name: ' Addon: CORAL TPU Rest API'
  slug: d44241f3
- name: otmonitor Add-on
  slug: a7902f0f
- name: AlexxIT addons repository
  slug: a889bffc
- name: The silly home add-on repository
  slug: "89141162"
- name: Helto4Real Add-ons
  slug: 1e72b768
- name: Home Assistant Emoncms Repository
  slug: 24b9df28
- name: SDeSalve add-ons for Hassio
  slug: 89275b70
- name: Official add-ons
  slug: core
- name: ESPHome
  slug: 5c53de3b
- name: Poeschl Home Assistant Add-ons
  slug: 243ffc37
- name: Home Assistant Community Add-ons
  slug: a0d7b954
arch: amd64
auto_update: true
channel: stable
debug: false
debug_block: false
diagnostics: true
healthy: true
logging: info
supported: false
timezone: Europe/Rome
update_available: false
version: 2022.10.2
version_latest: 2022.10.2
wait_boot: 5

Any clue on what could be happening / how to extract a log of the update / make it verbose?

*** Edit ***: Solved
The issue was lack of space on /var in the linux vm.
Unfortunately there was no message at all on HA side