Installing homegear on 0.64.2

Hi all,
I’m trying to install homegear on hass.io 0.64.2 on RPi3. After several tries of uninstalling and installing, I’m wondering if I’m using a wrong path?
I’m trying to install homegear, by using the following repository GitHub - yeah/hassio-addons: Homegear as a Hassio add-on. The addon appears, but no folders for homegear are created, as described in github. Clicking on start or rebuild does also not help. Nothing happens. Any ideas? I’m open for any other paths…
Thx for any advise.

… that’s how my log is looking right now:

2018-03-03 20:12:14 WARNING (Recorder) [homeassistant.components.recorder] Ended unfinished session (id=10 from 2018-03-02 20:19:27.387840)
2018-03-03 20:12:21 ERROR (MainThread) [homeassistant.setup] Error during setup of component homematic
Traceback (most recent call last):
File “/usr/lib/python3.6/site-packages/homeassistant/setup.py”, line 148, in _async_setup_component
component.setup, hass, processed_config)
File “/usr/lib/python3.6/asyncio/futures.py”, line 332, in iter
yield self # This tells Task to wait for completion.
File “/usr/lib/python3.6/asyncio/tasks.py”, line 250, in _wakeup
future.result()
File “/usr/lib/python3.6/asyncio/futures.py”, line 245, in result
raise self._exception
File “/usr/lib/python3.6/concurrent/futures/thread.py”, line 56, in run
result = self.fn(*self.args, **self.kwargs)
File “/usr/lib/python3.6/site-packages/homeassistant/components/homematic/init.py”, line 289, in setup
‘ip’: socket.gethostbyname(rconfig.get(CONF_HOST)),
socket.gaierror: [Errno -2] Name does not resolve
2018-03-03 20:15:04 ERROR (MainThread) [homeassistant.core] Timer got out of sync. Resetting

probably the system log is also usefull

starting version 3.2.4

18-03-03 19:11:11 INFO (MainThread) [main] Initialize Hassio setup
18-03-03 19:11:11 INFO (MainThread) [main] Setup HassIO
18-03-03 19:11:11 INFO (SyncWorker_0) [hassio.docker.supervisor] Attach to supervisor homeassistant/armhf-hassio-supervisor with version 0.96
18-03-03 19:11:13 INFO (SyncWorker_0) [hassio.docker.interface] Cleanup docker images: [‘homeassistant/armhf-hassio-supervisor:0.95’]
18-03-03 19:11:13 INFO (MainThread) [hassio.misc.host_control] Send ‘info’ to HostControl.
18-03-03 19:11:14 INFO (MainThread) [hassio.misc.host_control] Receive from HostControl: { “type”: “resinos”, “version”: “1.1”, “last_version”: “1.1”, “hostname”: “hassio”, “features”: [“shutdown”, “reboot”, “update”, “hostname”], “os”: “GNU/Linux” }.
18-03-03 19:11:14 INFO (SyncWorker_1) [hassio.docker.interface] Attach to image homeassistant/raspberrypi3-homeassistant with version 0.64.2
18-03-03 19:11:14 INFO (MainThread) [hassio.addons.git] Load addon /data/addons/core repository
18-03-03 19:11:14 INFO (MainThread) [hassio.addons.git] Load addon /data/addons/git/89330960 repository
18-03-03 19:11:14 INFO (MainThread) [hassio.addons] Load addons: 20 all - 20 new - 0 remove
18-03-03 19:11:14 INFO (SyncWorker_3) [hassio.docker.interface] Attach to image homeassistant/armhf-addon-samba with version 3.0
18-03-03 19:11:14 INFO (SyncWorker_1) [hassio.docker.interface] Attach to image homeassistant/armhf-addon-ssh with version 3.4
18-03-03 19:11:14 INFO (SyncWorker_7) [hassio.docker.interface] Attach to image 89330960/armhf-addon-rpi-homegear with version 0.2
18-03-03 19:11:14 INFO (SyncWorker_4) [hassio.docker.interface] Attach to image homeassistant/armhf-addon-homeassistant with version 2.31.25-p2
18-03-03 19:11:14 INFO (SyncWorker_0) [hassio.docker.interface] Attach to image homeassistant/armhf-addon-configurator with version 0.2.6
18-03-03 19:11:15 INFO (MainThread) [hassio.updater] Fetch update data from https://raw.githubusercontent.com/home-assistant/hassio/master/version.json
18-03-03 19:11:15 INFO (MainThread) [hassio.snapshots] Found 1 snapshot files
18-03-03 19:11:15 INFO (MainThread) [hassio.addons] Startup initialize run 0 addons
18-03-03 19:11:15 INFO (MainThread) [main] Run HassIO
18-03-03 19:11:15 INFO (MainThread) [hassio.misc.dns] Start DNS port forwarding for host add-ons
18-03-03 19:11:15 INFO (MainThread) [hassio.core] Ignore Hass.io auto updates on beta mode
18-03-03 19:11:15 INFO (MainThread) [hassio.core] Start API on 172.30.32.2
18-03-03 19:11:15 INFO (MainThread) [hassio.addons] Startup system run 1 addons
18-03-03 19:11:15 INFO (SyncWorker_6) [hassio.docker.interface] Clean homeassistant/armhf-addon-homeassistant docker application
18-03-03 19:11:22 INFO (SyncWorker_6) [hassio.docker.addon] Start docker addon homeassistant/armhf-addon-homeassistant with version 2.31.25-p2
18-03-03 19:11:27 INFO (MainThread) [hassio.addons] Startup services run 3 addons
18-03-03 19:11:27 INFO (SyncWorker_2) [hassio.docker.interface] Clean homeassistant/armhf-addon-ssh docker application
18-03-03 19:11:27 INFO (SyncWorker_8) [hassio.docker.interface] Clean homeassistant/armhf-addon-samba docker application
18-03-03 19:11:27 INFO (SyncWorker_3) [hassio.docker.interface] Clean 89330960/armhf-addon-rpi-homegear docker application
18-03-03 19:11:35 INFO (SyncWorker_8) [hassio.docker.addon] Start docker addon homeassistant/armhf-addon-samba with version 3.0
18-03-03 19:11:36 INFO (SyncWorker_2) [hassio.docker.addon] Start docker addon homeassistant/armhf-addon-ssh with version 3.4
18-03-03 19:11:39 ERROR (SyncWorker_3) [hassio.docker] Can’t start addon_89330960_rpi-homegear: 500 Server Error: Internal Server Error (“driver failed programming external connectivity on endpoint addon_89330960_rpi-homegear (154cb344116dd3ff4941c13d76a616cafb98223264bd8804250d695638779a50): Bind for 0.0.0.0:2001 failed: port is already allocated”)
18-03-03 19:11:44 INFO (SyncWorker_1) [hassio.docker.interface] Clean homeassistant/raspberrypi3-homeassistant docker application
18-03-03 19:11:49 INFO (SyncWorker_1) [hassio.docker.homeassistant] Start homeassistant homeassistant/raspberrypi3-homeassistant with version 0.64.2
18-03-03 19:12:39 INFO (MainThread) [hassio.homeassistant] Detect a running Home-Assistant instance
18-03-03 19:12:39 INFO (MainThread) [hassio.addons] Startup application run 1 addons
18-03-03 19:12:39 INFO (SyncWorker_11) [hassio.docker.interface] Clean homeassistant/armhf-addon-configurator docker application
18-03-03 19:12:43 INFO (SyncWorker_11) [hassio.docker.addon] Start docker addon homeassistant/armhf-addon-configurator with version 0.2.6
18-03-03 19:12:48 INFO (MainThread) [hassio.tasks] All core tasks are scheduled
18-03-03 19:12:48 INFO (MainThread) [hassio.core] Hass.io is up and running
18-03-03 19:16:55 INFO (SyncWorker_11) [hassio.docker.interface] Clean 89330960/armhf-addon-rpi-homegear docker application
18-03-03 19:16:57 ERROR (SyncWorker_11) [hassio.docker] Can’t start addon_89330960_rpi-homegear: 404 Client Error: Not Found (“linux runtime spec devices: error gathering device information while adding custom device “/dev/ttyACM0”: lstat /dev/ttyACM0: no such file or directory”)

Had the same problem.
First, you need to wait quite a long time for an add-on to be installed (around 20-30min) If you interrupt it in any way you’ll have this problem.
And Second, after you find yourself in this situation it is best to choose “uninstall” and start from the beginning than “rebuild”.
This is what worked for me.

It would be great if you could report your progress with the setup because I have working add-on and all the files but still did not manage to get it to work.
I constantly get these messages:

Couldn’t read from CUL device, because the file descriptor is not valid: /dev/ttyACM0. Trying to reopen…

and I don’t know what to do because “hassio host hardware” shows hardware detected. I’m obviously missing something.