Installing on Raspberry Pi4 B 8Gb w/PoE Hat v2

Tags: #<Tag:0x00007f325e870fb8> #<Tag:0x00007f325e870e78>

Hello,

I have the above spec, I can see the DHCP server giving out an IP to the unit, but I cannot connect to the webpage at all.

I started out flashing the 64bit OS, before I realised GPIO was possibly not supported on it, so gone over to the 32bit OS. Flashed with etcher and then plugged the SD card.

Can’t get anything out the webpage.

Without ordering myself a micro hdmi adapter, is there anything that screams not possible here?

Thanks

CCL

Welcome to the community… I presume you installed HASS OS 64bits followed by HASS OS 32 bits (you loose the benefits of 8Gb with 32 bits version)… You have to wait a couple of minutes before seeing the webpage on “homeassistant.local:8123”…

Thanks, yes used etcher to put 64bit onto the SD card, when nothing happened after 1 hour, no response from webpage or pinging the Pi I researched a little and saw GPIO support on 32bit version of HASS OS, so wiped the SD and used the 32bit with etcher. Same thing happens, no ping or webpage response for an hour. Tried removing the PoE hat and used a USB C cable to power it, same response with 32bit OS. Brand new SD card also, Sandisk ultra A2 64Gb variant

I have managed to resolve the issue. My router was quarantining the device on boot for some reason.

CCL

Glad you have it resolved… Are you sure the 64 bits is not supporting GPIO ? I would give a try to avoid to loose the benefits of the 8Gb memory…

1 Like

Thanks will try in due course.

Heyhey, I’m running 64 bit on a Pi 4, and have GPIO working fine, for what it’s worth.

Is it possible to get everything up and running using USB-C power, and later install the POE Hat? I tried to do this, and my Raspberry Pi4 B 8Gb refuses to boot on POE. The power LED on the Pi simply flashes a single time over and over forever.

I couldn’t say for sure, I don’t have the POE hat. That said, power is delivered through my case to the GPIO pins, not the USB C port, so I would imagine it should be fine.
If you have a spare SD card, can you put Rapsberry Pi OS and boot the Pi using that with POE? If not, something is wrong with your Pi or POE hat. If so, then it would be worth seeing if a clean install of HassOS will boot with POE and the sd card to see if there is a config issue in your OS…