Integration Smartthings fails

Hello,

Previously I had the Smartthings integration set up, but as of a recent update it started posting errors in my log so I decided to delete it so I could set it up fresh.

The problem is that when I now go to Integration - Add Integration and choose Smartthings I get this error message

“Config flow could not be loaded”

image

Does anyone know what I need to do in order to successfully set up the integration once again? I have tried restarting the host system after deleting the previous Smartthings-integraion.

2 Likes

I have a same situation and smartthings integration cant be added…

I had the same error on a different component, Raspberry Pi Power Supply checker. Turns out i had an old entry in my configuration.yaml and sensor.yaml for that component and forgot to remove it. I would double-check that you don’t have an orphan entry somewhere in your .yaml files. Once I removed the entries, I was able to add the integration using the UI.

I’m having this issue as well and can’t find any residual entries for SmartThings in any YAML files. Anyone had any luck with this?

1 Like

same here… I have tested in a fresh install via VM and only works if you have home assistant cloud with Nabucasa, I have tried with Duckdns and no longer work… maybe some think I’m missing?

Per this issues page (https://github.com/home-assistant/core/issues/47449), have you checked to see that your external_url is configured? Two people on that page say that it worked for them.
I personally haven’t upgraded yet due to this issue, but I’m wondering if this works or not. I would think it would since hmbarbosa says that it works with Nabucasa but not Duckdns.

2 Likes

Thanks chewie8han!!!and the problem was the external_url not configured… easy fix… go to Configuration/General and add your https://*************duckdns.ogr:8123 and restart… works good here

Thanks for highlighting this, set up external_url parameter in my configuration and I am now able to install Smartthings integration.

Awesome. Glad I was able to help. This was hesitant to update to the newest release without knowing if this was working or not.

I have the external_url enabled but I continue to have issues after the recent upgrade. It says everything is successful but the integration does not show up after saying success.

Few lines in the log show below:

Could not start session, Max amount of sessions reached, got {}

8:35:02 PM – /usr/local/lib/python3.8/site-packages/pysma/init.py (ERROR) - message first occurred at 8:24:09 PM and shows up 8 times

Received message for unregistered webhook 9503cbd3152847243f7f12ef08d37292f448751453e0dbd2364fbd254870c9db from 54.83.145.181

8:33:08 PM – Webhook (WARNING)

Unable to setup configuration entry ‘Home’ - please reconfigure the integration

8:33:07 PM – SmartThings (ERROR)

Unable to load scenes for configuration entry ‘Home’ because the access token does not have the required access

8:33:07 PM – SmartThings (ERROR)

Gloom...!   

I have the same problem and have been trawling the pages trying to fix it. 

In the hope that the external_url parameter is the key I have entered my Nabu Casa address
(https://**********.ui.nabu.casa format) in the external_url parameter but get the same old “Config Flow Could Not be Loaded” message.

Do I have the external_url entry wrong?

Appreciate any experiences.

1 Like

I had the same issue. After trying the steps above and reaching the same error I found a file that was leftover after removing the earlier instance: “config/.storage/smartthings” (note that the storage folder is hidden). After deleting this smartthings file, I was able to get past this error and re-establish a connection to SmartThings. Hope this helps.

5 Likes

I’m having the same issue with smartthings how do you find this hidden folder?

Where can I find that duckdns link??

Easiest way I found was to install the Web & SSH integration. Then use use basic linux commands to navigate to the folder and rename the file in question. True enough it worked perfectly for me after that.

I found the file and removed it, but still having the same error. Any help is highly appreciated.

Thanks, this worked for me!
I wasn’t able to see the file in the file editor addon, but I could delete it using the Terminal & SSH addon.

I’d previously set up Home Assistant Cloud using Nabu Casa.

Here’s what I did:

  1. Go to Supervisor->Add-on store
  2. Search for Terminal & SSH and install it
  3. Enable “Show in sidebar”
  4. Click “Start”
  5. Open up the terminal in the sidebar
  6. Enter “cd config/.storage”
  7. Enter “ls -la” to confirm that there’s a smartthings file in the list
  8. Enter “rm smartthings” to delete the file

When I tried to set up the smartthings integration after that, I didn’t get the “Config flow could not be loaded” error.

4 Likes

This worked like a charm! thanks :slight_smile:

Thanks for the step by step. This worked perfectly.

Thank you - this solution fixed my config flow error.