Internal Server Error- Fresh Install

Hi all,

Posting here to document my attempts to resolve this issue, hopefully it can help other users with a similar issue. Thanks to mods who have helped me get this far.

I have a fresh install of HA that I cannot access through the browser by any method. It is listed as a wired (LAN) connection in my router UI and responds to pings, but that is all. I have tried:

  • 15-20 re-flashes
  • several re-downloads of 32bit and 64 bit images
  • several power supplies
  • several SD cards
  • several SD card readers
  • wifi and LAN install attempts
  • specifically allowing TCP traffic to port 8123 as per this guide
  • disabling windows firewall altogether

Debugging using this guide yielded the following report:

-- Logs begin at Fri 2018-06-22 11:11:49 UTC. --
Jun 22 11:47:10 hassio hassos-supervisor[552]: 18-06-22 11:47:10 WARNING (MainThread) [hassio.homeassistant] Fails install landingpage, retry after 30sec
Jun 22 11:47:40 hassio hassos-supervisor[552]: 18-06-22 11:47:40 INFO (SyncWorker_11) [hassio.docker.interface] Pull image homeassistant/raspberrypi3-homeassistant tag landingpage.
Jun 22 11:47:50 hassio hassos-supervisor[552]: 18-06-22 11:47:50 ERROR (SyncWorker_11) [hassio.docker.interface] Can't install homeassistant/raspberrypi3-homeassistant:landingpage -> 500 Server Error: Internal Server Error ("Get https://registry-1.docker.io/v2/: dial tcp: lookup registry-1.docker.io on 192.168.1.1:53: read udp 192.168.1.103:42324->192.168.1.1:53: i/o timeout").

Would appreciate some pointers from more experienced folks. I’ve had HA working in the past and it seemed great, but I’m not sure I want to automate my whole life on something that breaks on a fresh install…

This appears to be a DNS lookup issue?

It appears that it can’t resolve the URL required to download hassio images.

Thanks FM, I appreciate you taking the time.

It seems to be DNS problem associated with docker. This article suggests that these kind of errors are somewhat commonplace.

Am I able to run the kinds of tests they suggest for docker inside Hassos? This is my first foray into anything command-line related so please excuse the dumb questions. I don’t need the problems solved for me, just the right direction

You should be able to, since HassOS is just running Docker, the commands to test appear to be Docker only

Unless I am doing something wrong, I don’t seem to be able use the commands they suggest

hassio > $ docker run busybox ping -c 1 192.203.230.10
Error: unknown command "$" for "hassio"
Run 'hassio --help' for usage.
FATA[0000] Error while executing rootCmd: unknown command "$" for "hassio"

hassio > login
# $ docker run busybox ping -c 1 192.203.230.10
/bin/ash: $: not found

Pinging any ip address from within hassos is unsuccessful

hassio > login
# ping 8.8.8.8
No response from 8.8.8.8

Though I’m not sure that really tells me much more than I already knew
Is there a standard method for troubleshooting DNS errors using hassos?

$ isn’t a command. That indicates you are at a prompt.

If you can’t ping an IP address, it has nothing to do with DNS. Pinging an IP doesn’t involve DNS at all.

Thanks for that. I’ve been successfully trying a few docker diagnostic commands. Again not sure what they tell me yet

docker run busybox ping 192.203.230.10
Unable to find image 'busybox:latest' locally
docker: Error response from daemon: Get https://registry-1.docker.io/v2/: dial tcp: lookup registry-1.docker.io on 192.168.1.1:53: read udp 192.168.1.103:54976->192.168.1.1:53: i/o timeout.

# nslookup index.docker.io
;; connection timed out; no servers could be reached

They are telling you the network is broken. Your device has no access to the outside world. It can’t ping an IP outside of it’s network (can you ping your router?), and it will never resolve any hostnames/DNS if you don’t fix the networking.