Invalid config for [script]: Integration

Tags: #<Tag:0x00007f3270b71070>

I’m literally pulling my hair out now so need to ask for help.

Today I upgraded to 0.117.5, running Home Assistant OS (HassOS 4.15) via Proxmox on an NUC. Been working great for a long time and upgraded for the Xbox integration with the new Xbox coming out yesterday.

For some reason HA refuses to recognise the scripts line in configuration.yaml with the following error message:

Logger: homeassistant.config
Source: config.py:415
First occurred: 2:02:32 (3 occurrences)
Last logged: 2:02:32

Invalid config for [script]: Integration ‘’ not found (See /config/configuration.yaml, line 10).

My config which worked before and comes back as valid config in server controls is as follows (Also with an empty scripts.yaml file):

homeassistant:
  customize: !include customize.yaml
script: !include scripts.yaml
group: !include groups.yaml
automation: !include automations.yaml
scene: !include scenes.yaml
notify: !include notifications.yaml

When I try to create a script anyway I get the following error message:

Message malformed: Integration ‘’ not found

I’ve rolled back via a snapshot with the same config file and scripts work correctly.

Really do not know what to do, unfortunately I’m not a coder but have managed tog et through researching the best I can and reading the forums but this doesn’t seem to be a common problem so would be really appreciative if anyone could help.

Thank you.

What line is line 10? If that’s your real config then scripts aren’t on line 10 so there may be something else wrong on line 10 that is causing script to not show as correct.

Also what is the error in the home-assistant.log file in your configuration folder? It might give more details.

I have the exact same problem although all the scripts are working and show up under scripts. When I comment out the import line the error goes away. Really strange.

Same issue for me. The scripts run but I receive an Error notification for that !include line.

Getting the same error “Message malformed: Integration ‘’ not found”