iOS app won't use Internal URL

I have been experiencing this as well. I can only hit the HA instance with WIFI off. It’s very weird. Nothing in the logs either.

My instance is using an external SSL provider and internally runs on port 443 so I can have a global URL (inside or outside).

Not sure if that has something to do with it… seems to have occured in one of the new updates of HA Companion.

Anybody get this to work yet? A little frustrating to have to disconnect from my home wifi to use the app at home. Unfortunately I haven’t had any luck.

I got mine working. Turned out to be an ATT IPv6 thing for me.

Thanks for the response @CCOSTAN unfortunately I turned IPv6 off on my router and that didn’t fix the issue. I will keep searching/testing different things out.

1 Like

I finally figured it out so in case someone else has this issue I’ll post. For some reason in the mobile app (at least for ios) I have always had my HA internal ip address listed as the internal connection and it worked just fine. So I am not sure exactly what changed but to fix the issue, I just used in the internal connection as well as the external connection and now it works just fine and I can connect to HA both on and off my wifi.

salok8228: Essentially, you are saying just always use your external address…which is exactly what this whole issue is about…If you want to use HAC, then you have to use your external address all the time because HAC never recognizes that it should use your internal address.

Yes that appears to be correct, sorry I should have reread the original post. The weird thing was my HAC used to use my internal IP address fine so I am not exactly sure what changed and this was literally just a couple of weeks ago. My issue was a little different than original post in that my app is indeed detecting that I am on my home lan and it does switch to the internal url, but it is unable to connect to my HA instance via the local IP because of the ssl error.

this is my situation too. after one of the recent updates, I am no longer able to access my home assistant instance via iPad or iPhone unless I use as both the internal and external url, or I get “the certificate for this server is invalid…” which means I can’t connect to my instance with internet down from my own wifi on my iPhone, only my computer. This really puts a damper on my cloudless smart home :expressionless:.

I tried this tutorial which seems to be a work around for now…


With the latest iOS app version, I can’t get the auto switching between internal and external URLs. It’s always stuck on the external connection.

This used to work quite reliably for me before. I have double checked the SSID set in the internal URL config too.

Anyone else having the same issue?


Try to delete ssid, add it again and refresh.

Yeah, I’ve tried this many times with no luck. Even tried reinstalling the app.

Is it working for you?

For me it is working, but I also had to allow this

1 Like

I know this thread is a bit old but i thought i’d make a note for anyone else having this issue.

I found that not only does location need to be set to always & local network enabled, but under location, precise Location MUST be enabled. Maybe this is documented somewhere but it took me many many hours to eventually try it and realize. I find it a bit odd on apple’s part, as i would have assumed precise location would have only included high precision GPS.

I’m always wondering why they’re not using the following method: (or give you the choice of this method)

STEPS: Connect to the local IP/server

  1. instant response? Connect
  2. no instant response? Connect to the remote URL

This is the least complex solution that has no device dependencies. If you always want the same type of access, don’t enter an internal IP so it will always go through the nabu casa cloud.

95% of the time using the HA app I will be at home. When I’m not inside my home I don’t mind waiting a few more seconds.

The method of matching a “local” SSID sounds interesting but is absolutely crazy if you don’t want HA to have access to my location, not even when I’m using it.

Can’t imagine that I’m the only one? :slight_smile:


That would be a much better solution. I rarely use the app outside of home and I don’t want to have location always on.

I did a sort of stupid workaround myself, I added my server twice in the app, one with only internal url and blank as external url then another instance but with urls reversed.

Now it will use the instance with internal url when at home and the rare occasions I use the app outside of home it’s a 3 finger swipe to change server to my other instance.